Download it now!
Bug 101842 - LO freezes while unsuccessfully searching for Firefox Themes
Summary: LO freezes while unsuccessfully searching for Firefox Themes
Status: RESOLVED DUPLICATE of bug 114731
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
5.3.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-09-01 11:45 UTC by Susobhan Ghosh
Modified: 2018-02-09 10:43 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Susobhan Ghosh 2016-09-01 11:45:10 UTC
Firefox themes doesn't return search results, and takes 5 minutes to show the error box. If I try to cancel the search, LO freezes. Even when the error box pops up, LO freezes, and I can only close LO by killing the process.

I am behind a proxy (with 443 open), and I have used firefox themes before behind the same proxy. I get a - 

"Neon returned NE_ERROR, http response status code was: 'SSL handshake failed: Connection reset by peer' " 

and 

"Neon returned NE_ERROR, http response status code was: 'Could not parse response status line'" 

error on cmd

Tested on Ubuntu 16.04 and 14.04

Version: 5.3.0.0.alpha0+
Build ID: 4a70eac6045c4d3d5773ad0807dcde5a25391836
CPU Threads: 4; OS Version: Linux 4.4; UI Render: default; 
Locale: en-IN (en_IN); Calc: group

and

Version: 5.3.0.0.alpha0+
Build ID: 07b25764a4c5479526951c0a0f8fbe4b43f4103e
CPU Threads: 8; OS Version: Linux 3.19; UI Render: default; 
Locale: en-US (en_US.UTF-8); Calc: group
Comment 1 Giuseppe Castagno (aka beppec56) 2016-09-03 15:06:03 UTC
@Susobhan Ghosh

can you enable the INFO log level for webdav: 
SAL_LOG="+INFO.ucb.ucb.webdav"
then attach the log you obtain on a Firefox search sequence?

Thanks
Comment 2 Jean-Baptiste Faure 2016-09-17 14:09:29 UTC
Reproducible with Version: 5.2.3.0.0+
Build ID: 8c20df32c8278bc4a076cef285db7788627f4c07
Threads CPU : 4; Version de l'OS :Linux 4.4; UI Render : par défaut; 
Ubuntu_16.04_x86-64
Locale : fr-FR (fr_FR.UTF-8); Calc: single

can't try with version 5.2.1.

and with Version: 5.3.0.0.alpha0+
Build ID: cea853720a66961ccd36246d67b26af23907de12
Threads CPU : 4; Version de l'OS :Linux 4.4; UI Render : par défaut; 
Ubuntu_16.04_x86-64
Locale : fr-FR (fr_FR.UTF-8); Calc: group

Best regards. JBF
Comment 3 Giuseppe Castagno (aka beppec56) 2016-09-17 16:09:52 UTC
I cannot reproduce with:

Version: 5.3.0.0.alpha0+
Build ID: 5b6185d27781d5876d1c6fb18d848a7babdfec88
CPU Threads: 8; OS Version: Linux 3.13; UI Render: default; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF-dbg, Branch:master, Time: 2016-09-16_23:49:25
Locale: en-US (en_US.UTF-8); Calc: group

@Jean-Baptiste:

when you have time, can you test with this daily version:
<http://dev-builds.libreoffice.org/daily/master/Linux-rpm_deb-x86_64@70-TDF-dbg/>

using the following command line:

SAL_LOG="-INFO-WARN+WARN.ucb.ucp.webdav+INFO.ucb.ucp.webdav" ./soffice 2>&1 > exec.log&

and attach the resulting log here?

Thanks.
Comment 4 Jean-Baptiste Faure 2016-09-17 16:50:20 UTC
Sorry, it was a misunderstanding of how to proceed in this personalization dialog from my side: I was believing I had to paste the URL of Firefox themes (https://addons.mozilla.org/fr/firefox/themes/) in the search field. In fact you have only to click on a category button and wait. LO 5.2 does not find anything but it works in the master.
That said I got a crash when switching from a category to another.

Set back to unconfirmed.

Best regards. JBF
Comment 5 Buovjaga 2016-10-08 19:09:16 UTC
Let's set to needinfo until we hear from Susobhan.
Comment 6 QA Administrators 2017-05-02 11:36:50 UTC Comment hidden (obsolete)
Comment 7 QA Administrators 2017-05-31 10:46:08 UTC Comment hidden (obsolete)
Comment 8 Kevin Suo 2018-02-06 09:09:44 UTC
See also:
https://www.libreofficechina.org/thread-1800-1-1.html
Comment 9 Kevin Suo 2018-02-07 02:42:24 UTC
Steps to Reproduce:
1. Goto "Tools > Options > Personalization > Own Theme > Select Theme".
2. Click on any of the Categories.
--> Showing "Searching, please wait...", without returning anything for two minums.
3. Click "Cancel".
--> LibreOffice hangs up.

[suokunlong@x230i lo-linux-dbgutil-daily]$ ./opt/program/soffice
warn:vcl.gdi:9390:9390:vcl/headless/svpgdi.cxx:239: non default depth bitmap, slow convert, upscale the input
(pkix_CacheCert_Add: PKIX_PL_HashTable_Add for Certs skipped: entry existed
(pkix_CacheCert_Add: PKIX_PL_HashTable_Add for Certs skipped: entry existed
(pkix_CacheCert_Add: PKIX_PL_HashTable_Add for Certs skipped: entry existed
(pkix_CacheCert_Add: PKIX_PL_HashTable_Add for Certs skipped: entry existed
(pkix_CacheCert_Add: PKIX_PL_HashTable_Add for Certs skipped: entry existed
warn:ucb.ucp.webdav:9390:9424:ucb/source/ucp/webdav-neon/NeonSession.cxx:1816: Neon returned NE_ERROR, http response status code was: 0 'Could not parse response status line'
(pkix_CacheCert_Add: PKIX_PL_HashTable_Add for Certs skipped: entry existed
(pkix_CacheCert_Add: PKIX_PL_HashTable_Add for Certs skipped: entry existed
(pkix_CacheCert_Add: PKIX_PL_HashTable_Add for Certs skipped: entry existed
(pkix_CacheCert_Add: PKIX_PL_HashTable_Add for Certs skipped: entry existed
(pkix_CacheCert_Add: PKIX_PL_HashTable_Add for Certs skipped: entry existed
(pkix_CacheCert_Add: PKIX_PL_HashTable_Add for Certs skipped: entry existed
(pkix_CacheCert_Add: PKIX_PL_HashTable_Add for Certs skipped: entry existed
(pkix_CacheCert_Add: PKIX_PL_HashTable_Add for Certs skipped: entry existed
(pkix_CacheCert_Add: PKIX_PL_HashTable_Add for Certs skipped: entry existed
(pkix_CacheCert_Add: PKIX_PL_HashTable_Add for Certs skipped: entry existed
(pkix_CacheCert_Add: PKIX_PL_HashTable_Add for Certs skipped: entry existed
(pkix_CacheCert_Add: PKIX_PL_HashTable_Add for Certs skipped: entry existed
(pkix_CacheCert_Add: PKIX_PL_HashTable_Add for Certs skipped: entry existed
(pkix_CacheCert_Add: PKIX_PL_HashTable_Add for Certs skipped: entry existed
(pkix_CacheCert_Add: PKIX_PL_HashTable_Add for Certs skipped: entry existed
^C

Set to NEW.
Comment 10 Kevin Suo 2018-02-07 02:43:30 UTC
(In reply to Kevin Suo from comment #9)
This test is done in
Version: 6.1.0.0.alpha0+
Build ID: 715114595e0feec49c4d54cc5eb26f13dccb7968
CPU threads: 4; OS: Linux 4.14; UI render: default; VCL: gtk3; 
Locale: zh-CN (zh_CN.UTF-8); Calc: group

My ip address is 121.101.208.18 in Beijing, China.
Comment 11 Kevin Suo 2018-02-07 02:51:10 UTC
This bug is similar with bug 114739, and that one was marked as a duplicate of bug 99837. But they may be different issue. 

Those two bugs (114739 and 99837) are related to the crash after you select a theme, but this bug is about the hang when you click the categories button (at this moment no theme is shown on the UI).
Comment 12 Jean-Baptiste Faure 2018-02-08 21:59:51 UTC
Please try a more recent build of the master, one that contains the commit fixing bug 114731.

Best regards. JBF
Comment 13 Xisco Faulí 2018-02-09 10:43:27 UTC
Setting as dupe of bug 114731.
Please, reopen it if the issue is still reproducible with a build containing the fix in bug 114731

*** This bug has been marked as a duplicate of bug 114731 ***