Bug 101866 - Some strings copied in formula groups of simple references get upper-cased
Summary: Some strings copied in formula groups of simple references get upper-cased
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
5.1.0.0.alpha0+ Master
Hardware: All All
: medium normal
Assignee: Tor Lillqvist
URL:
Whiteboard: target:5.3.0 target:5.2.2 target:5.1.6
Keywords:
: 101515 (view as bug list)
Depends on:
Blocks: OpenCL
  Show dependency treegraph
 
Reported: 2016-09-02 18:08 UTC by Tor Lillqvist
Modified: 2016-09-12 15:23 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Bugdoc (379.67 KB, application/vnd.oasis.opendocument.spreadsheet)
2016-09-02 18:08 UTC, Tor Lillqvist
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Tor Lillqvist 2016-09-02 18:08:08 UTC
Created attachment 127128 [details]
Bugdoc

See attached document. Some of the strings in sheet Hymns, from B508 downwards, are wrongly upper-cased. The formulas in this formula group are simple references, and in the case where they reference to a cell that it itself the result of a formula, the result gets upper-cased.
Comment 1 Commit Notification 2016-09-02 18:20:17 UTC
Tor Lillqvist committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=326da3886e6f700ad1fb269df201fae9fa01d5df

tdf#101866: Get rid of two more erroneous upper-casings of strings

It will be available in 5.3.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 2 Tor Lillqvist 2016-09-02 18:28:42 UTC
Forgot to mention in initial comment that this happens when the so-called software interpreter is used.
Comment 3 Commit Notification 2016-09-02 20:07:59 UTC
Tor Lillqvist committed a patch related to this issue.
It has been pushed to "libreoffice-5-2":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=36ee7be1e3e34b8eb07de1fc5e7f9f3681e58173&h=libreoffice-5-2

tdf#101866: Get rid of two more erroneous upper-casings of strings

It will be available in 5.2.2.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 4 Commit Notification 2016-09-02 20:09:32 UTC
Tor Lillqvist committed a patch related to this issue.
It has been pushed to "libreoffice-5-1":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=f87b678a40ab73402366f409078f20425f258953&h=libreoffice-5-1

tdf#101866: Get rid of two more erroneous upper-casings of strings

It will be available in 5.1.6.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 5 Eike Rathke 2016-09-03 10:00:12 UTC
*** Bug 101515 has been marked as a duplicate of this bug. ***