Download it now!
Bug 101890 - Save to PPT fails
Summary: Save to PPT fails
Status: RESOLVED INSUFFICIENTDATA
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
5.2.0.4 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-09-04 10:22 UTC by Erez Hadad
Modified: 2017-05-02 11:34 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Erez Hadad 2016-09-04 10:22:48 UTC
This seems to be a re-surface of 51179, same scenario.
Comment 1 V Stuart Foote 2016-09-04 13:37:58 UTC
Can not confirm on Windows 10 Pro 64-bit en-US with
Version: 5.2.1.2 (x64)
Build ID: 31dd62db80d4e60af04904455ec9c9219178d620
CPU Threads: 8; OS Version: Windows 6.19; UI Render: default; 
Locale: en-US (en_US); Calc: group

Please provide a test ODG that is failing filter saveas to MSOffice 97-2003 PPT format and complete steps to reproduce.

Also, a four year old isuue like bug 51179 does not provide test case nor is it likely relevant to your new issue.
Comment 2 Erez Hadad 2016-09-04 17:42:13 UTC
Confirmed on Ubuntu 14.04.5 and Ubuntu 16.04.1 on x86-64, using both LibreOffice 5.2.0.4 and 5.2.1.2 installed from the LibreOffice PPA.
Multiple computers with different versions listed above, same result. The issue is reproduced by opening an ODP and trying to save it as PPT (nor PPTX).
The message is exactly as reported in the first comment of 51179.
Comment 3 Aron Budea 2016-09-05 07:05:35 UTC
No repro with v5.2.0.4 (TDF build) / Ubuntu 16.04.
Does it happen with any ODP for you?

As Stuart wrote, the error message is too general to imply any kind of connection with bug 51179.
Comment 4 Erez Hadad 2016-09-05 07:15:42 UTC
I can try purge and re-install of packages to make sure it's not a configuration problem. Given that I tested on multiple machines, this is not very likely.
Comment 5 Erez Hadad 2016-09-05 07:20:53 UTC
Another common property of all the machines is setup with non-default locale. Specifically, LANG is set to en_US.UTF-8 and there is a secondary Hebrew language installed after the primary English. Also, the regional data (currency, date/time etc) is set to Hebrew format, e.g., LC_TIME = he_IL.UTF_8. Can anyone confirm in this setup?
Comment 6 Erez Hadad 2016-09-05 09:38:43 UTC
UPDATE: I downloaded a random ODP from the net (http://www.openoffice.org/marketing/ooocon2008/programme/friday_1484.odp), tried to save it as PPT using LibreOffice 5.2.1.2 on both Ubuntu 16.04.1 and 14.04.5 - and IT WORKED (with the exception of a few missing images on slides). 
This is much better than where I got to before.

So, I think this has something to do with the locale. I can load ODP presentations that I created on my machines (see locale setting in above comments) but I cannot save them as PPT.
Given the sensitivity (private and commercial) of the material in the presentations, I cannot share them as test material for others to confirm. Is there a test machine where someone can install a locale setting like mine with LibreOffice 5.2.0.4 or 5.2.1.2 and try to confirm this issue?
Comment 7 Buovjaga 2016-09-24 18:57:32 UTC
Why not create a simple test document that shows the problem?

Set to NEEDINFO.
Change back to UNCONFIRMED after you have provided the document.
Comment 8 QA Administrators 2017-03-28 08:17:49 UTC Comment hidden (obsolete)
Comment 9 QA Administrators 2017-05-02 11:34:13 UTC
Dear Bug Submitter,

Please read this message in its entirety before proceeding.

Your bug report is being closed as INSUFFICIENTDATA due to inactivity and
a lack of information which is needed in order to accurately
reproduce and confirm the problem. We encourage you to retest
your bug against the latest release. If the issue is still
present in the latest stable release, we need the following
information (please ignore any that you've already provided):

a) Provide details of your system including your operating
   system and the latest version of LibreOffice that you have
   confirmed the bug to be present

b) Provide easy to reproduce steps – the simpler the better

c) Provide any test case(s) which will help us confirm the problem

d) Provide screenshots of the problem if you think it might help

e) Read all comments and provide any requested information

Once all of this is done, please set the bug back to UNCONFIRMED
and we will attempt to reproduce the issue. Please do not:

a) respond via email 

b) update the version field in the bug or any of the other details
   on the top section of our bug tracker

Warm Regards,
QA Team

MassPing-NeedInfo-20170502