Download it now!
Bug 101899 - UI: Widget background color inconsistent GTK3 in Ubuntu
Summary: UI: Widget background color inconsistent GTK3 in Ubuntu
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
5.2.0.0.alpha0+
Hardware: All Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-09-05 02:39 UTC by Luke
Modified: 2016-11-14 09:50 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Screenshot of the toolbar issue (48.85 KB, image/png)
2016-09-05 02:39 UTC, Luke
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Luke 2016-09-05 02:39:27 UTC
Created attachment 127150 [details]
Screenshot of the toolbar issue

Steps to Reproduce:
1. With Ubuntu 16.04, create a new document
2. Insert shape
3. Click on it

Expected Results:
All toolbar foreground and background colors are consistent

Actual Results:
'Line Style', 'Line Width', and 'Area Style/Filling' use a totally different theme than all the other toolbar items.
Comment 1 Jean-Baptiste Faure 2016-09-05 04:52:10 UTC
Hi Luke, what is your version of LibreOffice?

Your screenshot shows that the issue is not the background of the toolbar but the background of some widgets like area color. I reproduce this behavior with LO 5.2 under Ubuntu 16.04 x86-64
Note : with GTK2, LO is not able to paint the background of toolbars.

Best regards. JBF
Comment 2 Luke 2016-09-08 06:01:17 UTC
Yes, you have to use the default GTK3 backend. 

I roll my own builds. The earliest build that I have is 
Version: 5.2.0.0.alpha0+
Build ID: e4d5b5efac71ed2a08dcd09877078a6cf6bde0d2

My most recent build Version: 5.3.0.0.alpha0+
Build ID: 619d5fceada2df7c7bc915cea51779fd115d0fcd

They are both affected by this bug. Is there anything else you need?
Comment 3 Jean-Baptiste Faure 2016-09-11 07:52:33 UTC
Confirmed. Setting as NEW.
Updated summary: toolbar backgroung -> widget background
OS -> Linux.
Version -> 5.2.0.0.alpha0+

Best regards. JBF
Comment 4 Björn Michaelsen 2016-09-12 06:34:33 UTC
This should be solved with downstream packaging in LibreOffice 1:5.2.1~rc2-0ubuntu1 and the matching update in ubuntu-themes 16.10+16.10.20160908-0ubuntu1.

See: https://bugs.launchpad.net/ubuntu/+source/libreoffice/+bug/1580537

The LibreOffice vendor patch hasnt been upstreamed yet as this is an Ubuntu only issue. Marking this WORKSFORME for now.

If there are no objection to upstream a vendor specific fix, I'll push it to upstream too.
Comment 5 Luke 2016-11-13 21:15:31 UTC
Björn Michaelsen,
This has been closed, but it's still affecting current builds. Could you please push your fix upstream?
Comment 6 Luke 2016-11-14 03:08:35 UTC
git master still has this issue on 16.10, 16.04, 14.04.
Comment 7 Björn Michaelsen 2016-11-14 09:50:29 UTC
(In reply to Luke from comment #5)
> This has been closed, but it's still affecting current builds. Could you
> please push your fix upstream?

No: The vendor patch is _both_ in LibreOffice and in Ubuntu themes. As such it wont work for upstream.