Bug 101911 - Calc: Add continuous page numbers on PDF export with different page styles
Summary: Calc: Add continuous page numbers on PDF export with different page styles
Status: RESOLVED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-09-05 17:01 UTC by Timur
Modified: 2016-09-21 07:08 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
test file (8.28 KB, application/vnd.oasis.opendocument.spreadsheet)
2016-09-06 04:50 UTC, Cor Nouws
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Timur 2016-09-05 17:01:53 UTC
In Writer, we can use Manual Break to change page orientation, while keeping page numbers continuous.

In Calc, we should also be able to get continuous page numbers on PDF export if there's different page i.e. sheet orientation.

Explanation: Supposing a solution for changing sheet orientation is new page style, than page numbering starts from 1. It can be manually started from some number, but each orientation change has the same problem, so it's not practical. If we have, for example, sheets with P, P, L, P, P, L, L, P (portrait/landscape) it doesn't make sense to manually change page number.
Comment 1 Cor Nouws 2016-09-05 18:51:40 UTC
Hi Timur,

No printer at hand here, but isn't the same problem applying to printing?
Comment 2 m.a.riosv 2016-09-05 22:56:43 UTC
As commented only one page style by sheet, so orientation change needs change the sheet.

To have a continuous pagination with PDF export, it's simple and possible selecting the sheets to print with Ctrl-click on the tab of sheets to print, and marking selection on the main tab in export PDF.

At least it works fine for me.

What it's really annoying it's that selection it's not default in PDF, making easy to export everything in the spreadsheet without want.

But I think not a bug.
Comment 3 Cor Nouws 2016-09-06 04:50:17 UTC
Created attachment 127166 [details]
test file

(In reply to m.a.riosv from comment #2)

> To have a continuous pagination with PDF export, it's simple and possible
> selecting the sheets to print with Ctrl-click on the tab of sheets to print,
> and marking selection on the main tab in export PDF.

But then still, page numbering start again on the sheet where there is another page style selected.
Comment 4 m.a.riosv 2016-09-06 08:32:13 UTC
(In reply to Cor Nouws from comment #3)
... marking selection on the main tab in export PDF.
> 
> But then still, page numbering start again on the sheet where there is
> another page style selected.

Don't forget to unmark the option in page styles for 'first page number' on 'Sheet' tab. Doing that works fine for me. :)
Comment 5 Cor Nouws 2016-09-06 08:58:58 UTC
(In reply to m.a.riosv from comment #4)

> Don't forget to unmark the option in page styles for 'first page number' on
> 'Sheet' tab. Doing that works fine for me. :)

Thanks - you're the expert here :)
Comment 6 Timur 2016-09-13 08:30:15 UTC
Olivier, it would be useful to add this somewhere in Help, because it's not so obvious. 
This may exceed current Help scope, but I think that should be generally welcomed, to clarify some usages.


For example, in https://help.libreoffice.org/index.php?title=5.1/Calc/Sheet_3&Language=en-US, on the bottom of Page Order:

Note: In order to have continuous page numbers on PDF export or print with different page styles, such as for different sheet orientation, one can create new Portrait and Landscape page styles with 'First page number' unmarked and use them for all pages except the first one that uses Default page style.
Comment 7 Olivier Hallot 2016-09-13 08:55:33 UTC
(In reply to Timur from comment #6)
> Olivier, it would be useful to add this somewhere in Help, because it's not
> so obvious. 
> This may exceed current Help scope, but I think that should be generally
> welcomed, to clarify some usages.
> 
> 
> For example, in
> https://help.libreoffice.org/index.php?title=5.1/Calc/Sheet_3&Language=en-US,
> on the bottom of Page Order:
> 
> Note: In order to have continuous page numbers on PDF export or print with
> different page styles, such as for different sheet orientation, one can
> create new Portrait and Landscape page styles with 'First page number'
> unmarked and use them for all pages except the first one that uses Default
> page style.

Please open a new bug for the help part of this bug and make it a blocker of bug#80430. Add all info possible to the bug to easy fixing it.Thanks
Comment 8 Timur 2016-09-21 07:08:51 UTC
NotABug indicating it is reported correctly, but it works properly, just not being obvious. It could always be a hint that Help might be amended.