Bug 101952 - UI bug when switching "Maximize" and "Unmaximize" when using gen/X11 backend
Summary: UI bug when switching "Maximize" and "Unmaximize" when using gen/X11 backend
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: x86-64 (AMD64) Linux (All)
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 102270 103598 (view as bug list)
Depends on:
Blocks: Maximized-Window
  Show dependency treegraph
 
Reported: 2016-09-07 00:36 UTC by Jason
Modified: 2021-02-02 17:10 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Screenshot (116.91 KB, image/png)
2016-09-07 00:36 UTC, Jason
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jason 2016-09-07 00:36:13 UTC
Created attachment 127184 [details]
Screenshot
Comment 1 Buovjaga 2016-09-29 19:32:27 UTC
For me, the problem manifests in black area in the top and left of the window, growing in size with each max/unmax.

I'm pretty sure this is a regression, so adding keywords..

Version: 5.2.1.2
Build ID: 1:5.2.1~rc2-0ubuntu1~xenial0
CPU Threads: 4; OS Version: Linux 4.4; UI Render: default; 
Locale: fi-FI (en_US.UTF-8); Calc: group
Comment 2 Xisco Faulí 2016-10-01 15:11:52 UTC
I can't reproduce any of the problems described in

Version: 5.3.0.0.alpha0+
Build ID: 33a2e47c907f7e2c1995b4a1e910dec94c3cedb4
CPU Threads: 4; OS Version: Linux 4.2; UI Render: default; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group
Comment 3 Buovjaga 2016-10-10 11:54:51 UTC
I noticed I didn't have libreoffice-gtk3 installed. After I installed it, the problem went away.
Comment 4 Maxim Monastirsky 2016-10-31 12:51:33 UTC
*** Bug 103598 has been marked as a duplicate of this bug. ***
Comment 5 Ole Holte Sandvik 2016-11-02 10:02:09 UTC
*** Bug 102270 has been marked as a duplicate of this bug. ***
Comment 6 Aron Budea 2016-12-28 02:37:44 UTC
Already occurs in 3.3.0 / Ubuntu 16.04. Not a regression.
Reproduced with: SAL_USE_VCLPLUGIN=gen ./soffice
Comment 7 QA Administrators 2017-12-29 03:28:44 UTC Comment hidden (obsolete)
Comment 8 mattia.b89 2019-02-02 22:03:52 UTC
Cannot reproduce it, in:

Version: 6.1.4.2
Build ID: 6.1.4-4
CPU threads: 4; OS: Linux 4.20; UI render: default; VCL: gtk3; 
Locale: it-IT (en_GB.UTF-8); Calc: group threaded
Comment 9 QA Administrators 2021-02-02 03:49:55 UTC
Dear Jason,

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

Test to see if the bug is still present with the latest version of LibreOffice from https://www.libreoffice.org/download/

If the bug is present, please leave a comment that includes the information from Help - About LibreOffice.
 
If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a comment that includes the information from Help - About LibreOffice.

Please DO NOT

Update the version field
Reply via email (please reply directly on the bug tracker)
Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not 
appropriate in this case)


If you want to do more to help you can test to see if your issue is a REGRESSION. To do so:
1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3) from https://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug
3. Leave a comment with your results.
4a. If the bug was present with 3.3 - set version to 'inherited from OOo';
4b. If the bug was not present in 3.3 - add 'regression' to keyword


Feel free to come ask questions or to say hello in our QA chat: https://kiwiirc.com/nextclient/irc.freenode.net/#libreoffice-qa

Thank you for helping us make LibreOffice even better for everyone!

Warm Regards,
QA Team

MassPing-UntouchedBug