Bug Hunting Session
Bug 101953 - Controls in the dialog Bullets and Numbering, tab Options, become wider/smaller when switching from numbers to graphics
Summary: Controls in the dialog Bullets and Numbering, tab Options, become wider/small...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
4.1.6.2 release
Hardware: All All
: medium normal
Assignee: Caolán McNamara
URL:
Whiteboard: target:5.3.0 target:5.2.3
Keywords: regression
Depends on:
Blocks: Dialog
  Show dependency treegraph
 
Reported: 2016-09-07 02:00 UTC by Yousuf Philips (jay) (retired)
Modified: 2016-10-06 14:44 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Yousuf Philips (jay) (retired) 2016-09-07 02:00:31 UTC
Steps:
1) Open writer
2) Format > Bullet and Numbering > Options
3) Set Numbers to Graphic and notice how the controls in the 2nd column increase in width

Regression caused by the dialog being converted to Glade.

Version: 5.3.0.0.alpha0+
Build ID: f7513f0f53f2d074c08610a68fb787bb379c31d4
CPU Threads: 2; OS Version: Linux 3.19; UI Render: default; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2016-09-02_23:58:05
Locale: en-US (en_US.UTF-8); Calc: group
Comment 1 Xisco Faulí 2016-09-12 12:45:14 UTC
Adding keyword 'bibisectRequest'.
Comment 2 Commit Notification 2016-10-03 20:27:01 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=d2e69a61a3e3b962cddf576558f1412c7baacd06

Resolves: tdf#101953 controls become wider/smaller switching to/from graphics

It will be available in 5.3.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 3 Yousuf Philips (jay) (retired) 2016-10-04 04:15:02 UTC
Thanks for backporting Caolan.

https://gerrit.libreoffice.org/#/c/29513/
Comment 4 Commit Notification 2016-10-06 14:44:11 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-5-2":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=375c4c788db61ac7b34e07ce2402a329e3d83de3&h=libreoffice-5-2

Resolves: tdf#101953 controls become wider/smaller switching to/from graphics

It will be available in 5.2.3.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.