Bug 101987 - Spellcheck dialog freezes for several seconds for every action chosen during Spelling Dialogue
Summary: Spellcheck dialog freezes for several seconds for every action chosen during ...
Status: RESOLVED DUPLICATE of bug 105426
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
5.2.1.2 release
Hardware: All Windows (All)
: medium major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: perf
Depends on:
Blocks:
 
Reported: 2016-09-08 08:55 UTC by MICHAEL TUCK
Modified: 2017-03-26 01:13 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Example spreadsheet (53.02 KB, application/vnd.oasis.opendocument.spreadsheet)
2017-03-18 19:43 UTC, Joel M
Details

Note You need to log in before you can comment on or make changes to this bug.
Description MICHAEL TUCK 2016-09-08 08:55:57 UTC
For Calc & Writer I find Spelling Dialogue freezes for many seconds at every stage (Correct/Ignore/Add to Dictionary)
Comment 1 Buovjaga 2016-09-30 19:20:58 UTC
Which operating system are you using?

Set to NEEDINFO.
Change back to UNCONFIRMED after you have provided the information.
Comment 2 Joel M 2017-03-18 19:41:36 UTC
I also experience this bug in LibreOffice Calc 5.3.0.3 (x64) under Windows 10. Symptoms are as described in https://bugs.documentfoundation.org/show_bug.cgi?id=93586, which may make these the same problem, with the exceptions that I get this in Calc (it's not nearly as bad in Writer), and I'm using Arial for the font.

I'm attaching the .ods I'm experiencing this on.
Comment 3 Joel M 2017-03-18 19:43:08 UTC
Created attachment 131992 [details]
Example spreadsheet

I experience the bug using this Calc file on Windows 10, LO v5.3.0.3 (x64).
Comment 4 Buovjaga 2017-03-19 17:32:14 UTC
NEW per comment 2
Comment 5 Adolfo Jayme 2017-03-26 01:13:52 UTC
This should be solved in 5.3.1 with https://cgit.freedesktop.org/libreoffice/core/commit/?h=libreoffice-5-3-1&id=53b186d85894c2c41afc025bda459db5cc6ef452

*** This bug has been marked as a duplicate of bug 105426 ***