Bug Hunting Session
Bug 102030 - Unable to open Recent Files and Templates split menu in Start Center
Summary: Unable to open Recent Files and Templates split menu in Start Center
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
4.4.7.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: accessibility
Depends on:
Blocks: Start-Center a11y
  Show dependency treegraph
 
Reported: 2016-09-09 21:32 UTC by Yousuf Philips (jay) (retired)
Modified: 2017-11-27 18:20 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Yousuf Philips (jay) (retired) 2016-09-09 21:32:39 UTC
Steps:
1) Open Start Center
2) Press tab to till focus is on the Recent Files or Templates split button
3) Pressing spacebar activates the main part of the button but the down arrow key doesnt expand the menu part, similar to how it does in the toolbar

Version: 5.3.0.0.alpha0+
Build ID: f7513f0f53f2d074c08610a68fb787bb379c31d4
CPU Threads: 2; OS Version: Linux 3.19; UI Render: default; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2016-09-02_23:58:05
Locale: en-US (en_US.UTF-8); Calc: group
Comment 1 Aron Budea 2016-09-12 01:41:05 UTC
It's even worse in Windows, Tab doesn't work at all. Should I open a separate bug report for that?
Comment 2 Aron Budea 2016-09-12 01:45:45 UTC
To be precise, it's just that initially the focus is nowhere. Tabbing works after setting focus somewhere.

I can confirm the behavior mentioned in the description with 5.3 master build / Windows 7 after setting initial focus in the list.
Comment 3 Yousuf Philips (jay) (retired) 2016-09-12 04:14:32 UTC
(In reply to Aron Budea from comment #2)
> To be precise, it's just that initially the focus is nowhere. Tabbing works
> after setting focus somewhere.

Yes a new bug exclusive to windows should be filed, as Open File is supposed to be set focus, like it is on linux. CC steve so he can check if its a problem on mac as well.
Comment 4 QA Administrators 2017-11-17 09:10:05 UTC Comment hidden (obsolete)
Comment 5 Alex ARNAUD 2017-11-27 15:54:06 UTC
(In reply to Yousuf Philips (jay) from comment #0)
> Steps:
> 1) Open Start Center
> 2) Press tab to till focus is on the Recent Files or Templates split button
> 3) Pressing spacebar activates the main part of the button but the down
> arrow key doesnt expand the menu part, similar to how it does in the toolbar

Hello Yousuf,

On LibreOfficeDev 6.1 from 2017-11-26 when I press spacebar on Recent files or templates the focus switch from the left side to the right side. So for example when I press space bar on recent files I move on the recent files list.
To open the related menu to the recent files I have to press alt+down arrow, I assume that it is a GTK behavior.

I don't understand precisely if what I've experienced is the same as you.

Best regards.
Comment 6 Yousuf Philips (jay) (retired) 2017-11-27 18:20:34 UTC
(In reply to Alex ARNAUD from comment #5)
> On LibreOfficeDev 6.1 from 2017-11-26 when I press spacebar on Recent files
> or templates the focus switch from the left side to the right side. So for
> example when I press space bar on recent files I move on the recent files
> list.

Yes the is the correct behaviour for spacebar.

> To open the related menu to the recent files I have to press alt+down arrow,
> I assume that it is a GTK behavior.

I guess this is the correct behaviour, because up and down also acts like tab and shift+tab to go between the buttons.