Bug Hunting Session
Bug 102050 - Insert image with custom style does not work
Summary: Insert image with custom style does not work
Status: RESOLVED DUPLICATE of bug 79160
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.3.0.0.alpha0+
Hardware: x86 (IA32) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-09-10 17:43 UTC by Regina Henschel
Modified: 2016-09-13 11:38 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Screenshot of the file select dialog (127.80 KB, image/png)
2016-09-10 17:43 UTC, Regina Henschel
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Regina Henschel 2016-09-10 17:43:44 UTC
Created attachment 127249 [details]
Screenshot of the file select dialog

1. Start a Writer document.

2. Insert a small image. It will be anchored to paragraph and aligned centered. Set its anchor to "as character".

3. While the image is selected create a new frame style, by clicking on the "+style" button. Name it e.g. "ImageAsCharacter". Make sure in its organizer tab, that it has the setting "as character".

4. Insert a next small image. Again it will be anchored to paragraph. Apply the newly created style "ImageAsCharacter" to make sure, that the style works as intended. The image will change its anchor to "as character".

5. Insert a next small image. But now do it different. Find the "Style" drop-down list in the file selection dialog. Open it and select the new style "ImageAsCharacter". Expected behavior: The image is inserted having the style "ImageAsCharacter" applied and therefore is anchored as character. Seen behavior: The image gets the default style "Graphics".
Comment 1 V Stuart Foote 2016-09-10 21:37:21 UTC
On Windows 10 Pro 64-bit en-US

with either
Version: 5.2.1.2 (x64)
Build ID: 31dd62db80d4e60af04904455ec9c9219178d620
CPU Threads: 8; OS Version: Windows 6.19; UI Render: GL; 
Locale: en-US (en_US); Calc: group

or
Version: 5.3.0.0.alpha0+
Build ID: 681d5fd37e469491268d40147c621187dc6f4b95
CPU Threads: 8; OS Version: Windows 6.19; UI Render: GL; 
TinderBox: Win-x86@42, Branch:master, Time: 2016-09-10_06:06:09
Locale: en-US (en_US); Calc: CL

Using LibreOffice dialogs, this seems to behave correctly.  The Insert -> Image using "Style" drop down and selecting a newly created custom style "ImageAsCharacter" from the list as described.

When the list opens it does show "Graphic" as the default choice, but the dropdown does seem to select sytle, and the style does seem to apply with anchor to character asserted.
Comment 2 Cor Nouws 2016-09-12 19:22:38 UTC
I thought there was already this or another issue, where selecting a style was only possible from the LibreOffice dialog, or somesuch...
Comment 3 Cor Nouws 2016-09-13 11:38:44 UTC
(In reply to Cor Nouws from comment #2)
> I thought there was already this or another issue, where selecting a style
> was only possible from the LibreOffice dialog, or somesuch...

Ah :) 79160

*** This bug has been marked as a duplicate of bug 79160 ***