Bug 102060 - Modifying effect or options returns focus to slide after preview
Summary: Modifying effect or options returns focus to slide after preview
Status: RESOLVED DUPLICATE of bug 115691
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
4.3.0.4 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: accessibility, bibisected, regression
Depends on:
Blocks: a11y
  Show dependency treegraph
 
Reported: 2016-09-11 15:56 UTC by Yousuf Philips (jay) (retired)
Modified: 2018-02-22 22:24 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
sample (11.78 KB, application/vnd.oasis.opendocument.presentation)
2016-09-11 16:09 UTC, Yousuf Philips (jay) (retired)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Yousuf Philips (jay) (retired) 2016-09-11 15:56:48 UTC
Steps:
1) open attached file
2) switch to custom animation deck of sidebar
3) make sure automatic preview is checked
4) change the direction
5) press up key and notice that it moves the title textbox up

Regression as this doesnt happen in 4.2.

Version: 5.3.0.0.alpha0+
Build ID: f7513f0f53f2d074c08610a68fb787bb379c31d4
CPU Threads: 2; OS Version: Linux 3.19; UI Render: default; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2016-09-02_23:58:05
Locale: en-US (en_US.UTF-8); Calc: group
Comment 1 Yousuf Philips (jay) (retired) 2016-09-11 16:09:24 UTC
Created attachment 127260 [details]
sample
Comment 2 Aron Budea 2016-09-11 16:17:33 UTC
Confirmed in 4.3.0.4 / Windows 7.
Works in 4.2.0.4.
Comment 3 Aron Budea 2016-09-11 16:57:50 UTC
This was awful... many, many commits to skip (Impress didn't start), first bad commit could not be uniquely identified, unfortunately.

# bad: [74b89c3193673ba9897dc4a4541500ef6e8d9bf7] source-hash-8f97326bdd3f42fc82aa5e1989fd03b0af1daf64
# good: [9c392cfdfe6e9a9bce98555ea989283a957aa3ad] source-hash-fc8f44e82de4ebdd50ac5fbb9207cd1a59a927e3
git bisect start 'latest' 'oldest'
# bad: [e289d9d328719fd70e9a2680fd0e4f586a97b3be] source-hash-3c0a7cf4f67720f2cca2c4eb543f838d5b644e7f
git bisect bad e289d9d328719fd70e9a2680fd0e4f586a97b3be
# bad: [0327d0bc45d60df0d1c8ac2470cf252b6bb8f780] source-hash-38fed70782ae6ac6b0282897c7abc6fa33a6de9e
git bisect bad 0327d0bc45d60df0d1c8ac2470cf252b6bb8f780
# bad: [130c0f90cdc74b7300c74ee7d49c459ea8b8c4f4] source-hash-4a969ac35174520f1ffeb4f919f5d7bb6d99a628
git bisect bad 130c0f90cdc74b7300c74ee7d49c459ea8b8c4f4
# bad: [a4ca1d9431eedeb3ce6b22b96cfabc5ccc3cb857] source-hash-c85f1ed54f64bb7c7d309ec87df9ce8027a4a108
git bisect bad a4ca1d9431eedeb3ce6b22b96cfabc5ccc3cb857
# bad: [b41194f886e84e8427e7c389e7cd8e66b888372a] source-hash-0379f8b6393e99667584a2964bedf82e4306c2fa
git bisect bad b41194f886e84e8427e7c389e7cd8e66b888372a
# skip: [45dfd25d60c9d931c1d173f3fddd6317b3df5235] source-hash-871d8e0f278dab646e1877a505577edc730a26cf
git bisect skip 45dfd25d60c9d931c1d173f3fddd6317b3df5235
# good: [719ddcfa306f2e1a958505cf936c2d2662ffe41a] source-hash-1da6609eb8d3d70bb620d949b1935a5789c2d2ce
git bisect good 719ddcfa306f2e1a958505cf936c2d2662ffe41a
# skip: [726a0f19f9ead231a1853e059622343e19234dd7] source-hash-a66090955f9e05905417660fc14e91b352f304d2
git bisect skip 726a0f19f9ead231a1853e059622343e19234dd7
# good: [46524fc9017498c88c1ce286f3cff3fa3d74d7bb] source-hash-b669e31252afe0c94e69e3959988e04ecdbaeafd
git bisect good 46524fc9017498c88c1ce286f3cff3fa3d74d7bb
# good: [64300cf3b8362398640a33f1aee2dd7f1fdf1d1f] source-hash-c0afa5b7ff135b1173f1cb55c564e88a82e702c4
git bisect good 64300cf3b8362398640a33f1aee2dd7f1fdf1d1f
# skip: [0c4b91e14fa2d5f481d1fe524f14f31a318ae740] source-hash-80ae9161ff231908431b6ee6471bd5363425ff26
git bisect skip 0c4b91e14fa2d5f481d1fe524f14f31a318ae740
# skip: [fab017f58669df271efb76738b0a86246f3baf1b] source-hash-efcc8ddd213e7f7a341526bdcffcee75d8fef77f
git bisect skip fab017f58669df271efb76738b0a86246f3baf1b
# bad: [4786fd2e38d24a7a9d95875c062f8456830c93db] source-hash-f0d93fab3eaad5865feb5895e542e8947c866aef
git bisect bad 4786fd2e38d24a7a9d95875c062f8456830c93db
# skip: [20801a1a32319ba2f1ca5a46ae8bf63ac9e4d36a] source-hash-95034bafdaecc9aaad556e6c3e47e74b9b2add5f
git bisect skip 20801a1a32319ba2f1ca5a46ae8bf63ac9e4d36a
# good: [3707b760a0352f7fefae49656e05ac302c6d7afe] source-hash-40ad0e8f6c5cecc01b47763457a1d1676a1fbc76
git bisect good 3707b760a0352f7fefae49656e05ac302c6d7afe
# skip: [726eb8c6fd0b212d06f79f0a510c7aa86ee794e9] source-hash-1a404132d94af93d99b2ab65185d2c1b3efd78d4
git bisect skip 726eb8c6fd0b212d06f79f0a510c7aa86ee794e9
# skip: [8d429739a8650e09a3a5459416852e69343eff61] source-hash-e2e8144d478754b8b59be3193669ca8ac17e5b78
git bisect skip 8d429739a8650e09a3a5459416852e69343eff61
# skip: [dcccbc500fdae5ebaf431078e69f3bfce7fd6e1f] source-hash-47bc56725a37834888680986844b5d7630a6581d
git bisect skip dcccbc500fdae5ebaf431078e69f3bfce7fd6e1f
# skip: [76a0bcc2a27c1e3015578a8b4bc14e0caa2ce5d7] source-hash-f6f7fc44768dae76b9f49a65ee16fece9d578f64
git bisect skip 76a0bcc2a27c1e3015578a8b4bc14e0caa2ce5d7
# good: [c10c019110e0fdd7ec52bf49d41e48586ae42b01] source-hash-78d1f562685c9bb8cd24d272b48e9d2d8c086308
git bisect good c10c019110e0fdd7ec52bf49d41e48586ae42b01
# skip: [793d65aaa999f14a7f6366a4edf3d2ef10c3da2b] source-hash-b7840fbb7e5866c06020676cf9ea3ad5a5034c59
git bisect skip 793d65aaa999f14a7f6366a4edf3d2ef10c3da2b
# skip: [53ac2c49ee37c664fda7c40435ae6c8eff9868a4] source-hash-dc6649908984c55659bc013e35f8131b7f85e6e7
git bisect skip 53ac2c49ee37c664fda7c40435ae6c8eff9868a4
# skip: [167f2257d68f8eb905b15fa3b9e067b30477336c] source-hash-151da1244f8db451f9b8c5c75dc09dd0969e4a28
git bisect skip 167f2257d68f8eb905b15fa3b9e067b30477336c
# skip: [27aac4868bcbf1e7bce321b703e44475602262a8] source-hash-4cbc3d855529737bf8ce37a3c98dbbcc6b17f09e
git bisect skip 27aac4868bcbf1e7bce321b703e44475602262a8
# skip: [78dc20d27ab6523d5e3a246923679618004ffb46] source-hash-41038b2b3d606508258ae4c1a99a5b9379c853d9
git bisect skip 78dc20d27ab6523d5e3a246923679618004ffb46
# skip: [4fd9c37678e342bae65efd850c0baf359df8423b] source-hash-6014e3c98d7f1f767297ff0f0b6f1a3be18b32d0
git bisect skip 4fd9c37678e342bae65efd850c0baf359df8423b
# skip: [b4aa6e6380b950f953529ef0865191485c2242ca] source-hash-6c992a54b662d39c860784aff7357b163db63dfb
git bisect skip b4aa6e6380b950f953529ef0865191485c2242ca
# skip: [2ca8b3bb0f45542552079103a90b0902c71e724c] source-hash-b193123b8e658d2eb25af5debe9de9e1b2386ef8
git bisect skip 2ca8b3bb0f45542552079103a90b0902c71e724c
# skip: [97f6d1e145d8221c08af685eee88e4b6e0208b6d] source-hash-82bc8b05c48398726c7fd8d1e2eaa2b365c53c28
git bisect skip 97f6d1e145d8221c08af685eee88e4b6e0208b6d
# skip: [bba8f6e1888a21597ba1d5376db1375c721ea9dd] source-hash-51a423cd75240e1e70165be8c0e5f1f09e8b68b9
git bisect skip bba8f6e1888a21597ba1d5376db1375c721ea9dd
# skip: [c219706ecc3ec3cab608d403c5b482ed08d7e4b7] source-hash-f30e479b0a337fb6f5711742d395d354269ece85
git bisect skip c219706ecc3ec3cab608d403c5b482ed08d7e4b7
# skip: [93eee77472a04bbe4543a69c3688ec479d7aec47] source-hash-cc5518ca61b209408a9d5262bbdcc39efccdd72d
git bisect skip 93eee77472a04bbe4543a69c3688ec479d7aec47
# skip: [4deea848fc276a898861267ea0e17363fdcb65e8] source-hash-3c10c9ec665a218ff331994ea3fa35cf2f4cd60e
git bisect skip 4deea848fc276a898861267ea0e17363fdcb65e8
# skip: [60ca8fa337ae105ac120e719c220c9ce313238d8] source-hash-4a0f0d714cc73c22dd2d363fd111d34f8413b387
git bisect skip 60ca8fa337ae105ac120e719c220c9ce313238d8
# skip: [d9c0dcac4d6c424dcabe5f4425edc6d9979a4813] source-hash-5585c4f2bf350d3e81d5963caad9a7a61baa9a20
git bisect skip d9c0dcac4d6c424dcabe5f4425edc6d9979a4813
# skip: [5132317dc4ce39a1296b7200b7dffd8f451b46a4] source-hash-55d6fdaf453062994d5f361621f4945f7b0e93dc
git bisect skip 5132317dc4ce39a1296b7200b7dffd8f451b46a4
# skip: [e4008a2f1d9e3723278102aaaff403d52e0e1cf9] source-hash-639aa8e72639fd01e9004977f1cfaafc13b1e45f
git bisect skip e4008a2f1d9e3723278102aaaff403d52e0e1cf9
# good: [26fe8a8817555806628a106fc5c190f22d442326] source-hash-0a05120e1a08c29b3495878d2a3b5fb30d344c6c
git bisect good 26fe8a8817555806628a106fc5c190f22d442326
# skip: [f1a522acc8616d6eafed8c8a449dcbe331f5ecc8] source-hash-a7806c318e9aa87312107b775f695b3dfe483f34
git bisect skip f1a522acc8616d6eafed8c8a449dcbe331f5ecc8
# skip: [71727abc696834dc1fab9f6edaebf9a8f2153962] source-hash-fa0fe19e89ba68a6b02cbdd5eff6bc161024c53d
git bisect skip 71727abc696834dc1fab9f6edaebf9a8f2153962
# only skipped commits left to test
# possible first bad commit: [4786fd2e38d24a7a9d95875c062f8456830c93db] source-hash-f0d93fab3eaad5865feb5895e542e8947c866aef
# possible first bad commit: [71727abc696834dc1fab9f6edaebf9a8f2153962] source-hash-fa0fe19e89ba68a6b02cbdd5eff6bc161024c53d
# possible first bad commit: [5132317dc4ce39a1296b7200b7dffd8f451b46a4] source-hash-55d6fdaf453062994d5f361621f4945f7b0e93dc
# possible first bad commit: [dcccbc500fdae5ebaf431078e69f3bfce7fd6e1f] source-hash-47bc56725a37834888680986844b5d7630a6581d
# possible first bad commit: [27aac4868bcbf1e7bce321b703e44475602262a8] source-hash-4cbc3d855529737bf8ce37a3c98dbbcc6b17f09e
# possible first bad commit: [2ca8b3bb0f45542552079103a90b0902c71e724c] source-hash-b193123b8e658d2eb25af5debe9de9e1b2386ef8
# possible first bad commit: [60ca8fa337ae105ac120e719c220c9ce313238d8] source-hash-4a0f0d714cc73c22dd2d363fd111d34f8413b387
# possible first bad commit: [f1a522acc8616d6eafed8c8a449dcbe331f5ecc8] source-hash-a7806c318e9aa87312107b775f695b3dfe483f34
# possible first bad commit: [e4008a2f1d9e3723278102aaaff403d52e0e1cf9] source-hash-639aa8e72639fd01e9004977f1cfaafc13b1e45f
# possible first bad commit: [4deea848fc276a898861267ea0e17363fdcb65e8] source-hash-3c10c9ec665a218ff331994ea3fa35cf2f4cd60e
# possible first bad commit: [b4aa6e6380b950f953529ef0865191485c2242ca] source-hash-6c992a54b662d39c860784aff7357b163db63dfb
# possible first bad commit: [20801a1a32319ba2f1ca5a46ae8bf63ac9e4d36a] source-hash-95034bafdaecc9aaad556e6c3e47e74b9b2add5f
# possible first bad commit: [76a0bcc2a27c1e3015578a8b4bc14e0caa2ce5d7] source-hash-f6f7fc44768dae76b9f49a65ee16fece9d578f64
# possible first bad commit: [78dc20d27ab6523d5e3a246923679618004ffb46] source-hash-41038b2b3d606508258ae4c1a99a5b9379c853d9
# possible first bad commit: [793d65aaa999f14a7f6366a4edf3d2ef10c3da2b] source-hash-b7840fbb7e5866c06020676cf9ea3ad5a5034c59
# possible first bad commit: [97f6d1e145d8221c08af685eee88e4b6e0208b6d] source-hash-82bc8b05c48398726c7fd8d1e2eaa2b365c53c28
# possible first bad commit: [726eb8c6fd0b212d06f79f0a510c7aa86ee794e9] source-hash-1a404132d94af93d99b2ab65185d2c1b3efd78d4
# possible first bad commit: [0c4b91e14fa2d5f481d1fe524f14f31a318ae740] source-hash-80ae9161ff231908431b6ee6471bd5363425ff26
# possible first bad commit: [167f2257d68f8eb905b15fa3b9e067b30477336c] source-hash-151da1244f8db451f9b8c5c75dc09dd0969e4a28
# possible first bad commit: [c219706ecc3ec3cab608d403c5b482ed08d7e4b7] source-hash-f30e479b0a337fb6f5711742d395d354269ece85
# possible first bad commit: [8d429739a8650e09a3a5459416852e69343eff61] source-hash-e2e8144d478754b8b59be3193669ca8ac17e5b78
# possible first bad commit: [d9c0dcac4d6c424dcabe5f4425edc6d9979a4813] source-hash-5585c4f2bf350d3e81d5963caad9a7a61baa9a20
# possible first bad commit: [fab017f58669df271efb76738b0a86246f3baf1b] source-hash-efcc8ddd213e7f7a341526bdcffcee75d8fef77f
# possible first bad commit: [bba8f6e1888a21597ba1d5376db1375c721ea9dd] source-hash-51a423cd75240e1e70165be8c0e5f1f09e8b68b9
# possible first bad commit: [4fd9c37678e342bae65efd850c0baf359df8423b] source-hash-6014e3c98d7f1f767297ff0f0b6f1a3be18b32d0
# possible first bad commit: [53ac2c49ee37c664fda7c40435ae6c8eff9868a4] source-hash-dc6649908984c55659bc013e35f8131b7f85e6e7
# possible first bad commit: [93eee77472a04bbe4543a69c3688ec479d7aec47] source-hash-cc5518ca61b209408a9d5262bbdcc39efccdd72d
Comment 4 Xisco Faulí 2016-09-13 09:05:50 UTC
I'd say it was introduced by cc5518ca61b209408a9d5262bbdcc39efccdd72d but I'm not completely sure...
Comment 6 Katarina Behrens (CIB) 2018-02-22 22:24:37 UTC

*** This bug has been marked as a duplicate of bug 115691 ***