Bug 102141 - UI: "Clear direct formatting" removed from context menu
Summary: UI: "Clear direct formatting" removed from context menu
Status: RESOLVED DUPLICATE of bug 102915
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.2.0.4 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: needsUXEval
Depends on:
Blocks: Context-Menu
  Show dependency treegraph
 
Reported: 2016-09-13 00:30 UTC by Lukas Jelinek
Modified: 2016-10-03 18:51 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Lukas Jelinek 2016-09-13 00:30:19 UTC
Since 5.2.0, the "Clear direct formatting" item has been removed from the context menu for the selected part of text. But this function was very handy and comfortable. Currently there is possibility to use Ctrl+M or the "Format" menu but it't often more complicated, less comfortable. Please consider to return the item back.
Comment 1 Petr Valach 2016-09-13 22:34:15 UTC
Although I suppose it isn't too hard to use hotkey Ctrl+m, I approve that some users find out using of context menu as very comfortable.
Comment 2 Aron Budea 2016-09-14 21:24:37 UTC
UX team, was the "Clear direct formatting" context menu item removed on purpose, and if it was, would it be fine to have it added again?
Comment 3 Maxim Monastirsky 2016-09-14 22:04:16 UTC
(In reply to Lukas Jelinek from comment #0)
> Since 5.2.0, the "Clear direct formatting" item has been removed from the
> context menu for the selected part of text. But this function was very handy
> and comfortable. Currently there is possibility to use Ctrl+M or the
> "Format" menu but it't often more complicated, less comfortable.
In that case you can add it back yourself under Tools > Customize... > Context Menus.

(In reply to Aron Budea from comment #2)
> was the "Clear direct formatting" context menu item removed on
> purpose
Yes it is. See https://gerrit.libreoffice.org/20446/
Comment 4 V Stuart Foote 2016-09-14 22:13:01 UTC
See discussions for removal in UX Design minutes and in
 
bug 81132
https://gerrit.libreoffice.org/11111
https://gerrit.libreoffice.org/13214

and finalized
bug 86606
https://gerrit.libreoffice.org/14979
Comment 5 Aron Budea 2016-09-14 22:52:52 UTC
Maxim, Stuart, thanks for the information!
As I can see in bug 81132, Clear Formatting was 6th on the list of most used right click options, which seems to be very popular compared to other fairly unused formatting options.

However, it's true Clear Direct Formatting is also there on the Formatting toolbar, so the keyboard shortcut and menu item aren't the only options for accessing it.
Comment 6 Yousuf Philips (jay) (retired) 2016-10-03 17:54:48 UTC
*** Bug 102915 has been marked as a duplicate of this bug. ***
Comment 7 tagezi 2016-10-03 18:30:57 UTC
Since the bug that I discovered, was marked as a duplicate, I open this bug again. The reason is described in the comments to the bug report.

Please note that the vote also has confirmed that this bug should be fixed.
https://plus.google.com/107566594492891737454/posts/H1qqdXMVkWd
Yousuf Philips (jay), If you suddenly do not believe a simple mathematical calculations and do not want to read the comments.
Comment 8 V Stuart Foote 2016-10-03 18:51:28 UTC
Since Heiko has the user survey linked to the other, makes more sense to close this as a dupe regards enhancement request and discussion of restoring a "Clear Direct Formatting" .uno:ReesetAttributes based entry on the Writer context menu.

*** This bug has been marked as a duplicate of bug 102915 ***