Bug 102142 - Notebookbar: certain icons are enabled in print preview mode
Summary: Notebookbar: certain icons are enabled in print preview mode
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.3.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:5.4.0
Keywords:
Depends on:
Blocks: Notebookbar
  Show dependency treegraph
 
Reported: 2016-09-13 00:35 UTC by Aron Budea
Modified: 2018-12-08 22:43 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
This bug is still present. (77.28 KB, image/jpeg)
2018-05-10 19:05 UTC, Pedro
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Aron Budea 2016-09-13 00:35:14 UTC
1. Switch to Notebookbar view (View -> Toolbar Layout -> Notebookbar).
2. Switch to View tab, and click Print Preview.

Buttons that are enabled or look enabled, but shouldn't be:
-Page layout tab: Indent icons
-Insert tab: Square, Ellipse, Triangle, Flowchart icons
-Home tab: Align top, Center vertically, Align bottom.

Version: 5.3.0.0.alpha0+
Build ID: 04695b95491b7e866298bf4231fb9cca25a35a93
CPU Threads: 4; OS Version: Windows 6.1; UI Render: default; 
Locale: hu-HU (hu_HU); Calc: CL
Comment 1 Yousuf Philips (jay) (retired) 2016-09-13 00:54:51 UTC
(In reply to Aron Budea from comment #0)
> -Page layout tab: Indent icons

Yes the icon's are enabled but not the controls.

> -Insert tab: Square, Ellipse, Triangle, Flowchart icons
> -Home tab: Align top, Center vertically, Align bottom.

These commands are enabled in non-notebookbar modes as well. :D

There is also References: Bibliography Database
Comment 2 Commit Notification 2017-01-18 17:53:31 UTC
Szymon Kłos committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=b93856a666cc0af099c934669a3d593116456b84

tdf#102142 : Disable edit paragraph style in the print preview mode

It will be available in 5.4.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 3 Commit Notification 2017-01-23 19:27:29 UTC
Szymon Kłos committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=6d031e4e3a2e773380374b5b142db5f5ebcdcf79

tdf#102142 : disable paragraph spacing icons in the print preview mode

It will be available in 5.4.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 4 QA Administrators 2017-03-01 10:52:03 UTC
Hello Szymon,
Is this bug fixed?
If so, could you please close it as RESOLVED FIXED?
Comment 5 Yousuf Philips (jay) (retired) 2017-04-15 18:44:43 UTC
We should ideally fix the shape buttons on the Insert tab before we close this bug.

.uno:BasicShapes.rectangle
.uno:BasicShapes.ellipse
.uno:BasicShapes.isosceles-triangle

@Maxim: Any thoughts?
Comment 6 QA Administrators 2018-04-17 02:31:03 UTC Comment hidden (obsolete)
Comment 7 Pedro 2018-05-10 19:05:17 UTC
Created attachment 142025 [details]
This bug is still present.

This bug is still present in 6.1Dev.
Comment 8 andreas_k 2018-12-08 22:43:25 UTC
there is an print tab available which is now active and the other tabs have the non possible actions grayed out. only in the hometab the styles icons (H1, H2, ...) are not grayed out, but the reason is how this commands are integrated into the notebookbar.

for me this bug is fixed in 6.2