Bug 102160 - [I18n] Untranslated item in the File services dialog
Summary: [I18n] Untranslated item in the File services dialog
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: framework (show other bugs)
Version:
(earliest affected)
5.3.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Andras Timar
URL:
Whiteboard: target:6.0.0.1 target:6.1.0
Keywords:
: 104676 (view as bug list)
Depends on:
Blocks: CMIS Not-Localizable
  Show dependency treegraph
 
Reported: 2016-09-13 14:21 UTC by Gabor Kelemen (allotropia)
Modified: 2017-12-03 11:20 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Screenshot of the problem on KeyID UI (40.37 KB, image/png)
2016-09-13 14:21 UTC, Gabor Kelemen (allotropia)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Gabor Kelemen (allotropia) 2016-09-13 14:21:13 UTC
Created attachment 127296 [details]
Screenshot of the problem on KeyID UI

In the File Services window the list item "Other CMIS" is not translatable. While other items in this list are product names - so one can say these should't be localized - this one is not.
Comment 1 Julien Nabet 2016-09-17 17:30:59 UTC
On pc Debian x86-64 with master sources updated today, I could reproduce this.
Strings come from here:
http://opengrok.libreoffice.org/xref/core/officecfg/registry/data/org/openoffice/Office/Common.xcu#492

Giuseppe: thought you might be interested in this one.
Comment 2 Julien Nabet 2016-12-14 15:09:01 UTC
*** Bug 104676 has been marked as a duplicate of this bug. ***
Comment 3 Commit Notification 2017-12-01 13:25:59 UTC
Andras Timar committed a patch related to this issue.
It has been pushed to "libreoffice-6-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=f8d9ca3848b5d5224c2e4391eaf56940e93bcd01&h=libreoffice-6-0

tdf#102160 make 'Other CMIS' string localizable

It will be available in 6.0.0.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 4 Commit Notification 2017-12-01 20:43:21 UTC
Andras Timar committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=ae745789704fd7ad86c84ff9875cda810ff915b0

tdf#102160 make 'Other CMIS' string localizable

It will be available in 6.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 5 Gabor Kelemen (allotropia) 2017-12-03 11:20:27 UTC
Thanks Andras!