Bug 102177 - Document focus lost when context menu opened
Summary: Document focus lost when context menu opened
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.2.1.2 release
Hardware: All All
: medium normal
Assignee: Caolán McNamara
URL:
Whiteboard: target:5.3.0 target:5.2.3
Keywords: accessibility, bibisectRequest, regression
: 101171 (view as bug list)
Depends on:
Blocks: Context-Menu a11y
  Show dependency treegraph
 
Reported: 2016-09-13 17:07 UTC by am_dxer
Modified: 2016-11-16 10:54 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description am_dxer 2016-09-13 17:07:11 UTC
Steps to reproduce:
1. Press the Applications key from within a writer document to open the context menu.
2. Press escape or select an item from the menu that returns focus to the document.
3. It is not possible to use the keyboard to navigate around the document.

The user must press F6 to move focus back to a control.
Comment 1 Yousuf Philips (jay) (retired) 2016-09-14 02:22:24 UTC
Didnt fully get what you meant, do you mean the alt key when you said "applications key". If so pressing escape returns to close the menu does return me to the document.
Comment 2 am_dxer 2016-09-14 11:41:02 UTC
Sorry for being unclear. I am referring to the key that looks like a cursor hovering over a menu. It is to the left of the right Control key and usually performs a similar action to a right click.
Comment 3 Yousuf Philips (jay) (retired) 2016-09-14 20:15:45 UTC
Confirmed that the context menu doesnt maintain focus within the document when opened, so focus isnt in document when pressing escape.

Regression as this doesnt happen in 5.1.5.

Version: 5.3.0.0.alpha0+
Build ID: 78404fe5549fded2eaf0c5ea6e1ca66039e995af
CPU Threads: 2; OS Version: Linux 3.19; UI Render: default; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2016-09-11_09:14:01
Locale: en-US (en_US.UTF-8); Calc: group
Comment 4 raal 2016-09-27 11:20:05 UTC
Version: 5.3.0.0.alpha0+, windows. No repro, I can for example open menu with Alt+F : Press the Applications key ; Press escape ; Alt+F opens menu File

After "Press the Applications key ; Press escape" I doesn't see blinking cursor, maybe this is the problem of this bug?

@am_dxer: what's your OS?

Thanks
Comment 5 Caolán McNamara 2016-09-27 12:40:45 UTC
its got to be non-gtk3 (maybe also non-mac) to see this
Comment 6 Commit Notification 2016-09-27 15:29:24 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=4da7971812b0a53ba80f7d9c29851c527488067d

Resolves: tdf#102177 focus not restored from context menus

It will be available in 5.3.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 7 V Stuart Foote 2016-09-27 20:27:34 UTC
*** Bug 101171 has been marked as a duplicate of this bug. ***
Comment 8 Commit Notification 2016-10-06 14:30:15 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-5-2":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=06761518b63cc420ee11cff3e54e1059a5985b01&h=libreoffice-5-2

Resolves: tdf#102177 focus not restored from context menus

It will be available in 5.2.3.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 9 Cor Nouws 2016-10-21 12:33:40 UTC
perfect (daily20161020) - thanks!