Bug 102186 - MS PowerPoint with Chart shows hidden data labels when opened in Impress
Summary: MS PowerPoint with Chart shows hidden data labels when opened in Impress
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Chart (show other bugs)
Version:
(earliest affected)
5.1.0.3 release
Hardware: All All
: medium normal
Assignee: Markus Mohrhard
URL:
Whiteboard: target:6.3.0 target:6.2.0.1 target:6.1.4
Keywords: bibisected, bisected, filter:pptx, regression
: 98293 105513 (view as bug list)
Depends on:
Blocks: OOXML-Chart PPTX
  Show dependency treegraph
 
Reported: 2016-09-14 00:00 UTC by george.secillano
Modified: 2018-11-19 15:00 UTC (History)
8 users (show)

See Also:
Crash report or crash signature:


Attachments
Word doc containing screenshots comparing MS power point and Impress (531.87 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2016-09-14 00:00 UTC, george.secillano
Details
Test PPTX with embedded chart (598.63 KB, application/vnd.openxmlformats-officedocument.presentationml.presentation)
2016-09-14 00:01 UTC, george.secillano
Details
Screenshot from Powerpoint (167.14 KB, image/png)
2016-10-07 18:29 UTC, Buovjaga
Details
Screenshot from Impress 5.1 (153.86 KB, image/png)
2016-10-07 18:30 UTC, Buovjaga
Details

Note You need to log in before you can comment on or make changes to this bug.
Description george.secillano 2016-09-14 00:00:46 UTC
Created attachment 127321 [details]
Word doc containing screenshots comparing MS power point and Impress

See attached samplechart2.pptx - the underlying excel data uses pivot tables and are used in formulas in the data series.

Charts using simple formulas and native values render correctly (data labels are correctly hidden).
Comment 1 george.secillano 2016-09-14 00:01:40 UTC
Created attachment 127322 [details]
Test PPTX with embedded chart
Comment 2 Buovjaga 2016-10-07 18:29:19 UTC
Created attachment 127865 [details]
Screenshot from Powerpoint
Comment 3 Buovjaga 2016-10-07 18:30:37 UTC
Created attachment 127866 [details]
Screenshot from Impress 5.1
Comment 4 Buovjaga 2016-10-07 18:32:39 UTC
I confirm it.

Works ok in 3.6, so regression!

Arch Linux 64-bit, KDE Plasma 5
Version: 5.3.0.0.alpha0+
Build ID: ff2a399b61f34f7920e594e8cbb6c19045b24956
CPU Threads: 8; OS Version: Linux 4.7; UI Render: default; 
Locale: fi-FI (fi_FI.UTF-8); Calc: group
Built on October 7th 2016

Arch Linux 64-bit
Version 3.6.7.2 (Build ID: e183d5b)
Comment 5 raal 2016-10-13 15:56:22 UTC
This seems to have begun at one of the below commits.
Adding Cc: to Markus Mohrhard; Could you possibly take a look at this one? Thanks

2b926872a7664f9271264a29e62e90a32ee76e14 is the first bad commit
commit 2b926872a7664f9271264a29e62e90a32ee76e14
Author: Norbert Thiebaud <nthiebaud@gmail.com>
Date:   Mon Jun 1 03:07:32 2015 -0500

    source sha:4c3cfe60ac05d5404e3f2a92fff7af2d2f38628a

    source sha:4c3cfe60ac05d5404e3f2a92fff7af2d2f38628a
    source sha:5fa0adf25cfcb71129e05e7218cde46874306c15
    source sha:007eadfaa0efae0d8baa51b56295b5adc6564b50
    source sha:df6eaac55e6a8b2bec3f3897e87b9a58efe36bc6
    source sha:2e4b736b8a245a03ff20dbc3b0c9cf3be2d1ae01
    source sha:090960a1eb8bff1cf74f041690cd7258070ba312
    source sha:1478d2c37e57db1ee869f8ca5573b7dc7c7d6a51
    source sha:0791b8f1d35f2795ff87e21d04395b3ec8bd831d
    source sha:e001998cb11ce865f2ea8925a058245a04d9e701
    source sha:7438087a1db55aba395b241df24b4908c9491a32
    source sha:9ded594ec9bf79acfcf0570f873c2c29130eaaf3
    source sha:23de8cfe4d8021cc375731b48a055f4111063172
    source sha:4e35dfb3c4d5fb9f92ef741d9232dfe32612c572
    source sha:f6000b3aabbc234d46a3dc818d37d4a0b6ac23c6
    source sha:5693eb07f645bef934c2e16ba252298d304ff420
    source sha:935f3b9993bfb76560c07ba0d39df4ce21e58518
    source sha:2a1b49b4ad569dd2af8f777aae578484f55d4b9a
    source sha:48d7336ff68a46b814586c8e9ce32690b4d1ade9
    source sha:f418edfb2302a32ae6fc571b774504055eb2d345
    source sha:02b2ebd32101abd2c2cd7c13ce80109f7a72a7bd
    source sha:3eff437c462808df929ae6fd0034c0989f7fda3d
    source sha:0c8d6a434fb4015e9fb9a43827453d464eb9f7b5
    source sha:1a65d2f85a49b47d163083f7b46f026178aed38a
    source sha:5c0800805dabe0f672b15497fb92e8326f18a0f8
Comment 6 Aron Budea 2017-08-28 00:20:18 UTC
*** Bug 105513 has been marked as a duplicate of this bug. ***
Comment 7 Aron Budea 2017-08-28 00:21:56 UTC
There's also an issue with colors, reported in bug 105517.
Comment 8 Commit Notification 2018-11-18 05:17:23 UTC
Markus Mohrhard committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/4bd2e57653ce22044ab984b06c84f22ef287cecf%5E%21

tdf#102186, don't overwrite the deleted flag

It will be available in 6.2.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 9 Commit Notification 2018-11-18 14:59:32 UTC
Markus Mohrhard committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/8b83659bb8f3368a1df949d5bc84d7b2dd0370b4%5E%21

tdf#102186, add test for deleted data labels

It will be available in 6.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 10 Markus Mohrhard 2018-11-18 16:40:20 UTC
*** Bug 98293 has been marked as a duplicate of this bug. ***
Comment 11 Commit Notification 2018-11-19 01:07:33 UTC
Markus Mohrhard committed a patch related to this issue.
It has been pushed to "libreoffice-6-2":

https://git.libreoffice.org/core/+/388fd9918c0a2cf5f72bbb14aa8d22cc99681c0d%5E%21

tdf#102186, don't overwrite the deleted flag

It will be available in 6.2.0.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 12 Xisco Faulí 2018-11-19 09:07:47 UTC
Verified in

Version: 6.2.0.0.beta1+
Build ID: 268364e35100b559f42d8c02b930c5cca1c84be7
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded

@Markus Mohrhard, thanks for fixing this!!
Comment 13 Commit Notification 2018-11-19 15:00:55 UTC
Markus Mohrhard committed a patch related to this issue.
It has been pushed to "libreoffice-6-1":

https://git.libreoffice.org/core/+/47c05f6e1bb4ec77f242001e4c2d297af48f511e%5E%21

tdf#102186, don't overwrite the deleted flag

It will be available in 6.1.4.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.