Bug 102203 - UI: Command Insert > Page Number is confusing (in relation to also existing choice, at different place, to show/hide Master page Elements)
Summary: UI: Command Insert > Page Number is confusing (in relation to also existing c...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Fields-Page-Number
  Show dependency treegraph
 
Reported: 2016-09-15 10:03 UTC by bureautiquelibre
Modified: 2019-01-22 15:08 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Example: slide master without page number (11.63 KB, application/vnd.oasis.opendocument.presentation)
2016-09-15 10:03 UTC, bureautiquelibre
Details

Note You need to log in before you can comment on or make changes to this bug.
Description bureautiquelibre 2016-09-15 10:03:34 UTC
Created attachment 127340 [details]
Example: slide master without page number

Hi,

Some users report me the following issue:

The command Insert/Page Number doesn't actually insert anything into the slides.

What the feature seems to really do is enabling or disabling the display of some standard fields if they are present in the slide masters.
It does nothing if the fields aren't present in the slide master.

For example: if I use a slide master that doesn't have a page number field in it, using the Insert/Page number feature will do nothing if I play with the page number check box and validate. Use provided example to test: I removed the page number field from the standard slide masters.

If the field is present in slide master, it will enable or disable its display (I'm not sure that this is easy to see if the field display is enabled or disabled, this could maybe confuse users also: I see the field in the slide master but it doesn't display = bug ? ).

The name and location of the feature is confusing: in order to actually insert fields, the use of Insert/Field is the right way to go and this option is right below "Page Number", so users never reach it and click on page number instead.

IMHO, the feature should be moved in another menu, maybe display (or format) since it doesn't insert anything and perhaps the name changed for something more explicit.

Something for the design team I think :)

Best Regards,
Eric Ficheux
Comment 1 Heiko Tietze 2016-09-15 13:58:17 UTC
So we could disable the menu entry when the master has no page field or we change the master, perhaps after confirmation. Or this menu entry gets kill in favor of the master slide. But nothing works really well. Ideas?
Comment 2 bureautiquelibre 2016-09-16 10:34:52 UTC
Hi,

The following is only my opinion:

Killing this menu entry in favor of the master slides seems to me the best for the following reasons:

* The Insert/Page Number adds no additional feature: the same results can be achieved by working on the master slides directly.

* Dealing with the master slides or master notes (don't know if it's the right name in English) looks easy to understand, it's straightforward: you see the item/field on the master slide, it displays on the slides, if it isn't there, it doesn't display on the slides.

* The feature adds unnecessary complexity to how master slides work: to figure out if your page number will display, it must be in master slide AND enabled in the page number dialog ... seems a bit complicated for the average user who could easily think it's a bug. It also makes master slides confusing since you can get a result different than what is displayed in the master slides view.

Regards,
Eric
Comment 3 Cor Nouws 2016-09-20 08:59:16 UTC
(In reply to bureautiquelibre from comment #0)
> 
> IMHO, the feature should be moved in another menu, maybe display (or format)
> since it doesn't insert anything and perhaps the name changed for something
> more explicit.

Hi Eric,

The menu allows to insert a page number (and a field 'date time' (or foo) and a field title), when I didn't add this type of content before. So 'Insert' makes sense from that perspective?
OTOH, indeed there is a hidden relation with "Slide > Master elements"

(In version 3.3.0.4 it was 'hidden' in View > Model > Master Elements)
Comment 4 Cor Nouws 2016-09-20 09:13:40 UTC
so the rationale is that it's a design decision whether or not to allow a page number on a type of slide (master page) and a user decision whether or not to use it.
Help says (on top of the page) "Adds or changes text in placeholders at the top and the bottom of slides and slide masters." I do not see a reference to the choice given to show/hide master elements (Slide > Master elements).
Maybe the UI / dialog could make that link clear?
Comment 5 bureautiquelibre 2016-09-23 13:24:49 UTC
Hi Cor,

Thanks for the 2 posts, makes the logic of the feature clear now: I didn't see the Designer and User point of view before.

So yes, clarification is needed in the UI/Dialog to better reflect it,

Regards,
Eric Ficheux
Comment 6 Cor Nouws 2016-09-25 18:32:35 UTC
to add some things I notice:

- The preview, right in the Dialog Insert > Header and Footer
 - does hide master page elements that are not available (by the menu Slide > Master Page Elements)
 - does show elements that are selected in the dialog black, and gray if not

A first idea: a label with the preview: "position / available master page elements"
Comment 7 Regina Henschel 2017-09-11 15:31:31 UTC
The page number can be shown using a field or using a presentation class. This is given in file format and cannot be restricted to one or the other. The users needs the ability to work on a presentation regardless which kind of page number it contains.

Suggestions:
Add the dialog to "Slides" instead of the "Master Elements" dialog. (Problems with dialog Master Elements are in bug 112327.)
Title it "Manage Master Elements".
Remove "Insert > Page number" and "Insert Header and Footer", which both go this dialog, see bug 104088. 

[I personal do not like the current dialog design, because it mixes working on a single slide with working on the master slide. But that is a different topic.]
Comment 8 Heiko Tietze 2019-01-22 08:25:31 UTC
Meanwhile (6.1) , Page Number was removed from the Insert menu in favor of Slide Number, which is duplicated under Field (don't like this and would remove it). So I'd close the issue as WFM.
Comment 9 Cor Nouws 2019-01-22 15:08:58 UTC
Side note:

(In reply to Heiko Tietze from comment #8)
> which is duplicated under Field (don't like this and would
> remove it). 
Similar in Writer