Bug Hunting Session
Bug 102223 - EDITING Deleting all content from a cell changes font formatting
Summary: EDITING Deleting all content from a cell changes font formatting
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
5.0.3.2 release
Hardware: All All
: medium normal
Assignee: Noel Grandin
URL:
Whiteboard: target:5.3.0 target:5.2.3
Keywords:
Depends on:
Blocks:
 
Reported: 2016-09-16 11:17 UTC by Noel Grandin
Modified: 2016-09-21 09:42 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
bug file (14.57 KB, application/vnd.oasis.opendocument.presentation)
2016-09-16 11:17 UTC, Noel Grandin
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Noel Grandin 2016-09-16 11:17:51 UTC
Created attachment 127360 [details]
bug file

open attached presentation, mark an area and set font to Arial, 12. Then mark a cell, cut it and font changes to Liberation Sans, 18. 

Expected Result: Formatting does not change
Comment 1 Cor Nouws 2016-09-20 08:50:57 UTC
Hi Noel,

from what I know, cutting a cell in Calc has the same effect. So I would say it is by design?
Comment 2 Noel Grandin 2016-09-20 09:17:22 UTC
Cor, probably Calc people use a lot less styles, and so don't expect this behaviour.
Since Impress is really just a drawing engine, people expect styles to stay put :-)
Comment 3 Noel Grandin 2016-09-20 09:26:46 UTC
i just checked, in Calc if you press Delete on a cell that has a custom (e.g.) font height, then the font height is not deleted
Comment 4 Cor Nouws 2016-09-20 09:43:50 UTC
there is a difference in Dell and Ctrl+X. But I agree with you about the expectation of users here.
Comment 5 Commit Notification 2016-09-20 10:48:49 UTC
Noel Grandin committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=5865af093c9698c7358e6f3b8ae37cd2cb1cfaff

tdf#102223 EDITING Deleting all content from a cell changes font formatting

It will be available in 5.3.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 6 Commit Notification 2016-09-21 09:42:54 UTC
Noel Grandin committed a patch related to this issue.
It has been pushed to "libreoffice-5-2":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=6a361f874debed3863b55f741552faf8170d19bc&h=libreoffice-5-2

tdf#102223 EDITING Deleting all content from a cell changes font formatting

It will be available in 5.2.3.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.