Download it now!
Bug 102284 - FORMATTING: Footnote separator thickness can't be thinner than 0.25pt
Summary: FORMATTING: Footnote separator thickness can't be thinner than 0.25pt
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.4.6 release
Hardware: All Linux (All)
: medium normal
Assignee: Yousuf Philips (jay) (retired)
URL:
Whiteboard: target:5.3.0
Keywords: regression
: 46925 (view as bug list)
Depends on:
Blocks: Footnote-Endnote
  Show dependency treegraph
 
Reported: 2016-09-19 14:03 UTC by Jeff
Modified: 2017-10-09 17:02 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
footer separator 0.00pt sample (8.73 KB, application/vnd.oasis.opendocument.text)
2016-10-16 17:44 UTC, Yousuf Philips (jay) (retired)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jeff 2016-09-19 14:03:46 UTC
The separator line between footnote and the main body text may no longer be thinner than 0.25pt (which is quite thick).

To reproduce:
* Format > Page > Footnote.
* Under Separator Line, set Thickness to 0.10. 
* Hit Tab.  It instantly resets to 0.25pt.

Similar to #56559 but for footnote separators, instead of column separators.
Comment 1 Buovjaga 2016-10-11 17:28:00 UTC
(In reply to Jeff from comment #0)
> The separator line between footnote and the main body text may no longer be
> thinner than 0.25pt (which is quite thick).

I don't get the "no longer" part: in LibO 3.3 (inherited from OO.o), it could be at a minimum 0 or 0.5 pts. In 3.4, it became more granular with 0.25 pts allowed.
Comment 2 Jeff 2016-10-12 15:22:32 UTC
Sorry typo by me. I don't know about the history of this feature.  Rather, I just think that 0.25pt is quite thick, especially when most other borders default to 0.05.
Comment 3 Yousuf Philips (jay) (retired) 2016-10-13 02:37:27 UTC
The minimum height of 0.05pt for borders is quite likely a mistake that we hope to correct, but the minimum height should be set to a reasonable minimum when it gets printed.
Comment 4 Yousuf Philips (jay) (retired) 2016-10-16 14:52:55 UTC
So i checked MS Word and there separator is larger than 0.25pt and is a character and not a border line, which you can adjust its thickness. So i'd say that a minimum of 0.25pt sounds good, but not allowing numbers below 0.25pt will cause compatibility problems with older OOo documents which allowed a minimum value of 0.00pt.
Comment 5 Buovjaga 2016-10-16 16:26:12 UTC
(In reply to Yousuf Philips (jay) from comment #4)
> So i checked MS Word and there separator is larger than 0.25pt and is a
> character and not a border line, which you can adjust its thickness. So i'd
> say that a minimum of 0.25pt sounds good, but not allowing numbers below
> 0.25pt will cause compatibility problems with older OOo documents which
> allowed a minimum value of 0.00pt.

Bug 36722 - it is solved by "line style: None".
Comment 6 Yousuf Philips (jay) (retired) 2016-10-16 17:44:29 UTC
Created attachment 128032 [details]
footer separator 0.00pt sample
Comment 7 Yousuf Philips (jay) (retired) 2016-10-16 18:06:43 UTC
(In reply to Buovjaga from comment #5)
> Bug 36722 - it is solved by "line style: None".

Close but unfortunately not as can be seen with attachment 128032 [details], by importing it and it shows 0.25pt when i should say 0.00pt.

This is a simple fix.

https://gerrit.libreoffice.org/29932
Comment 8 Commit Notification 2016-10-19 13:27:30 UTC
Yousuf Philips committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=2f3f06461e7c830105935a1590ff9f181169dff5

tdf#102284 Allow footnote separator thickness of 0pt

It will be available in 5.3.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 9 Xisco Faulí 2016-11-12 14:43:54 UTC
Hello Yousuf,
Is this bug fixed?
If so, could you please close it as RESOLVED FIXED?
Comment 10 Yousuf Philips (jay) (retired) 2017-10-09 17:02:46 UTC
*** Bug 46925 has been marked as a duplicate of this bug. ***