Bug 102298 - [UI] In Autofilter the 5 elements on top do not get focus by Tab, nor have a shortcut
Summary: [UI] In Autofilter the 5 elements on top do not get focus by Tab, nor have a ...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: accessibility, implementationError
Depends on:
Blocks: a11y, Accessibility AutoFilter
  Show dependency treegraph
 
Reported: 2016-09-19 20:22 UTC by Cor Nouws
Modified: 2021-06-04 13:30 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
screen short (15.82 KB, image/png)
2016-09-19 20:25 UTC, Cor Nouws
Details
sequence of elements accessed by pressing tab repeatedly in LO 7.2 (33.05 KB, image/png)
2021-06-04 13:19 UTC, Stéphane Guillou (stragu)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Cor Nouws 2016-09-19 20:22:02 UTC

    
Comment 1 Cor Nouws 2016-09-19 20:25:22 UTC
Items Sort Ascending, Sort Descending, Top 10, Empty and Non Empty
get no focus with Tab nor have a short cut
Comment 2 Cor Nouws 2016-09-19 20:25:41 UTC
Created attachment 127439 [details]
screen short
Comment 3 m.a.riosv 2016-09-19 21:30:33 UTC
Confirmed
Comment 4 QA Administrators 2017-11-09 07:43:48 UTC Comment hidden (obsolete)
Comment 5 Cor Nouws 2017-12-29 20:38:03 UTC
still a problem in Version: 6.1.0.0.alpha0+
Build ID: a9b202a6b7000e7af34f2a639ca207122a3968bf
CPU threads: 4; OS: Linux 4.13; UI render: default; VCL: gtk2; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2017-12-26_23:09:36
Locale: nl-NL (nl_NL.UTF-8); Calc: group threaded
Comment 6 QA Administrators 2018-12-30 03:47:10 UTC Comment hidden (obsolete)
Comment 7 Cor Nouws 2019-01-01 18:02:58 UTC
still the same in Version: 6.3.0.0.alpha0+
Build ID: 082144fa0fb2021cfb41494bb6eb5bf417e58ab1
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time: 2018-12-31_03:11:43
Locale: nl-NL (nl_NL.UTF-8); UI-Language: en-US
Calc: threaded(In reply to QA Administrators from comment #6)
Comment 9 Roman Kuznetsov 2019-08-06 15:02:51 UTC
Cor, I can select any control in Autofilter window by Tab key in

Version: 6.4.0.0.alpha0+ (x86)
Build ID: ca6df519a78e5bfc96030c916f242b86306194e5
CPU threads: 4; OS: Windows 6.1; UI render: default; VCL: win; 
Locale: ru-RU (ru_RU); UI-Language: en-US
Calc: threaded

please retest it yourself
Comment 10 Stéphane Guillou (stragu) 2021-06-04 13:19:02 UTC
Created attachment 172622 [details]
sequence of elements accessed by pressing tab repeatedly in LO 7.2

I don't know if this is specific to the platform that was in use, but I can reproduce on my Ubuntu 18.04-based system (with Budgie + GTK), with the latest master of LibreOffice:

Version: 7.2.0.0.alpha1+ / LibreOffice Community
Build ID: 774be6d793203183fe1856ffb8b720f00b48c2bb
CPU threads: 8; OS: Linux 4.15; UI render: default; VCL: gtk3
Locale: en-AU (en_AU.UTF-8); UI: en-US
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time: 2021-06-03_19:22:06
Calc: threaded

In detail, using the tab key allows me to cycle through the following elements, in order (as shown in screenshot):

1. Search field
2. "All" tick box
3. "Show only the current item" button
4. "Hide only the current item" button
5. Value list (use down and up arrows to navigate inside the list)
6. Cancel
7. OK
8. "Sort Ascending" (and other options in that top list can also be navigated with up and down arrows)

So I can access all items in the dialogue with tab, up and down.

I also tested version 7.0.4, and I could access that top list with the tab key as well.

As this is two people not able to reproduce, and as Roman's question hasn't been answered in 10 months, I will mark as WORKSFORME. But please feel free to reopen with more details about your platform if you can still reproduce with LO 7.2!
Comment 11 Stéphane Guillou (stragu) 2021-06-04 13:30:33 UTC
...and by "I can reproduce", I obviously mean "I can't reproduce"... Apologies.