Download it now!
Bug 102311 - Find does not initialize state of prev/next buttons UI
Summary: Find does not initialize state of prev/next buttons UI
Status: RESOLVED INSUFFICIENTDATA
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.1.4.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Find-Search
  Show dependency treegraph
 
Reported: 2016-09-20 14:18 UTC by yolo
Modified: 2017-05-31 10:45 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description yolo 2016-09-20 14:18:34 UTC
Have a Writer document open

Search for a word that exists at least once
control+f "word"
- Note: Find Next and Find Previous buttons are enabled

Click the red X to the left of Find Text field to close the Find toolbar
Click on another window
Click on Writer
Press control+f to open the find toolbar

BUG
Find Next and Find Previous buttons are disabled

EXPECTED
Find Next and Find Previous buttons to be enabled since there is text in the Find Text field.
Comment 1 yolo 2016-09-20 14:19:08 UTC
Similar to #99818
Comment 2 yolo 2016-09-20 14:20:48 UTC
ie. bug 99818
Comment 3 yolo 2016-09-20 14:25:02 UTC
Get around

After control+f when Find Previous and Find Next are incorrectly disabled
press right arrow to unselect search text
press space to modify Find Text value
press backspace to remote the space

Find Previous and Find Next are now enabled
Comment 4 Buovjaga 2016-10-13 09:57:14 UTC
(In reply to yolo from comment #0)
> EXPECTED
> Find Next and Find Previous buttons to be enabled since there is text in the
> Find Text field.

There is no text in the field after your steps.

Win 7 Pro 64-bit Version: 5.3.0.0.alpha0+
Build ID: e2f6c7f0d0cc14f851d7028ff846c5dc658a81c6
CPU Threads: 4; OS Version: Windows 6.1; UI Render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2016-10-10_23:08:02
Locale: fi-FI (fi_FI); Calc: group
Comment 5 Buovjaga 2016-10-13 18:26:38 UTC
Set to NEEDINFO.
Change back to UNCONFIRMED, if you still see text in 5.2.2 after closing and reopening the search. Change to RESOLVED WORKSFORME, if the problem went away.
Comment 6 QA Administrators 2017-05-02 11:36:18 UTC Comment hidden (obsolete)
Comment 7 QA Administrators 2017-05-31 10:45:31 UTC Comment hidden (obsolete)