Bug Hunting Session
Bug 102321 - [FILEOPEN] Rectangle shown instead of EMF+image
Summary: [FILEOPEN] Rectangle shown instead of EMF+image
Status: RESOLVED DUPLICATE of bug 39327
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: graphics stack (show other bugs)
Version:
(earliest affected)
3.6.0.4 release
Hardware: All All
: medium normal
Assignee: Bartosz
URL:
Whiteboard: interoperability
Keywords: filter:emf, regression
Depends on:
Blocks: EMF-WMF
  Show dependency treegraph
 
Reported: 2016-09-21 08:49 UTC by Ákos
Modified: 2017-08-25 12:46 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
The .doc file with inserted .emf image (181.50 KB, application/msword)
2016-09-21 08:49 UTC, Ákos
Details
The file rendered by LOWriter 5.2.1.2 and MSWord 2016 (134.64 KB, image/png)
2016-09-21 08:53 UTC, Ákos
Details
The file rendered by LOWriter 3.5.7.2 (90.17 KB, image/png)
2016-09-21 08:55 UTC, Ákos
Details
WMF File extracted from .doc file (77.29 KB, image/wmf)
2017-04-04 20:44 UTC, Bartosz
Details
Second EMF file extracted from test document (32.37 KB, image/x-emf)
2017-04-27 07:51 UTC, Bartosz
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ákos 2016-09-21 08:49:45 UTC
Created attachment 127503 [details]
The .doc file with inserted .emf image

In attached .doc file was inserted two .emf images. Instead of the images, only an empty rectangle is shown in LibreOffice 5.2.1.2 32 bit (win10 Ent 64bit)

In LO 3.5.7.2 is shown OK, but from LO 3.6.0.4 don't.
Comment 1 Ákos 2016-09-21 08:53:54 UTC
Created attachment 127504 [details]
The file rendered by LOWriter 5.2.1.2 and MSWord 2016
Comment 2 Ákos 2016-09-21 08:55:40 UTC
Created attachment 127505 [details]
The file rendered by LOWriter 3.5.7.2
Comment 3 Caolán McNamara 2016-09-28 19:45:56 UTC
export EMF_PLUS_DISABLE=1 makes it work, so its presumably a problem with emf+ support
Comment 4 Bartosz 2017-04-02 19:16:51 UTC

*** This bug has been marked as a duplicate of bug 103639 ***
Comment 5 Bartosz 2017-04-04 20:44:33 UTC
Created attachment 132338 [details]
WMF File extracted from .doc file
Comment 6 Bartosz 2017-04-27 07:51:19 UTC
Created attachment 132882 [details]
Second EMF file extracted from test document
Comment 7 Bartosz 2017-04-27 09:35:41 UTC
It seems that second image is not displayed correctly, even with latests fixes
Comment 8 Bartosz 2017-04-27 21:36:15 UTC
I could confirm that with latest changes whole document is displayed correctly.
Comment 9 Bartosz 2017-04-27 21:44:16 UTC

*** This bug has been marked as a duplicate of bug 103639 ***
Comment 10 Patrick Jaap 2017-04-28 11:48:25 UTC Comment hidden (obsolete)
Comment 11 Patrick Jaap 2017-04-28 11:55:09 UTC Comment hidden (obsolete)
Comment 12 Patrick Jaap 2017-04-28 12:06:25 UTC Comment hidden (obsolete)
Comment 13 Bartosz 2017-05-06 23:51:16 UTC
Hello Akos.
It seems that the issue with importing emf+ images was resolved in LibreOffice 5.4.
Please download the LibreOffice 5.4 Daily Build from website:
http://dev-builds.libreoffice.org/daily/master/

and check if the problem was resolved for you.

Could you please confirm that?
Comment 14 Bartosz 2017-05-07 01:02:22 UTC
I notice too thin lines width with many EMF+ files, exported by ChemDraw application.
With this commit, I have fixed all such issues:
https://gerrit.libreoffice.org/#/c/37319/
Comment 15 Bartosz 2017-05-08 22:44:43 UTC

*** This bug has been marked as a duplicate of bug 31814 ***
Comment 16 Timur 2017-08-24 17:49:37 UTC
I guess this is not a dupe of bug 31814 that's not really fixed but rather of bug 39327 that is.
Comment 17 Timur 2017-08-25 12:46:23 UTC

*** This bug has been marked as a duplicate of bug 39327 ***