Bug 102338 - shrink-to-fit text confuses printing, causing extra empty pages to print
Summary: shrink-to-fit text confuses printing, causing extra empty pages to print
Status: RESOLVED DUPLICATE of bug 57257
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
5.2.1.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-09-21 21:07 UTC by Jim Avera
Modified: 2021-11-17 13:27 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
demo spreadsheet (9.55 KB, application/vnd.oasis.opendocument.spreadsheet)
2016-09-21 21:07 UTC, Jim Avera
Details
demo spreadsheet (9.54 KB, application/vnd.oasis.opendocument.spreadsheet)
2016-09-21 21:11 UTC, Jim Avera
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jim Avera 2016-09-21 21:07:37 UTC
Created attachment 127531 [details]
demo spreadsheet

Appending text to a cell formatted with "shrink to fit" can cause another column to spring into existence.  The empty column is forced to be printed.  If there is not enough room horizontally, then extra page(s) are printed containing nothing.

It is as if LO examines a cell to see if it would overflow the cell width before realizing that overflow is impossible because "shrink to fit" is in effect.

In the attached spreadsheet, all cells in the first row are "shrink to fit", yet if the text in the right-most cell is "too long", an extraneous column is forced to exist and be printed.

STEPS TO REPRODUCE:

1. Open attached demo spreadsheet.
2. View->Page Break checked
3. Edit B1 to replace the "x" with "shrinked"
4. (optional) Print Preview

RESULTS: Column C springs into existence, even though empty, and is printed.

EXPECTED RESULTS: No new column appears; the text in B1 is shrunk to fit B1 without altering the number of columns or pages printed.
Comment 1 Jim Avera 2016-09-21 21:11:12 UTC
Created attachment 127532 [details]
demo spreadsheet
Comment 2 m.a.riosv 2016-09-22 12:24:04 UTC
Reproducible.
Version: 5.2.2.1 (x64)
Build ID: 3c2231d4aa4c68281f28ad35a100c092cff84f5d
CPU Threads: 4; OS Version: Windows 6.19; UI Render: default; 
Locale: es-ES (es_ES); Calc: group

It happens even without 'shrink to fit cell size' enable, if the text doesn't fit in the cell.
Comment 3 Xisco Faulí 2017-09-29 08:51:31 UTC Comment hidden (obsolete)
Comment 4 Jim Avera 2017-09-29 18:40:08 UTC
Bug is still there in master.  A new column is incorrectly created if text in the preceding column would overflow if shrink-to-fit were not in effect (but does not overflow because of that, so no new column should be added).

Version: 6.0.0.0.alpha0+
Comment 5 QA Administrators 2018-09-30 02:47:44 UTC Comment hidden (obsolete)
Comment 6 Jim Avera 2018-10-01 19:55:33 UTC
Bug is still there in Version: 6.2.0.0.alpha0+ 2018-09-23_18:22:34
Locale: en-US (en_US.UTF-8); Calc: threaded
Comment 7 Jim Avera 2018-10-01 20:00:00 UTC
Changes title to make more clear that extra empty pages may be printed
Comment 8 QA Administrators 2019-10-02 02:55:55 UTC Comment hidden (obsolete)
Comment 9 QA Administrators 2021-10-02 03:39:34 UTC Comment hidden (obsolete)
Comment 10 Kevin Suo 2021-11-17 13:27:02 UTC
Mark as duplicate of bug 57257. Feel free to reset to NEW if you disagree.

*** This bug has been marked as a duplicate of bug 57257 ***