Bug 102508 - FILEOPEN: a file generated by an external application does not show all embedded images
Summary: FILEOPEN: a file generated by an external application does not show all embed...
Status: RESOLVED DUPLICATE of bug 101000
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.1.4.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bisected, regression
Depends on:
Blocks:
 
Reported: 2016-09-25 09:50 UTC by mk01
Modified: 2016-09-25 20:54 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
sample file displaying the error (250.58 KB, application/vnd.oasis.opendocument.text)
2016-09-25 09:50 UTC, mk01
Details
Screen shot from AOO 4, showing correct output (150.18 KB, image/jpeg)
2016-09-25 09:51 UTC, mk01
Details
Screen Shot from LO5, showing only two pictures (112.49 KB, image/jpeg)
2016-09-25 09:52 UTC, mk01
Details

Note You need to log in before you can comment on or make changes to this bug.
Description mk01 2016-09-25 09:50:02 UTC
User-Agent:       Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:49.0) Gecko/20100101 Firefox/49.0
Build Identifier: Version: 5.1.4.2 Build-ID: 1:5.1.4-0ubuntu1

 I generate ODT files from a web database. I create content.xml, meta.xml, manifest, Pictures/*

I also pack some images into the ODT file. AOO 4.x shows all three images in my sample file. LO only shows the first two.

The same behavior is displayed on Windows with LO 5 (latest stable version)

Reproducible: Always

Steps to Reproduce:
1. open attached file
2. Scroll to "Startorte"

Actual Results:  
The table should show three images.
It only shows two

When more images are requested, only the first two are shown.
The error also appears in Layouts not generating a table

Expected Results:  
Three images should be shown in the table




Reset User Profile?No
Comment 1 mk01 2016-09-25 09:50:57 UTC
Created attachment 127617 [details]
sample file displaying the error
Comment 2 mk01 2016-09-25 09:51:44 UTC
Created attachment 127618 [details]
Screen shot from AOO 4, showing correct output
Comment 3 mk01 2016-09-25 09:52:30 UTC
Created attachment 127619 [details]
Screen Shot from LO5, showing only two pictures
Comment 4 MM 2016-09-25 11:35:50 UTC
Unconfirmed with v5.0.6.3 under mint 17.3 x64.
Confirmed with v5.2.1.2 under ubuntu 16.04 x64.
Confirmed with v5.1.5.2 under windows 7 x64.
Comment 5 raal 2016-09-25 20:23:27 UTC
This seems to have begun at the below commit.
Adding Cc: to Caolán ; Could you possibly take a look at this one? Thanks

author	Caolán McNamara <caolanm@redhat.com>	2015-11-11 13:34:43 (GMT)
committer	Caolán McNamara <caolanm@redhat.com>	2015-11-19 09:31:00 (GMT)
commit	de0432a9256188c7b5cd1a83858311e68c890ebf (patch)

36819a8a88302af3a9b955eb7190aad1ef571a38 is the first bad commit
commit 36819a8a88302af3a9b955eb7190aad1ef571a38
Author: Norbert Thiebaud <nthiebaud@gmail.com>
Date:   Thu Nov 19 06:59:42 2015 -0800

    source sha:de0432a9256188c7b5cd1a83858311e68c890ebf

 git bisect log
# bad: [05d11632892a322664fb52bac90b2598b7fb7544] source sha:5616d22b57a9a5e57d545e912e029162a230829b
# good: [c1efd324c6ad448ac9edb030dc9738b9e6899e4d] source sha:ab465b90f6c6da5595393a0ba73f33a1e71a2b65
git bisect start 'origin/master' 'oldest'
# good: [97526ab777da7e58ce283c05498262ecdd4d6f7f] source sha:4ea70f87f7a2b61eda6e5ab1f48debf6fcfadc1f
git bisect good 97526ab777da7e58ce283c05498262ecdd4d6f7f
# good: [86fee7ded76d9c2756ccab6aef160a2d7fab0ab6] source sha:1b62841b1859ae3443e2bf1ebe99ec3d6afb6cc2
git bisect good 86fee7ded76d9c2756ccab6aef160a2d7fab0ab6
# good: [11864a7db429a57aeea021e0b3f1fb1412282d32] source sha:e5b721a14c1c8e5261a70588b30353cbb5bd55c6
git bisect good 11864a7db429a57aeea021e0b3f1fb1412282d32
# good: [7d52a87c0aa24498584ec522705cfae3a3a5a038] source sha:479df22d0b4b0e0393fcf621e7380b38415bcef8
git bisect good 7d52a87c0aa24498584ec522705cfae3a3a5a038
# bad: [bea538a879f50238f4c9c6f05e3d7390db9d76c7] source sha:7289a140fc68dc898ba2b2357cc960968195f236
git bisect bad bea538a879f50238f4c9c6f05e3d7390db9d76c7
# bad: [ad146f48b7f50d159d5b96f1c118cdb8412a98b8] source sha:91cbbb7797f048834b51690e9fab60aa778b1e44
git bisect bad ad146f48b7f50d159d5b96f1c118cdb8412a98b8
# bad: [e19c6163b0c6f5c6618cefd870a31522957fb620] source sha:ff522704109078a0cde844c74d608137b7c70f42
git bisect bad e19c6163b0c6f5c6618cefd870a31522957fb620
# bad: [cb343d9d1273b0981a35f9629a32aace88bc0609] source sha:bb2ee8c2b550186e48ca5f069dcf8a9d69d65729
git bisect bad cb343d9d1273b0981a35f9629a32aace88bc0609
# good: [dee525d2053607f9651075bead2f32ca32d6c40b] source sha:526bbbbd2f8eb227bc0dacd755a6c72511adf976
git bisect good dee525d2053607f9651075bead2f32ca32d6c40b
# bad: [47b0f459600b21f862998451a23173b53ace80c8] source sha:8311c6ed4970d22e7a6459fa7ed2779560e5e11d
git bisect bad 47b0f459600b21f862998451a23173b53ace80c8
# bad: [f224c781b4257dcfcb431d5928f8d54d0b2fdf78] source sha:c94cf0cf5f10edb45a74a58c95c306b0d271645b
git bisect bad f224c781b4257dcfcb431d5928f8d54d0b2fdf78
# bad: [179ce594887adf39f57a3d04abe4c7df0c0a7a85] source sha:5319def848e855068512f0f895086ff7a1f9e44f
git bisect bad 179ce594887adf39f57a3d04abe4c7df0c0a7a85
# bad: [36819a8a88302af3a9b955eb7190aad1ef571a38] source sha:de0432a9256188c7b5cd1a83858311e68c890ebf
git bisect bad 36819a8a88302af3a9b955eb7190aad1ef571a38
# first bad commit: [36819a8a88302af3a9b955eb7190aad1ef571a38] source sha:de0432a9256188c7b5cd1a83858311e68c890ebf
Comment 6 Xisco Faulí 2016-09-25 20:54:32 UTC

*** This bug has been marked as a duplicate of bug 101000 ***