Bug 102694 - FILEOPEN (xlsx) pivot tables with groups takes long time to import
Summary: FILEOPEN (xlsx) pivot tables with groups takes long time to import
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
5.2.0.4 release
Hardware: All All
: medium normal
Assignee: Tamás Zolnai
QA Contact:
URL:
Whiteboard: target:5.3.0 target:5.2.4
Keywords: perf
: 89264 (view as bug list)
Depends on:
Blocks: Pivot-Table
  Show dependency treegraph
 
Reported: 2016-09-27 20:23 UTC by Tamás Zolnai
Modified: 2017-06-19 13:16 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
pivot tables with groups (219.97 KB, application/vnd.openxmlformats-officedocument.spreadsheetml.sheet)
2016-09-27 20:23 UTC, Tamás Zolnai
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Tamás Zolnai 2016-09-27 20:23:44 UTC
Created attachment 127685 [details]
pivot tables with groups

The attached xlsx file takes a lot time to import. (I waited 20 minutes before shut down the application.)
My computer parameters are: Intel i7-6700 CPU, 16GB RAM, SSD.
The expected import time is less than a minute.

The issue is related to the groups of the pivot tables. All pivot tables in the test document have the same source range and so share the same groups.
Comment 1 Tamás Zolnai 2016-09-27 20:27:01 UTC
A fix was added to master:
https://cgit.freedesktop.org/libreoffice/core/commit/?id=3b64a198568d5b2bb14066581aca112cc6182fd7

With that codechange import time is less than a minute.
Comment 2 Commit Notification 2016-10-09 10:18:16 UTC
Tamás Zolnai committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=03a1143cc75161dab56b20f1ab9e723ddd0caa8e

tdf#102694, bnc#957991: Improve pivot cache reading performance

It will be available in 5.3.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 3 Yousuf Philips (jay) 2016-10-21 10:05:42 UTC
Congrats on the fix. 20 minutes to half a minute is a huge improvement.

http://zolnaitamas.blogspot.ae/2016/10/improving-pivot-table-import.html

Added it to the release notes.
https://wiki.documentfoundation.org/ReleaseNotes/5.3#Improvements_in_OpenXML_filter
Comment 4 Commit Notification 2016-10-22 18:06:53 UTC
Tamás Zolnai committed a patch related to this issue.
It has been pushed to "libreoffice-5-2":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=29999ea70626a4b1dd312ad6e07f1131b6449f93&h=libreoffice-5-2

tdf#102694, bnc#957991: Improve pivot cache reading performance

It will be available in 5.2.4.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 5 Buovjaga 2017-06-19 13:16:09 UTC
*** Bug 89264 has been marked as a duplicate of this bug. ***