Bug 102915 - Restore Clear Direct Formatting (an uno:ResetAttributes command) to the context menu
Summary: Restore Clear Direct Formatting (an uno:ResetAttributes command) to the conte...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.2.0.4 release
Hardware: All All
: low enhancement
Assignee: Yousuf Philips (jay)
QA Contact:
URL:
Whiteboard: target:5.5.0 target:5.4.0.1
Keywords:
: 102141 (view as bug list)
Depends on:
Blocks: Context-Menu Clone-Clear-Formatting
  Show dependency treegraph
 
Reported: 2016-10-01 19:18 UTC by tagezi
Modified: 2017-06-10 15:23 UTC (History)
11 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description tagezi 2016-10-01 19:18:03 UTC
User-Agent:       Mozilla/5.0 (X11; Linux x86_64; rv:45.0) Gecko/20100101 Firefox/45.0
Build Identifier: Version: 5.2.3.0.0+

When I try to remove the formatting of the text.

Reproducible: Always

Steps to Reproduce:
1.Open any document with text or create new and add text in it
2. Select text
3. Click the right mouse button
Actual Results:  
The item Clear Direct Formatting is not in the context menu

Expected Results:  
The item Clear Direct Formatting is in the context menu




Reset User Profile?Yes
Comment 1 kompilainenn 2016-10-01 20:33:27 UTC
it's "improvement" of usability from UI team
Comment 2 m.a.riosv 2016-10-01 21:48:38 UTC
It was removed bug#86606
Comment 3 tagezi 2016-10-01 22:02:13 UTC
(In reply to m.a.riosv from comment #2)
> It was removed bug#86606

Can you specify a link to the decision to remove this item?
Comment 4 m.a.riosv 2016-10-01 22:44:10 UTC
The committer is member of the UX team.

You can ask on the UX ML http://nabble.documentfoundation.org/UX-Advise-f3619688.html
Comment 5 V Stuart Foote 2016-10-02 01:03:59 UTC
Direct formatting controls present with default Context menu(s) have been removed by design (bug 86606). Ability to customize context menu has been implemented. For the general case deemphais of direct formatting by removal from context menu is the desired direction for the UI as it bolsters consistent use of Styles.
Comment 6 tagezi 2016-10-02 08:55:29 UTC
I do not understand the logic of how will promote the use of styles of deleting the item . It is better to remove the buttons "bold", "italics" and "underline" from the toolbar.

However, I use this option very often, because the first thing I need to do in the document before you start to work with it is to remove all the manual formatting. (For example, https://wiki.documentfoundation.org/File:LO4.x_Reference_A4_Calc_Impress_Base.odt , such files exist 32).
Because the Design team also decided to remove some of the keyboard shortcuts (for example, CTRL + F4, apparently in order that human could consider about close a document one more time), the document management, with only the keyboard is not convenient. Also, I mark a place in a document in yellow colour to quickly find it,  if I have questions. Using styles is not desirable for them, because after work, I have to be sure that deleted all such notes. Thus, I keep one hand on the keyboard and the other on the mouse in order to run faster.
I tried to add this item to the menu. But when installing the new version, he disappears again. Also, I will have to add it each time when the user profile reset , if the bug is associated with it. So, I add it for the third time in the menu for the last 2 months.
Comment 7 Cor Nouws 2016-10-02 14:38:31 UTC
(In reply to V Stuart Foote from comment #5)
> Direct formatting controls present with default Context menu(s) have been
> removed by design (bug 86606).

Few things that I notice:
1. Dialogs Character, Paragraph and Bullets and Numbering are also direct formatting tools. And present in the context menu.
2. Clear Direct Formatting is to be considered a styles tool.
3. Further more I don't see any mention, nor argumentation to remove Clear Direct Formatting in bug 86606. 

So I consider this bug report valid.
Comment 8 V Stuart Foote 2016-10-02 16:48:33 UTC
@Cor, *

It was removed during Maxim's work on making all src based context menus user customizable implementing XML configuration for bug 93837 

Followed recommended simplifications of the context menu per Design UX decision as argued in bug 81132 and bug 86606

With XML based customization now supported--no reason to keep unhelpful defaults in the context menus.

=-=

For those that prefer it available on Context menus, trivial now to add it back as a per user customization recorded to profile.

Tools -> Customize -> Context Menus tab

Select the Text menu from dropdown list.

Select the Add button.

Browse the Category list to the Format class.

Scroll the Commands list to "Clear Direct Formatting".

Add button and close to add it to the Menu content for the context menu.

Drag up or down to adjust its position on Context menu.


=-ref-=
https://cgit.freedesktop.org/libreoffice/core/commit/?id=447c313586e9b36acff393feae15f5e1b63861ae
Comment 9 tagezi 2016-10-02 16:57:17 UTC
(In reply to V Stuart Foote from comment #8)
> @Cor, *

> With XML based customization now supported--no reason to keep unhelpful
> defaults in the context menus.
Could you give a link to studies that suggest that this item is not needed? Or is it the opinion of 5 people who decide that the 2-million people are needed and what is not?
Comment 10 V Stuart Foote 2016-10-02 17:25:53 UTC
(In reply to tagezi from comment #9)
> Could you give a link to studies that suggest that this item is not needed?
> Or is it the opinion of 5 people who decide that the 2-million people are
> needed and what is not?

See also, and we meet continually http://webchat.freenode.net/?channels=libreoffice-design

and hold Weekly meeting in-person via Google Hangouts

https://wiki.documentfoundation.org/Design/Meetings

feel free to drop in and contribute.
Comment 11 tagezi 2016-10-02 17:50:51 UTC
(In reply to V Stuart Foote from comment #10)
> (In reply to tagezi from comment #9)
> > Could you give a link to studies that suggest that this item is not needed?
> > Or is it the opinion of 5 people who decide that the 2-million people are
> > needed and what is not?
> 
> See also, and we meet continually
> http://webchat.freenode.net/?channels=libreoffice-design
> 
> and hold Weekly meeting in-person via Google Hangouts
> 
> https://wiki.documentfoundation.org/Design/Meetings
> 
> feel free to drop in and contribute.

I'm sorry, but that you have indicated there is no new information. Removing the item is not only logical, but also harmful. And the fact that the design team did not see such a simple thing very frustrating. I feel that with this approach, the design team will create us something like MSO - absolutely not usability thing.

Moreover, I have already said:

(In reply to V Stuart Foote from comment #10)
> (In reply to tagezi from comment #9)
> I tried to add this item to the menu. But when installing the new version,
> he disappears again. Also, I will have to add it each time when the user
> profile reset , if the bug is associated with it. So, I add it for the third
> time in the menu for the last 2 months.

In addition, I can say that I am in a chat under the same nickname almost constantly (24/7/365).
Comment 12 Cor Nouws 2016-10-02 18:28:41 UTC
Hi Stuart,

Thanks for the new arguments. However, to me it looks that this command has been removed maybe in a slip..

(In reply to V Stuart Foote from comment #8)
> @Cor, *
> 
> It was removed during Maxim's work on making all src based context menus
> user customizable implementing XML configuration for bug 93837 

For now, I have see no argumentation to remove that specific command.

> Followed recommended simplifications of the context menu per Design UX
> decision as argued in bug 81132 and bug 86606

Which is a good thing in general.

> With XML based customization now supported--no reason to keep unhelpful
> defaults in the context menus.

I don't think it's unhelpful at all.
Copy/Cut/Paste are in the context menu, main menu, toolbars and have shortcuts.
Clear Direct Formatting is maybe not that often used, but at least as important.

See also my arguments in comment 7.
Comment 13 Cor Nouws 2016-10-02 18:30:38 UTC
Maybe looking at this specific commend in a UX-meeting (again?) is useful?
Comment 14 V Stuart Foote 2016-10-02 18:39:13 UTC
@Jay, Heiko, Samuel, Kendy

Did Maxim overshoot during conversion of the context menus for customization? Should a "Clear Direct Formatting" be included by default on the context menu?

Personally, I don't think so as I find that between the <Ctrl>+M global shortcut, the Formatting toolbar and the Format menu entry there is more than sufficient coverage without needing an item on the context menu(s).

Stuart
Comment 15 Cor Nouws 2016-10-02 18:59:44 UTC
(In reply to V Stuart Foote from comment #14)
> @Jay, Heiko, Samuel, Kendy

> Personally, I don't think so as I find that between the <Ctrl>+M global
> ...

and for your convenience: comment 7, comment 11 and comment 12 give arguments for the other view ;)
Comment 16 tagezi 2016-10-02 19:18:42 UTC
(In reply to V Stuart Foote from comment #14)
> @Jay, Heiko, Samuel, Kendy
> 
> Personally, I don't think so as I find that between the <Ctrl>+M global
> shortcut, the Formatting toolbar and the Format menu entry there is more
> than sufficient coverage without needing an item on the context menu(s).

Following your logic, we can remove all the context menu.

Since I use two hands when editing documents, one on the keyboard, and the other on the mouse, I'll lose up to 3 seconds in any other mode. It can be up to 3-4 minutes on a document page, just to wave a hand. For me, the most convenient to use the context menu.

The context menu has a lot of other useless functions (such as copy (Ctrl+C), cut (Ctrl+X), paste (Ctrl+V), paragraph (because it has to be done through styles)). Why Clear Direct Formatting?
Comment 17 V Stuart Foote 2016-10-02 19:50:13 UTC
Well, clearly not a bug as it was done intentionally and functions as intended. At most an enhancment--if ill advised.

Adjusting summary.
Comment 18 kompilainenn 2016-10-02 20:05:08 UTC
tagezi: do it yourself =) this is easy patch.
Comment 19 Heiko Tietze 2016-10-02 20:18:46 UTC
(In reply to V Stuart Foote from comment #14)
> @Jay, Heiko, Samuel, Kendy

You argumentation to focus on styles make sense. Likewise tagezi's concerns of missing functionality. Let's ask the LibO community to get an impression.

https://plus.google.com/107566594492891737454/posts/T9RpbhVM2cS
Comment 20 kompilainenn 2016-10-03 07:01:02 UTC
(In reply to Heiko Tietze from comment #19)
> (In reply to V Stuart Foote from comment #14)
> > @Jay, Heiko, Samuel, Kendy
> 
> You argumentation to focus on styles make sense. Likewise tagezi's concerns
> of missing functionality. Let's ask the LibO community to get an impression.
> 
> https://plus.google.com/107566594492891737454/posts/T9RpbhVM2cS

=) 

the vast majority want to have a menu item

Heiko, such surveys need make for any changes in UI
Comment 21 tagezi 2016-10-03 10:13:59 UTC
(In reply to kompilainenn from comment #20)
> (In reply to Heiko Tietze from comment #19)
> > https://plus.google.com/107566594492891737454/posts/T9RpbhVM2cS
> the vast majority want to have a menu item
> 
> Heiko, such surveys need make for any changes in UI

It is strange that we should have a debate and ballot on this simple point. This is a very simple logical chain.
Assume people are novices. When they edit a document, they use the button before their eyes, that is, those that are on the panel and they will not use the Main or context menu, if they see necessary function. That is, for them it does not matter what is in the context menu.
Now suppose that a person is skilled user of LO. If they create a new document, all items in the context menu are meaningless to them. They do not use it, because almost everything they can done by hot keys, which is much faster.
But we know that a very large number of documents have a history of several years, and can be created by users that can not / do not want to use styles (this is often true for MSO users). In this case, the editors spend time to put in order the document. Moreover, if the document is a fairly simple format, it is enough Ctrl+A and Ctrl+M. But if the formatting is complex, the editors allocate small piece of text, reset a format and  set a text style for this piece. Natural, as an experienced user, they notice that they spend a lot of time on their hand movements, and a logical, to use of the right mouse button, that is the context menu for Clear Direct Formatting.
There is one more category of users having an average experience. This is the largest group is divided into two parts.
The first part wants to study and to use LO efficiently. They gradually come to the opinion of experienced users and they will need the item.
The second group does not want to learn, they want that work will be performed. Ideally, they want a maximum one button that will carry them any request. They tolerate the context menu, because they can not do anything  about it. They do not know how to use styles, what document structure is, and that the hot keys perform a specific action more quickly, and do not want to know these. Their task is only to the early completion of what they do.

All of this can be seen if you draw a decision tree.
Of course, users who want a single button for all occasions much more. And then the question is, for whom do we make our product, for people who are not interested anything, or for people who want to use LO effectively?

Normally, when developers do an application redesign, developers begin with the study of business processes in which items are involved. And only after this, they decide on  their movement or removal.

So it all looks very strange to me. And the fact that the return consciously deleted functionality (ie consciously made mistakes) is now an enhancement, not a bug.
Comment 22 Yousuf Philips (jay) 2016-10-03 17:54:48 UTC
(In reply to Cor Nouws from comment #7)
> Few things that I notice:
> 1. Dialogs Character, Paragraph and Bullets and Numbering are also direct
> formatting tools. And present in the context menu.

They are present as they arent in the toolbars and are only available in the menus.

> 2. Clear Direct Formatting is to be considered a styles tool.

Its a direct formatting tool as it doesnt affect styles.

(In reply to Cor Nouws from comment #12)
> Thanks for the new arguments. However, to me it looks that this command has
> been removed maybe in a slip..

It was intentional. :D

> I don't think it's unhelpful at all.
> Copy/Cut/Paste are in the context menu, main menu, toolbars and have
> shortcuts.

Clipboard functions are the most used functions in any app and they are the only exception to be included in all places, but likely not for long. (bug 84848)

> Clear Direct Formatting is maybe not that often used, but at least as
> important.

Definitely important enough that it was added to the toolbars.

(In reply to V Stuart Foote from comment #14)
> Did Maxim overshoot during conversion of the context menus for
> customization? Should a "Clear Direct Formatting" be included by default on
> the context menu?

So I was removing it in 5.1/5.2 in this patch ( https://gerrit.libreoffice.org/#/c/20446/ ) and Maxim suggested i not push it in as it would conflict with his work and he would incorporate my changes into his patch.

(In reply to tagezi from comment #11)
> I'm sorry, but that you have indicated there is no new information. Removing
> the item is not only logical, but also harmful. And the fact that the design
> team did not see such a simple thing very frustrating. I feel that with this
> approach, the design team will create us something like MSO - absolutely not
> usability thing.

The discussion regarding the removal of direct formatting entries is in bug 81132 and i removed the entry from the context menu once it was added into the formatting toolbar. With easy access to the option in the toolbar, it shouldnt be available in the context menu.

*** This bug has been marked as a duplicate of bug 102141 ***
Comment 23 V Stuart Foote 2016-10-03 18:51:28 UTC
*** Bug 102141 has been marked as a duplicate of this bug. ***
Comment 24 V Stuart Foote 2016-10-03 18:54:03 UTC
@Jay, *

Since Heiko has the user survey linked here, makes more sense to close bug 102141 as a the duplicate regards this enhancement request and discussion of restoring a "Clear Direct Formatting" .uno:ReesetAttributes based entry on the Writer context menu.
Comment 25 Cor Nouws 2016-10-03 19:19:14 UTC Comment hidden (obsolete)
Comment 26 Cor Nouws 2016-10-03 19:20:54 UTC
Hi all,

Sorry for the long read.
Thanks for reopening Stuart and Jay and Stuart for showing links for discussion.

Reasons I see for restoring the item:

 = = = =
(In reply to V Stuart Foote from comment https://bugs.documentfoundation.org/show_bug.cgi?id=102141#4)
> See discussions for removal in ...

First: all (maybe all but one) of the mentioned links do _not_ discuss at all why 'Clear Direct Formatting'  should be removed or not.

(In reply to V Stuart Foote from comment https://bugs.documentfoundation.org/show_bug.cgi?id=102141#4)
> See discussions for removal in UX Design minutes and in

I've checked ~40 minutes from 2014/2015 and there was no mention of any discussion or whether or not to remove 'Clead Direct Formatting'.
Of course I may have missed it, in which case I would appreciate to learn the arguments.

> bug 81132
> https://gerrit.libreoffice.org/11111
> https://gerrit.libreoffice.org/13214
> 
> and finalized
> bug 86606
> https://gerrit.libreoffice.org/14979

 = = = =
Second: also other linked issues (here or in 102915) do not have any argumentation on the subject.

 = = = =

Third, In reply to Yousuf Philips (jay) from comment #22)

> (In reply to Cor Nouws from comment #7)
> > Few things that I notice:
> > 1. Dialogs Character, Paragraph and Bullets and Numbering are also direct
> > formatting tools. And present in the context menu.
> 
> They are present as they arent in the toolbars and are only available in the
> menus.

The argument was that all direct formatting items were removed.

> > 2. Clear Direct Formatting is to be considered a styles tool.
> 
> Its a direct formatting tool as it doesnt affect styles.

It is a powerful tool to work with styles properly.
I'm really sorry that I have to type such an obvious argument down.

> (In reply to Cor Nouws from comment #12)
> > Clear Direct Formatting is maybe not that often used, but at least as
> > important.
> 
> Definitely important enough that it was added to the toolbars.

A toolbar is not a context menu.
The context menu can be started without moving the mouse, and even without using the mouse (properties key or extra in LibreOffice Shift+F10)
Further more: as people access the context menu often, there is a good change they will discover the item in the neatly trimmed context menu (compared to the richly filled tool bar), thus enhancing the use of tools for working with clear (... ;) ) styles.

> (In reply to V Stuart Foote from comment #14)
> > Did Maxim overshoot during conversion of the context menus for
> > customization? Should a "Clear Direct Formatting" be included by default on
> > the context menu?
> 
> So I was removing it in 5.1/5.2 in this patch (
> https://gerrit.libreoffice.org/#/c/20446/ ) and Maxim suggested i not push
> it in as it would conflict with his work and he would incorporate my changes
> into his patch.

You kindly asked him to do so in your comment from December 15 2015.
I see no trace however of deliberate choice to remove the function.

> (In reply to tagezi from comment #11)
> > I'm sorry, but that you have indicated there is no new information. Removing
> > the item is not only logical, but also harmful. And the fact that the design
> > team did not see such a simple thing very frustrating. I feel that with this
> > approach, the design team will create us something like MSO - absolutely not
> > usability thing.
> 
> The discussion regarding the removal of direct formatting entries is in bug
> 81132 and i removed the entry from the context menu once it was added into
> the formatting toolbar. With easy access to the option in the toolbar, it
> shouldnt be available in the context menu.

As written before: 
- there is no separate discussion on removing the choice 'Clead Direct Formatting'.
- access to the toolbar cannot be considered equal to access to the context menu.

 = = = =

Fourth: comment #c19
76% of 125 votes say yes to the question "Do you need the function "Clear Direct Formatting" in Writer's context menu?"
Comment 27 Yousuf Philips (jay) 2016-10-03 21:20:34 UTC
(In reply to V Stuart Foote from comment #24)
> Since Heiko has the user survey linked here, makes more sense to close bug
> 102141 as a the duplicate regards this enhancement request and discussion of
> restoring a "Clear Direct Formatting" .uno:ReesetAttributes based entry on
> the Writer context menu.

As this bug was opened afterwards and the discussion of whether it was intentional or not was addressed there as you asked in comment 8, this was marked as the duplicate. When it comes to the g+ survey, i wouldnt place that much faith in the results due to the limited scope of the audience, the question asked and the lack of additional questions like :-

do you use this command?
how often do you use the command?
do you use the shortcut key?
where do you primarily activate this command?
what version of LO are you running?
have you seen/used the command in the toolbar?
is it better to have this command in the toolbar or context menu?

This command has low usage metrics, isnt important enough to be in all three locations (menu, toolbar, context menu), and takes up valuable space which is against the HIG. 

(In reply to Cor Nouws from comment #26)
> First: all (maybe all but one) of the mentioned links do _not_ discuss at
> all why 'Clear Direct Formatting'  should be removed or not.

Yes no explicitly talk about the removal of that specific entry. I removed it based on the toolbar, menu and context menu reorganization work I did based on the OOo usage metrics.

> I've checked ~40 minutes from 2014/2015 and there was no mention of any
> discussion or whether or not to remove 'Clead Direct Formatting'.
> Of course I may have missed it, in which case I would appreciate to learn
> the arguments.

No there was no discussion in the meetings regarding this particular entry, it was about removing direct formatting entries in general (bug 86606).

> Second: also other linked issues (here or in 102915) do not have any
> argumentation on the subject.

I assume you meant bug 102141 and the issue being addressed was whether it was intentional or not, which stuart also asked here in comment 8.

> Third, In reply to Yousuf Philips (jay) from comment #22)
> The argument was that all direct formatting items were removed.

Yes all direct formatting that is available in the toolbars and isnt behind a dialog.

> It is a powerful tool to work with styles properly.
> I'm really sorry that I have to type such an obvious argument down.

Seems we are talking about different things here.

> A toolbar is not a context menu.
> The context menu can be started without moving the mouse, and even without
> using the mouse (properties key or extra in LibreOffice Shift+F10)
> Further more: as people access the context menu often, there is a good
> change they will discover the item in the neatly trimmed context menu
> (compared to the richly filled tool bar), thus enhancing the use of tools
> for working with clear (... ;) ) styles.

Things are more discoverable and more used in the toolbar than they will be in the context menu because they are in plain sight and dont require the opening of the context menu for discoverability.

> You kindly asked him to do so in your comment from December 15 2015.
> I see no trace however of deliberate choice to remove the function.

https://gerrit.libreoffice.org/#/c/20446/1/sw/source/ui/app/mn.src@135

> As written before: 
> - there is no separate discussion on removing the choice 'Clead Direct
> Formatting'.
> - access to the toolbar cannot be considered equal to access to the context
> menu.

Yes they arent equal. Access through the toolbar is many times higher.

> Fourth: comment #c19
> 76% of 125 votes say yes to the question "Do you need the function "Clear
> Direct Formatting" in Writer's context menu?"

Read above about my thoughts of the survey.

Would suggest this discussion be taken to the weekly meeting, so that all points can be discussed and voted on.
Comment 28 kompilainenn 2016-10-04 06:19:30 UTC
I add my five cents:

Yousuf wanted delete from context menu ALL item for manual formatting.

But the idea of removing the possibility of direct formatting from the context menu involves the removal of items to CREATE a direct formatting. Is not it so? 
Item "Clear Direct Formatting" uses for DELETE manual formatting and helps user in the work with styles
Comment 29 Alex Thurgood 2016-10-04 13:59:23 UTC
My concern here is that there has been an assumption that deleting the entry from the context menu will somehow orient users to apply styles rather than direct formatting.

For that to be the case, the styles have to work reproducibly and reliably. This is clearly not the case with the default Title/Header styles at least, and the "workaround" given on the bug report associated with incorrect application of Title/Header styles was to use the "Clear formatting" command. This particular bug (I don't have the reference right now), FWIW, is still around today.

One can not and should not be a proponent of a workaround for a given bug and then make access to the tool required to apply the workaround more difficult. It defeats user expectations and leads to disenchantment in user perception of the development process.
Comment 30 Alex Thurgood 2016-10-04 14:05:23 UTC
I would add a question as to whether anyone gave any thought to those with motor difficulties or RSI where having to move the mouse cursor up to the Styles dialog and clicking on Remove formatting is far more of a pain than right mouse button clicking on the offending point in the document, generally where one is editing, and choosing the same command from the context menu ?
Comment 31 Cor Nouws 2016-10-04 14:11:32 UTC
(In reply to Alex Thurgood from comment #30)
> I would add a question as to whether anyone gave any thought to those with
> motor difficulties or RSI where having to move the mouse cursor up to the
> Styles dialog and clicking on Remove formatting is far more of a pain than
> right mouse button clicking on the offending point in the document,
> generally where one is editing, and choosing the same command from the
> context menu ?

from comment #26: "A toolbar is not a context menu.
The context menu can be started without moving the mouse, and even without using the mouse (properties key or extra in LibreOffice Shift+F10)
Further more: as people access the context menu often, there is a good change they will discover the item in the neatly trimmed context menu (compared to the richly filled tool bar), thus enhancing the use of tools for working with clear (... ;) ) styles."
Comment 32 Alex Thurgood 2016-10-04 14:24:15 UTC
(In reply to Cor Nouws from comment #31)

> 
> from comment #26: "A toolbar is not a context menu.
> The context menu can be started without moving the mouse, and even without
> using the mouse (properties key or extra in LibreOffice Shift+F10)
> Further more: as people access the context menu often, there is a good
> change they will discover the item in the neatly trimmed context menu
> (compared to the richly filled tool bar), thus enhancing the use of tools
> for working with clear (... ;) ) styles."

Agreed, my point exactly :-)
Comment 33 Cor Nouws 2016-10-04 19:55:18 UTC
to facilitate fast resolving of this issue, I've already prepared a little patch in gerrit: https://gerrit.libreoffice.org/29526
Comment 34 Octavio Alvarez 2016-10-05 00:27:51 UTC
As a heavy user of styles, I'll allow myself to state that "Clear Direct Formatting" is way too useful as a styles-related tool. Even though it affects DF only, the tool is used in the context of styles.

The reason is really simple: without the existence of styles, "Direct Formatting" just becomes "Formatting" and the need for "Clear Direct Formatting" turns into "Clear All Formatting", without the distinction between the two types of formatting. So there is a reason why the command only clears direct formatting and nothing more.

Also, as I said on bug #86606 c18 [1], the statement that "Direct formatting has been removed from the default configuration of the context menu" is false. For it to be true, the items "Character" and "Paragraph" should be removed too from the menu. Those are nothing more than Direct Formatting.

My guess is that the intention was to remove "individual directly-applicable formatting attributes" from the context menu, like Font, Size, Bold, etc.

Furthermore, it is known that the Design Team has the intention of promoting the use of styles. For people willing to learn, the appearance of the words "Direct Formatting" in a menu as prominent as the context menu lets people grasp the idea that there is some particular kind of formatting that is called "direct", and in consequence, there has to be another kind of non-direct formatting. This, in turn, helps people understand that there are *two* ways to apply formatting attributes to text.

In conclusion, the given arguments for removal make no sense and I consider it an unfortunate design decision. Restoring the option to the context menu would be the best way to proceed.

[1] https://bugs.documentfoundation.org/show_bug.cgi?id=86606#c18
Comment 35 Heiko Tietze 2016-10-14 18:11:21 UTC
Decision was made in the design team on Oct/14 to bring back the functionality in the context menu but move it into the upcoming styles submenu. Reason to do so is that we have remove direct formatting in the toolbar now and want to promote styles in general.
Comment 36 tagezi 2016-10-14 19:24:27 UTC
(In reply to Heiko Tietze from comment #35)
> Decision was made in the design team on Oct/14 to bring back the
> functionality in the context menu but move it into the upcoming styles
> submenu. Reason to do so is that we have remove direct formatting in the
> toolbar now and want to promote styles in general.

How many time will people spend to click the item from the submenu?
It is not that there are the item in the menu or not. There are a large number of documents, which requires the removing of direct formatting, because they were made by ... Why if someone does not know how to work in the Writer, people who are able to work have to spend time?

Your promotion styles, does not remove the direct formatting from the documents, which were made since 97 year in MSO.
The problem is that the movement of the cursor or the hand of two seconds, poured to a quarter of an hour per a page. And when you want to remove direct formatting and assign a style for multi-page document, this movement begins to take hours.
Comment 37 Cor Nouws 2016-10-14 21:10:01 UTC
(In reply to tagezi from comment #36)
> (In reply to Heiko Tietze from comment #35)
> > Decision was made in the design team on Oct/14 to bring back the
> > functionality in the context menu but move it into the upcoming styles
> > submenu. Reason to do so is that we have remove direct formatting in the
> > toolbar now and want to promote styles in general.
> 
> How many time will people spend to click the item from the submenu?

It's good to have it ready at top in the submenu I think yes.

> It is not that there are the item in the menu or not. There are a large
> number of documents, which requires the removing of direct formatting,
> because they were made by ... Why if someone does not know how to work in
> the Writer, people who are able to work have to spend time?

If there is so much direct formatting in a file, I guess removing all is what is needed, not remove some and keep some other? Isn't it that then one can simply select large parts and clear at once?
Comment 38 m.a.riosv 2016-10-14 21:14:37 UTC
Sometimes it's not easy for me to understand why changes are done, but

(In reply to tagezi from comment #36)
> How many time will people spend to click the item from the submenu?

Almost the same, sub-menus open without click.

> It is not that there are the item in the menu or not. There are a large
> number of documents, which requires the removing of direct formatting,
> because they were made by ... Why if someone does not know how to work in
> the Writer, people who are able to work have to spend time?

If someone doesn't know she/he needs to learn, people able to work has another quicker ways like [Ctrl+M]

> Your promotion styles, does not remove the direct formatting from the
> documents, which were made since 97 year in MSO.

I hope so.

> The problem is that the movement of the cursor or the hand of two seconds,
> poured to a quarter of an hour per a page. And when you want to remove
> direct formatting and assign a style for multi-page document, this movement
> begins to take hours.

Are you talking about removing the direct format word by word. I think it's easy Menu/Edit/Select All [Ctrl+A]
and then
Menu/Format/Clear direct formating [Ctrl+M],
to get the whole document's body clear of direct formatting.
Comment 39 tagezi 2016-10-14 21:23:10 UTC
(In reply to Cor Nouws from comment #37)
> (In reply to tagezi from comment #36)
> > (In reply to Heiko Tietze from comment #35)
> > > Decision was made in the design team on Oct/14 to bring back the
> > > functionality in the context menu but move it into the upcoming styles
> > > submenu. Reason to do so is that we have remove direct formatting in the
> > > toolbar now and want to promote styles in general.
> > 
> > How many time will people spend to click the item from the submenu?
> 
> It's good to have it ready at top in the submenu I think yes.

I need to make speed measurement. I can not do speed measurements now, it takes time. I made measurements on the taskbar, and keyboard shortcuts, and this has led to very poor performance.
Reasoning without measurement, is a waste of time.
Comment 40 Octavio Alvarez 2016-10-14 23:35:33 UTC
A reminder:

This is just about restoring Clear Direct Formatting from the context menu. This *does not imply* removing it from anywhere else.

People will still have many other options for using this, like Ctrl+M the toolbar and the Format menu.
Comment 41 Peter Beurle 2016-10-17 08:43:27 UTC
Hurray, its back. Super handy for cleaning up other peoples documents.(In reply to Heiko Tietze from comment #35)
> Decision was made in the design team on Oct/14 to bring back the
> functionality in the context menu but move it into the upcoming styles
> submenu. Reason to do so is that we have remove direct formatting in the
> toolbar now and want to promote styles in general.

Hurray
Comment 42 Cor Nouws 2016-10-18 18:55:14 UTC
perfectly fine for me to adapt the patch (comment #33) to make a submenu Styles with at least some character styles.
  Bug 85940 - Accessing paragraph and character styles from context menu

If this needs more time (> few weeks?), I suggest to push the patch as is for the moment. OK?
Comment 43 Kumāra 2016-12-16 07:58:39 UTC
Wow... Pretty serious argument over one context menu item.

I don't need it but would still vote to have it back in the menu. (I use the function with a toolbar icon I added.)
Comment 44 Cor Nouws 2017-02-06 11:33:17 UTC
(In reply to Heiko Tietze from comment #35)
> Decision was made in the design team on Oct/14 to bring back the
> functionality in the context menu but move it into the upcoming styles
> submenu. Reason to do so is that we have remove direct formatting in the
> toolbar now and want to promote styles in general.

So we have three context menus where this is relevant:
normal context; table; text box

In normal text and tables, the lower part of the context menu is:
  Character
  Paragraph
  ... (some more)
  – – – – – – – – – 
  Edit Style

In a text box it is
  Character
  Paragraph
(no style applied there)

For normal and table I suggest the following:

  ... (some more)
  – – – – – – – – – 
  Clear Direct Formatting
  Styles > ..
  Edit Style

reasons:
- If clear direct formatting should be with styles, it must be with Edit Style too.
- Edit style is used often and I would not like hiding it

For a text box I suggests to simply add
  Clear Direct Formatting
at the bottom. No styling involved (Writer/currently)

Opinions?
Comment 45 Yousuf Philips (jay) 2017-02-09 10:05:20 UTC
(In reply to Cor Nouws from comment #44)
>   ... (some more)
>   – – – – – – – – – 
>   Clear Direct Formatting
>   Styles > ..
>   Edit Style
> 
> reasons:
> - If clear direct formatting should be with styles, it must be with Edit
> Style too.
> - Edit style is used often and I would not like hiding it

Yes they should be together and placing them in a submenu isnt hiding them, its organizing them and making the best use of space. You asked about the organization in bug 85940 comment 9, which i did reply to, so lets go with that.
Comment 46 Daniel Grigoras 2017-02-16 10:34:03 UTC
I just upgraded and noticed that the "Clear direct formatting" context menu option was removed.
Though I use this feature a lot, this is not an issue considering that I was able to insert this command as a button on the Standard toolbar next to the "Clone formatting" button. I prefer the button to the context menu.
This command is a standard button displayed by default in MS Word and should become a default button on the Standard toolbar of LO Writer.
Comment 47 Yousuf Philips (jay) 2017-05-23 00:46:51 UTC
Patch is in - https://gerrit.libreoffice.org/#/c/37925/

(In reply to Darius Daniel Grigoras from comment #46)
> Though I use this feature a lot, this is not an issue considering that I was
> able to insert this command as a button on the Standard toolbar next to the
> "Clone formatting" button. I prefer the button to the context menu.

I had hoped to add it next to 'Clone Formatting', but presently it only works for text (bug 107319).

> This command is a standard button displayed by default in MS Word and should
> become a default button on the Standard toolbar of LO Writer.

It has been a default button in the formatting toolbar since LibreOffice 5.0.
Comment 48 Commit Notification 2017-05-27 20:39:03 UTC
Yousuf Philips committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=dc8ac5373d21c0ea35f73e2730940f3da35f5654

tdf#102915 Restore 'Clear Direct Formatting' to context menu

It will be available in 5.5.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 49 Commit Notification 2017-05-29 17:34:40 UTC
Yousuf Philips committed a patch related to this issue.
It has been pushed to "libreoffice-5-4":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=2c21380ce9d1a65a55ecffe93116b42233d792f2&h=libreoffice-5-4

tdf#102915 Restore 'Clear Direct Formatting' to context menu

It will be available in 5.4.0.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 50 V Stuart Foote 2017-06-10 15:23:00 UTC
Yes that will work. 

And I'm looking forward to seeing the additional UNO commands needed for bug 108030 and bug 101896 also making it into the "Styles" context menu. 

For starters need to think about how to handle Thomas's suggestion of a means to remove applied Character styles (bug 85940 #15). In the sense that, like "Clearing Direct Formatting" here, providing a capability via context menu to reset the style(s) of selection to defined Default(s) is helpful.

Not all the controls for the Menu as tdf#101896, but at least changing the selection back to document default styles.