Bug 102927 - Filtering with Autofilter freezes Calc
Summary: Filtering with Autofilter freezes Calc
Status: RESOLVED DUPLICATE of bug 122419
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
5.2.1.2 release
Hardware: All All
: medium major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: haveBacktrace
Depends on:
Blocks:
 
Reported: 2016-10-03 06:50 UTC by Chusky
Modified: 2020-11-08 07:22 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
version used (93.95 KB, image/jpeg)
2016-10-03 06:50 UTC, Chusky
Details
ODS File (9.51 MB, application/vnd.oasis.opendocument.spreadsheet)
2016-10-04 05:44 UTC, Chusky
Details
a backtrace (11.37 KB, text/plain)
2016-12-11 14:00 UTC, fiftyigfuci_f_mi
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Chusky 2016-10-03 06:50:01 UTC
Created attachment 127783 [details]
version used

Greetings,

Kindly asking your support for LibreOffice Calc, when I put strings as in autofilter of the spreadsheet the application crashed down.


Sincerely,

Chuscky
Comment 1 m.a.riosv 2016-10-03 21:47:14 UTC Comment hidden (obsolete)
Comment 2 Chusky 2016-10-04 05:44:06 UTC
Created attachment 127796 [details]
ODS File
Comment 3 Aron Budea 2016-10-05 05:32:06 UTC
By crash you mean Calc hangs, right?

Hangs for me with 5.2.1.2 and 5.3 master builds (id: 4563921f23d79f6e3e431a314064c6dd201cfee2) / Windows 7.

Document itself loads slowly because it has 482195 rows, and opening the autofilter is slow as well for the same reason, at least on columns with many different entries. Hang only happens when filtering on such columns (like Cell ID and not on Vendor for example).
Comment 4 Chusky 2016-10-06 07:55:08 UTC
(In reply to Aron Budea from comment #3)
> By crash you mean Calc hangs, right?
> 
> Hangs for me with 5.2.1.2 and 5.3 master builds (id:
> 4563921f23d79f6e3e431a314064c6dd201cfee2) / Windows 7.
> 
> Document itself loads slowly because it has 482195 rows, and opening the
> autofilter is slow as well for the same reason, at least on columns with
> many different entries. Hang only happens when filtering on such columns
> (like Cell ID and not on Vendor for example).


Yes it hangs then (Not Responding) I will terminate the session by Task Manager. 482195 rows  is almost 50 percent of the maximum rows allotted, it this the limitation of the program? 
Hangs happen on all columns except for Vendor, because it had only one string format.
Comment 5 Aron Budea 2016-10-06 08:19:05 UTC
Some slowness can be expected, but no, it shouldn't be a limitation.
Comment 6 fiftyigfuci_f_mi 2016-12-11 14:00:38 UTC
Created attachment 129498 [details]
a backtrace

I confirmed on both:
Version: 5.2.2.2
Build ID: 1:5.2.2-0ubuntu2
CPU Threads: 2; OS Version: Linux 4.9; UI Render: default; 
Locale: en-US (en_US.UTF-8); Calc: group

(My debug dev build)
Version: 5.4.0.0.alpha0+
Build ID: f35d29c8388744be1f95ec4acfca12eec706911a
CPU Threads: 2; OS Version: Linux 4.9; UI Render: default; VCL: gtk3; 
Locale: en-US (en_US.UTF-8); Calc: group
Comment 7 m.a.riosv 2017-01-18 13:00:11 UTC
*** Bug 105406 has been marked as a duplicate of this bug. ***
Comment 8 ju0815nk 2017-03-29 07:56:35 UTC
I can reproduce this bug with v5.3.1 on Linux (Xubuntu 16.04). Using autofilter on a column with > 100k rows and entering a single letter in the search box will completely freeze Libreoffice *and* (surprisingly) the whole X, i.e. I have to switch to a console terminal (Ctrl+F1) and kill soffice to be able to continue. Libreoffice is using 100% CPU of one core and does not return within reasonable time (10-20s).

To reproduce this issue:

- ungzip file in attachment
- run libreoffice --calc aaa.txt and keep default values for import
- Mark whole sheet, set autofilter on all columns
- Choose autofilter on column "GeneSymbol"
- Try to enter something in search box

-> LO will freeze immediately (before even showing the entered letter)
Comment 9 ju0815nk 2017-03-29 08:17:12 UTC
Just found out that the test file is too big for upload.

Please use this one instead: 

ftp://ftp.sanger.ac.uk/pub/gencode/Gencode_mouse/release_M12/gencode.vM12.metadata.MGI.gz

- ungzip file to file aaa.txt
- run libreoffice --calc aaa.txt and keep default values for import
- Mark whole sheet, set autofilter on all columns
- After selecting auto filter, click "yes" when asked if the first row should be used as header line. 
- Choose filter second column
- Try to enter something in search box

-> LO will freeze immediately (before even showing the entered letter)


Interestingly, If the first line is not chosen as header line, Calc still freezes but X stays responsive.
Comment 10 ju0815nk 2017-04-03 12:35:28 UTC

*** This bug has been marked as a duplicate of bug 76481 ***
Comment 11 berger 2019-09-10 17:10:38 UTC
Reopened because bug 76481 (opening of autofilter UI freeze) seems to be resolved.

Version: 6.2.6.2
Build ID: 1:6.2.6-0ubuntu0.16.04.1~lo1
CPU threads: 8; OS: Linux 4.4; UI render: default; VCL: gtk2; 
Locale: en-US (en_US.UTF-8); UI-Language: en-US
Calc: threaded

i7-4712MQ CPU @ 2.30GHz

Opening the autofilter UI and entering a single character in the search box freezes the UI for several minutes. Same for removing the character afterwards. 

Time of freeze seems to depend on the length of the list of remaining entries in the list (i.e. the entries in the listbox below), as entering more characters reduces the waiting time. 

Tested with attachment #2 and also with data set from bug 76481 (220k rows).
Comment 12 perie_gut 2020-03-22 12:58:32 UTC
The issue is still unresolve both in stable and fresh release . 

Version: 6.3.5.2 (x64)
Build ID: dd0751754f11728f69b42ee2af66670068624673
CPU threads: 8; OS: Windows 10.0; UI render: default; VCL: win; 
Locale: en-PH (en_PH); UI-Language: en-US
Calc: threaded
Comment 13 V Stuart Foote 2020-03-22 14:01:50 UTC

*** This bug has been marked as a duplicate of bug 76481 ***
Comment 14 Kevin Suo 2020-11-08 07:22:07 UTC
Mark as a duplicate of bug 122419 instead, see my comment in:
bug 76481#c31

*** This bug has been marked as a duplicate of bug 122419 ***