Bug Hunting Session
Bug 103046 - Crash at EDITING of Slide transition (Folienuebergang)
Summary: Crash at EDITING of Slide transition (Folienuebergang)
Status: RESOLVED DUPLICATE of bug 108069
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
5.1.5.2 release
Hardware: x86-64 (AMD64) Windows (All)
: high critical
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: haveBacktrace
Depends on:
Blocks: OpenGL
  Show dependency treegraph
 
Reported: 2016-10-07 08:30 UTC by Markus Vogel
Modified: 2017-10-27 11:07 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Backtrace (19.90 KB, text/plain)
2016-10-10 13:49 UTC, Markus Vogel
Details
backtrace with fresh installed LO 5.2.2 win x86 (23.71 KB, text/plain)
2016-10-10 20:16 UTC, Markus Vogel
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Markus Vogel 2016-10-07 08:30:19 UTC
Sorry - I only know the German items:
At some items of "Folienuebergang" LO 5.1.5 crashes at once when trying to make the "Vorschau", e.g. for "Blende" or "Feines Auflösen".
Comment 1 Joel Madero 2016-10-08 04:49:52 UTC
Not a useful bug report at all. Please provide useful steps and then set to UNCONFIRMED. For examples see: https://wiki.documentfoundation.org/QA/BugReport#Good_Reports
Comment 2 Markus Vogel 2016-10-08 11:28:16 UTC
My System: Win10 pro 1607, Version 14393.222

1. Install LibreOffice 5.1.5 portable
2. New presentation
3. Duplicate page/slide twice
4. Mark second slide
5. Open Slide bar with "Slide transition" 
6. Click e.g. on "Dissolve" - everything is okay
7. Click on "Fading" - LO crashes
If you unmark "Automatic preview" it won't crash at once, but it crashes when you press F5 and go to the second slide.

I hope that will help you now.
Same behaviour with fresh installed LO 5.2.2, so I downgraded to 4.4.7, where everything workes fine. 
[Options-View says: "Current GL-Status: disabled"]
Comment 3 arnaud.malfoy 2016-10-09 04:22:40 UTC
I'm trying to replicate this bug on Ubuntu 16.04.1 with Libre Office 5.2.2.2. Could you elaborate on step 4. Not sure what you mean by "Mark second slide". Thanks
Comment 4 Joel Madero 2016-10-09 04:57:04 UTC
(In reply to arnaud.malfoy from comment #3)
> I'm trying to replicate this bug on Ubuntu 16.04.1 with Libre Office
> 5.2.2.2. Could you elaborate on step 4. Not sure what you mean by "Mark
> second slide". Thanks

He just means select it in the left side panel (left click once)


Version: 5.3.0.0.alpha0+
Build ID: f32b300c9e071c2bdee2a7b925200feb93add702
CPU Threads: 2; OS Version: Linux 3.16; UI Render: default; 
Locale: en-US (en_US.UTF-8); Calc: group

Cannot reproduce
Comment 5 Buovjaga 2016-10-09 19:31:07 UTC
Yeah, cannot reproduce.

Markus: please try LibreOffice 5.2.2. If portable still crashes, please try the official installed version.

Set to NEEDINFO.
Change back to UNCONFIRMED, if the problem persists. Change to RESOLVED WORKSFORME, if the problem went away.
Comment 6 Markus Vogel 2016-10-10 09:24:00 UTC
(In reply to Buovjaga from comment #5)
> Markus: please try LibreOffice 5.2.2. If portable still crashes, please try
> the official installed version.

I tried both - on my Desktop Computer it crashes, on my Laptop with the same windows version it works. 

It seems that I have to stay at Version 4.4.7.
Thanks Markus
Comment 7 Buovjaga 2016-10-10 09:41:51 UTC
(In reply to Markus Vogel from comment #6)
> (In reply to Buovjaga from comment #5)
> > Markus: please try LibreOffice 5.2.2. If portable still crashes, please try
> > the official installed version.
> 
> I tried both - on my Desktop Computer it crashes, on my Laptop with the same
> windows version it works. 
> 
> It seems that I have to stay at Version 4.4.7.
> Thanks Markus

Sorry, I didn't notice you mentioned 5.2.2. But it is interesting that your laptop works. I checked on dev IRC channel and Fade transition does use OpenGL. The use of OpenGL in transitions is separate from the interface use of OpenGL.

What sort of graphics hardware do you have in the crashy desktop?
Comment 8 Markus Vogel 2016-10-10 11:22:01 UTC
(In reply to Buovjaga from comment #7)
> Sorry, I didn't notice you mentioned 5.2.2. But it is interesting that your
> laptop works. I checked on dev IRC channel and Fade transition does use
> OpenGL. The use of OpenGL in transitions is separate from the interface use
> of OpenGL.
> 
> What sort of graphics hardware do you have in the crashy desktop?

NVIDIA GeForce 7025 / NVIDIA nForce 630a
Comment 9 Buovjaga 2016-10-10 11:28:59 UTC
Thanks. 5.2 has a crash reporter, but it might not catch all crashes. Here is the more manual way to get crash data: https://wiki.documentfoundation.org/How_to_get_a_backtrace_with_WinDbg
Comment 10 Markus Vogel 2016-10-10 13:49:35 UTC
Created attachment 127921 [details]
Backtrace

Hi, now here is the backtrace I received - I hope it helps.
Thankyou for looking!
Comment 11 Buovjaga 2016-10-10 17:00:21 UTC
(In reply to Markus Vogel from comment #10)
> Created attachment 127921 [details]
> Backtrace
> 
> Hi, now here is the backtrace I received - I hope it helps.
> Thankyou for looking!

Hey, the backtrace seems like it is not useful. I'm not certain it is because you did it with 5.1.5 portable.

Just to make it clear: did you first try crashing it with 5.2.2?
Comment 12 Buovjaga 2016-10-10 18:31:38 UTC
Btw., we discussed this on IRC and it was pointed out that the GPU in the crashing machine only supports OpenGL up to version 1.5. The Impress transitions now require OpenGL 2.1 support at a minimum: https://wiki.documentfoundation.org/ReleaseNotes/5.1#OpenGL_Transitions

However, the crashing is not OK and should be fixed.
Comment 13 Markus Vogel 2016-10-10 20:16:08 UTC
Created attachment 127934 [details]
backtrace with fresh installed LO 5.2.2 win x86
Comment 14 Markus Vogel 2016-10-10 20:25:02 UTC
(In reply to Buovjaga from comment #11)
> Hey, the backtrace seems like it is not useful. I'm not certain it is
> because you did it with 5.1.5 portable.
> 
> Just to make it clear: did you first try crashing it with 5.2.2?

Hi, I had deinstalled LO 5.2.2 because of the bug and installed 4.4.7 for working.

Because of your question now I deinstalled LO 4.4.7 and removed any files in /AppData/Roaming/LibreOffice. Then I installed LO 5.2.2 win x86 and made another backtrace that you see above. 
I hope that's more useful ...
Comment 15 Aron Budea 2016-10-10 21:56:47 UTC
Reproduced with v5.2.1.2 / Windows 7.
Filing crash report wasn't offered, and WinDbg backtrace was useless, the only result of the analysis was that the application had exited.

This is the content of opengl_device.log:

DriverVersion: 2.7.1.6
DriverDate: 6-18-2010
DeviceID: PCI\VEN_102B&DEV_2539&SUBSYS_0040102B&REV_01
AdapterVendorID: 0x102b
AdapterDeviceID: 0x2539
AdapterSubsysID: 0x0040102b
DeviceKey: System\CurrentControlSet\Control\Video\{CC00E15A-1A8D-4171-B4B3-930DEB562651}\0000
DeviceString: Matrox Millennium P690 PCIe x16
Comment 16 Aron Budea 2016-10-17 02:54:36 UTC

*** This bug has been marked as a duplicate of bug 103236 ***
Comment 17 Xisco Faulí 2017-10-27 11:07:01 UTC

*** This bug has been marked as a duplicate of bug 108069 ***