Download it now!
Bug 103048 - FILEOPEN: XLSX with Form controls doesn't work in LO
Summary: FILEOPEN: XLSX with Form controls doesn't work in LO
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.3.0.4 release
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: filter:xlsx
Depends on:
Blocks: Form-Controls XLSX-Form-Controls
  Show dependency treegraph
 
Reported: 2016-10-07 11:15 UTC by Gabor Kelemen
Modified: 2020-06-15 11:54 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
The problematic document (491.95 KB, application/vnd.openxmlformats-officedocument.spreadsheetml.sheet)
2016-10-07 11:16 UTC, Gabor Kelemen
Details
The resulting value is different in C10 (50.98 KB, image/png)
2016-10-21 12:39 UTC, Gabor Kelemen
Details
Hungarian accented characters are missing (24.86 KB, image/png)
2016-10-21 12:46 UTC, Gabor Kelemen
Details
Linked cell info disappears from the option button (14.06 KB, image/png)
2016-10-21 12:52 UTC, Gabor Kelemen
Details
The $ marks disappeared from linked cell info of the List Box (19.62 KB, image/png)
2016-10-21 12:54 UTC, Gabor Kelemen
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Gabor Kelemen 2016-10-07 11:15:47 UTC
Description:
Attached file has some form control items that do not seem to import/work correctly in Calc 5.1.4 and 5.3alpha.

The file is password protected, but can be unlocked with this password: AAABBBAABBA_

Steps to Reproduce:
1. Select a date value in C9
2. In C14 a value should appear. In the hidden C10 cell a value should appear, in Excel this is an integer number, in Calc a date.
3. 

Another problem is the text of the option buttons: In Excel they contain Hungarian accented characters, in Calc these are replaced with spaces.

Actual Results:  
No value appears in C14.

The option buttons texts are: "Nem r szes ltem" instead of "Nem részesültem" and "Az al bbiak szerint r szes ltem" instead of "Az alábbiak szerint részesültem"

Expected Results:
The same value appears in C14 as in Excel.

Option button texts contain accented characters.


Reproducible: Always

User Profile Reset: No

Additional Info:


User-Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:49.0) Gecko/20100101 Firefox/49.0
Comment 1 Gabor Kelemen 2016-10-07 11:16:45 UTC
Created attachment 127852 [details]
The problematic document
Comment 2 m.a.riosv 2016-10-08 12:06:54 UTC
Hi @Gabor, thanks for reporting.

Sorry but in
C10:=VLOOKUP(C10;$Keretek.A3:F369;6;0)
dates in $Keretek are in column B not A
so you need adapt the range to search and column number.
It happens also in other formulas like C14.

Resolved as not a bug, please if you are not agree, reopen it.
Comment 3 Gabor Kelemen 2016-10-21 12:31:09 UTC
Hi

I do not agree. Reopening :).

I should have emphasized that this spreadsheet was not made by me, but I got it from corporate HR. They made it for Excel and in that it works, regardless the starting column of VLOOKUP's range.

I'll add a few screenshots about small differences side by side.
Comment 4 Gabor Kelemen 2016-10-21 12:39:07 UTC
Created attachment 128122 [details]
The resulting value is different in C10

Format Cells window: Selecting the date 2016.01.08 in the C9 form control results in a value of 10 in Excel and a value of 2016.01.08 in Calc.
Also the format of C10 is "Generic" in Excel and "Text" in Calc.
Comment 5 Gabor Kelemen 2016-10-21 12:46:17 UTC
Created attachment 128124 [details]
Hungarian accented characters are missing

A separate issue, but the accented characters are indeed removed.
Comment 6 Gabor Kelemen 2016-10-21 12:52:18 UTC
Created attachment 128125 [details]
Linked cell info disappears from the option button
Comment 7 Gabor Kelemen 2016-10-21 12:54:20 UTC
Created attachment 128126 [details]
The $ marks disappeared from linked cell info of the List Box
Comment 8 Buovjaga 2016-11-03 11:30:34 UTC
Repro with document.

Win 7 Pro 64-bit Version: 5.3.0.0.alpha1+
Build ID: 4b4abb73fcd7f2802e73102b3e7c30face8d309c
CPU Threads: 4; OS Version: Windows 6.1; UI Render: default; Layout Engine: old; 
TinderBox: Win-x86@39, Branch:master, Time: 2016-10-31_02:54:50
Locale: fi-FI (fi_FI); Calc: group

Version: 4.3.0.1
Build ID: 67f5430184326974072b65403ef1d9d934fc4481
Comment 9 QA Administrators 2018-07-03 02:38:47 UTC Comment hidden (obsolete)
Comment 10 m.a.riosv 2018-07-03 08:46:45 UTC
Still in
Version: 6.0.5.2 (x64)
Build ID: 54c8cbb85f300ac59db32fe8a675ff7683cd5a16
CPU threads: 4; OS: Windows 10.0; UI render: GL; 
Locale: es-ES (es_ES); Calc: CL
Comment 11 Justin L 2018-10-29 18:16:18 UTC
Still a problem in 6.2 master. Although C10 doesn't show a date, but just shows a seconds integer, it is not showing the "position", but the "value". So that looks like an import error - perhaps the wrong default, where if it isn't specified it should be position, not value?  Jut guessing.

Confirmed that the option buttons at B67/B68 still have spaces in the labels.
Comment 12 QA Administrators 2019-11-08 03:37:35 UTC
Dear Gabor Kelemen,

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

Test to see if the bug is still present with the latest version of LibreOffice from https://www.libreoffice.org/download/

If the bug is present, please leave a comment that includes the information from Help - About LibreOffice.
 
If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a comment that includes the information from Help - About LibreOffice.

Please DO NOT

Update the version field
Reply via email (please reply directly on the bug tracker)
Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not 
appropriate in this case)


If you want to do more to help you can test to see if your issue is a REGRESSION. To do so:
1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3) from http://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug
3. Leave a comment with your results.
4a. If the bug was present with 3.3 - set version to 'inherited from OOo';
4b. If the bug was not present in 3.3 - add 'regression' to keyword


Feel free to come ask questions or to say hello in our QA chat: https://kiwiirc.com/nextclient/irc.freenode.net/#libreoffice-qa

Thank you for helping us make LibreOffice even better for everyone!

Warm Regards,
QA Team

MassPing-UntouchedBug