Download it now!
Bug 103057 - Elements of different sidebar decks overlaps in Impress
Summary: Elements of different sidebar decks overlaps in Impress
Status: RESOLVED DUPLICATE of bug 104229
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
5.2.2.2 release
Hardware: x86-64 (AMD64) All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Sidebar-UI-UX
  Show dependency treegraph
 
Reported: 2016-10-08 12:44 UTC by Francisco
Modified: 2017-12-19 15:54 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Screenshot (134.61 KB, image/png)
2016-10-08 12:44 UTC, Francisco
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Francisco 2016-10-08 12:44:57 UTC
Created attachment 127875 [details]
Screenshot

As the title says.

When selecting different decks, the sidebar shows the Styles deck and when moving the pointer over it, the buttons of the deck that is actually selected (Properties) appears.

So far, I have experienced this bug only in Impress, but this may be a general bug.

Steps:
Sadly, I haven't been able to track specific steps to reproduce it yet. Sorry... 

But it indeed happens on Windows and Linux (both x64) with OpenGL disabled.

I'm attaching a screenshot that shows the problem.

This issue could be related to bug 96451, which is similar and has been already solved for Math. So... I hope that even without any specific step to reproduce (it just happens... :-(  ) the developer that solved bug 96451 could now what's happening.
Comment 1 V Stuart Foote 2016-10-08 14:50:53 UTC
The screen clip seems to show the Properties deck with the Styles and Formatting deck bleeding into it.  You look to be editing the template file for the MidnightBlue Impress template with text cursor focus in the Title .

Please post build details from the Help -> About LibreOffice dialog.

Also the toolbars look to be customized from default, what tool is the toggled active "T" in the Drawing toolbar docked left?

Do you still have issue when you use a new default user profile?
Comment 2 Francisco 2016-10-08 15:31:37 UTC
(In reply to V Stuart Foote from comment #1)
> The screen clip seems to show the Properties deck with the Styles and
> Formatting deck bleeding into it.  You look to be editing the template file
> for the MidnightBlue Impress template with text cursor focus in the Title .

It has happen with the default template also. If my memory doesn't fail, in most of the cases I had edited the master also.

> Please post build details from the Help -> About LibreOffice dialog.

Versión: 5.2.2.2 (x64)
Id. de compilación: 8f96e87c890bf8fa77463cd4b640a2312823f3ad
Subprocesos de CPU: 4; Versión de SO: Windows 6.29; Renderizado de IU: predeterminado; 
Configuración regional: en-US (es_AR); Calc: group

> Also the toolbars look to be customized from default, what tool is the
> toggled active "T" in the Drawing toolbar docked left?

Insert text box... although I don't know why it was activated. I wasn't inserting any text box :-/

> Do you still have issue when you use a new default user profile?

Not sure, it happened suddenly. I should check using Impress from the beginning with a clean profile.
Comment 3 Francisco 2016-10-08 17:01:37 UTC
> Not sure, it happened suddenly. I should check using Impress from the
> beginning with a clean profile.

Stuart:

I just reproduce it using a clean profile and the default template + OpenGL disabled (it's enabled by default).

Again, and sadly, I can't find proper steps to reproduce. I just start to click on different parts of the slide, with "properties" deck selected. 
Then, and suddenly, after selecting the Title of the slide the bug appears but not always.
Comment 4 V Stuart Foote 2016-10-08 19:24:37 UTC
OK, thanks for the additional details. 

I've not been able to replicate, but will try with clean profile with OpenGL disabled.

Back to Unconfirmed for now--of course if you can come up with reliable STR please post.
Comment 5 Xisco Faulí 2017-10-31 17:53:16 UTC
It seems to me like a dupe of bug 104229

*** This bug has been marked as a duplicate of bug 104229 ***