Download it now!
Bug 103084 - Keyboard shortcut for Insert comment and Edit comment should be the same
Summary: Keyboard shortcut for Insert comment and Edit comment should be the same
Status: RESOLVED DUPLICATE of bug 95854
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
5.1.0.3 release
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: needsDevEval, topicUI
Depends on:
Blocks: UNO-Command-New Shortcuts-Accelerators
  Show dependency treegraph
 
Reported: 2016-10-10 09:54 UTC by Daniel
Modified: 2016-11-29 18:31 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Daniel 2016-10-10 09:54:50 UTC
Description:
Currently, a standard keyboard shortcut (Ctrl+Alt+C) is set for inserting a comment in a cell, i.e. the same action as right-clicking on the cell and choosing "Insert comment". This will open the yellowish comment box.
Once a cell already contains a comment, there is no longer any context menu item "Insert comment". Instead, the context menu contains an entry "Edit comment", but this entry is not linked to the keyboard shortcut. Hence, the shortcut can only be used on cells without an existing comment. In order to reach and edit existing comments via keyboard shortcuts, the user has to define a _different_ custom shortcut for this.

Steps to Reproduce:
1. Place the cursor on a cell without comment.
2. Press Ctrl+Alt+C and enter a comment.
3. Close the comment box.
4. Press Ctrl+Alt+C again.

Actual Results:  
Nothing happens on step 4.

Expected Results:
On step 4, the comment box should open again to edit the comment. The same shortcut as for new comments should be used for this.
From a user perspective, Insert comment and Edit comment are the same because you expect that inserting a comment permits you to edit it right away.


Reproducible: Always

User Profile Reset: No

Additional Info:


User-Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:49.0) Gecko/20100101 Firefox/49.0
Comment 1 Cor Nouws 2016-10-10 14:11:44 UTC
Hi daniel,

Thanks! Actually there is an issue (xxx) for assigning a short cut to edit a comment..

The idea is logic. However.. when doing the same short cut, keep in mind how that should behave 
 - if you want to set more comments at the same insert point
 - if you want to set a comment at a range that partially overlap a range
   that already has a comment
 - if you want to set a comment at a position where someone else already commented.

I do not say it is impossible, but those cases must be considered.

Ciao - Cor
Comment 2 Yousuf Philips (jay) (retired) 2016-10-10 14:21:42 UTC
Would assume we'd need a new uno command that we could assign the shortcut to that would execute insert comment if no comment is present and edit comment if a comment is already there.
Comment 3 Daniel 2016-10-10 15:04:08 UTC
(In reply to Cor Nouws from comment #1)
> Hi daniel,
> 
> Thanks! Actually there is an issue (xxx) for assigning a short cut to edit a
> comment..
> 
> The idea is logic. However.. when doing the same short cut, keep in mind how
> that should behave 
>  - if you want to set more comments at the same insert point
>  - if you want to set a comment at a range that partially overlap a range
>    that already has a comment
>  - if you want to set a comment at a position where someone else already
> commented.
> 
> I do not say it is impossible, but those cases must be considered.
> 
> Ciao - Cor

I am not aware of any possibility to
- add more than one comment to each cell.
- add a comment to more than one cell (i.e. a range of cells)
- have different comments from different users.
The comment feature in Calc is not the same as in Writer where different users can comment on overlapping ranges.
Please correct me if I am wrong.
Comment 4 Cor Nouws 2016-10-11 08:58:31 UTC
(In reply to daniel from comment #3)

> Please correct me if I am wrong.

You're completely right. Sorry I missed the component Calc!
Comment 5 Buovjaga 2016-11-29 18:31:25 UTC

*** This bug has been marked as a duplicate of bug 95854 ***