Bug Hunting Session
Bug 103188 - FILEOPEN: DOCX Incorrect text in First page's footer
Summary: FILEOPEN: DOCX Incorrect text in First page's footer
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.2 all versions
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, filter:docx, regression
Depends on:
Blocks: DOCX-Header-Footer
  Show dependency treegraph
 
Reported: 2016-10-13 18:17 UTC by Xisco Faulí
Modified: 2019-11-06 14:39 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Screenshot of the document in Word and Writer 6.0 (542.84 KB, image/png)
2019-11-06 13:47 UTC, NISZ LibreOffice Team
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Xisco Faulí 2016-10-13 18:17:34 UTC
FILEOPEN: Incorrect text in First page's footer

Steps to reproduce:
1. Open attachment #102344 [details]
2. Check first page's footer

Observed Behavior: First page's footer contains this string on the right: 'Australian Flexible Learning Network. Page 4"

Expected behavior: First page's footer shouldn't have that text

Reproduced in 

Version: 5.3.0.0.alpha0+
Build ID: ae94c223e2e21e42fc7feca72402b910e5eab5c7
CPU Threads: 4; OS Version: Linux 4.2; UI Render: default; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group

and in ( removing the blue square )

Version: 4.2.0.0.alpha1+
Build ID: 22ea573b7417db0392c006dff06cde50ddbcd469

but not in

Version: 4.1.0.0.alpha1+
Build ID: a2c9d4f8bbde97f175bae4df771273a61251f40
Comment 2 Xisco Faulí 2016-10-13 22:28:43 UTC
I'm pretty sure the duplicate image of the 'Austrian Goverment' is also related to this bug.
The 'Acknowledgements' problem is reported in bug 103205
Comment 3 Yousuf Philips (jay) (retired) 2016-10-19 19:19:29 UTC
The "Australian Flexible Learning Network. Page 4" is available on the first page in MS Word 2010, but it is being covered up by the blue square, so the issue is that 'Rectangle 5' has a weird z-order issue as moving the square hides the stuff behind it, but alt+tabbing back and forth or scrolling up and then back down will show the stuff behind it.

(In reply to Xisco Faulí from comment #2)
> I'm pretty sure the duplicate image of the 'Austrian Goverment' is also
> related to this bug.

The second image isnt a duplicate of the first as the second says 'Department of Education and Workplace Relations' (image4.png in the xml zip) and the first says 'Department of Industry, Innovation Science, Research and Tertiary Education' (image3.png in the xml zip). If i had to guess, i'd assume the image is located off the page and LO doesnt have this feature.

word/_rels/document.xml.rels: <Relationship Id="rId12" Type="http://schemas.openxmlformats.org/officeDocument/2006/relationships/image" Target="media/image4.png"/>

word/document.xml: <pic:pic xmlns:pic="http://schemas.openxmlformats.org/drawingml/2006/picture"> ... <pic:blipFill><a:blip r:embed="rId12" cstate="print" /><a:srcRect /><a:stretch><a:fillRect /></a:stretch></pic:blipFill>
Comment 4 QA Administrators 2017-12-10 16:40:37 UTC Comment hidden (obsolete)
Comment 5 NISZ LibreOffice Team 2019-11-06 13:47:38 UTC
Created attachment 155579 [details]
Screenshot of the document in Word and Writer 6.0

Can no longer reproduce in:

Verzió: 6.0.0.3
Build az.: 64a0f66915f38c6217de274f0aa8e15618924765
CPU szálak: 4; OS: Windows 6.3; Felületmegjelenítés: alapértelmezett; 
Területi beállítások: hu-HU (hu_HU); Calc: CL

It was bad in:

Version: 5.4.0.3
Build ID: 92c2794a7c181ba4c1c5053618179937228ed1fb
CPU threads: 4; OS: Windows 6.2; UI render: default; 
Locale: en-US (hu_HU); Calc: CL
Comment 6 Xisco Faulí 2019-11-06 14:39:56 UTC
Indeed, Fixed in

Version: 6.4.0.0.alpha1+
Build ID: ee909ca2c02f949605f68720c3f1eef658502749
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded

and

Version: 6.0.0.0.alpha1+
Build ID: 6eeac3539ea4cac32d126c5e24141f262eb5a4d9
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group threaded

so it has been fixed for a while... Nice!