Download it now!
Bug 103218 - FILEOPEN XLSX Image has incorrect proportions
Summary: FILEOPEN XLSX Image has incorrect proportions
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.6.0.4 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: interoperability
Keywords: bibisected, filter:xlsx, regression
Depends on:
Blocks: Calc-Images XLSX
  Show dependency treegraph
 
Reported: 2016-10-14 14:04 UTC by Leonardo M. Ramé
Modified: 2019-09-17 11:34 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Comparison between excel and calc (77.94 KB, image/jpeg)
2016-10-14 14:05 UTC, Leonardo M. Ramé
Details
Original Excel file (141.99 KB, application/vnd.openxmlformats-officedocument.spreadsheetml.sheet)
2016-10-14 14:06 UTC, Leonardo M. Ramé
Details
screenshot (65.42 KB, image/png)
2018-06-28 17:21 UTC, Xavier Van Wijmeersch
Details
Excel file compared in MSO LO5.3 LO6.0 LO6.4+ (108.89 KB, image/jpeg)
2019-09-17 11:34 UTC, Timur
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Leonardo M. Ramé 2016-10-14 14:04:33 UTC
Description:
When opening an .xslx file LibreOffice Calc displays our logo image wrongly sized.

Please, download a sample file from here: http://45.63.8.72/libreoffice/ImageError.xlsx

Also you can see a picture showing how it is displayed in Excel and Calc, to easily grasp what I mean: http://45.63.8.72/libreoffice/imageerror.jpg

Regards,
Leonardo.

Steps to Reproduce:
1. Just open the file http://45.63.8.72/libreoffice/ImageError.xlsx in LO Calc (any version).

Actual Results:  
The logo image is displayed wrongly sized.

Expected Results:
It should be displayed as in Excel (see http://45.63.8.72/libreoffice/imageerror.jpg).


Reproducible: Always

User Profile Reset: No

Additional Info:


User-Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:49.0) Gecko/20100101 Firefox/49.0
Comment 1 Leonardo M. Ramé 2016-10-14 14:05:59 UTC
Created attachment 128009 [details]
Comparison between excel and calc
Comment 2 Leonardo M. Ramé 2016-10-14 14:06:19 UTC
Created attachment 128010 [details]
Original Excel file
Comment 3 Leonardo M. Ramé 2016-10-14 14:06:40 UTC
Please not I've attached both files.
Comment 4 Xisco Faulí 2016-10-19 22:11:15 UTC
Hi Leonardo,

Thanks for reporting.

I do confirm the problem in

Version: 5.3.0.0.alpha0+
Build ID: 8974b0fafb18f9dd3f2c0e175a3255b80e4c249e
CPU Threads: 4; OS Version: Linux 4.2; UI Render: default; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group

and in

Version 4.1.0.0.alpha0+ (Build ID: efca6f15609322f62a35619619a6d5fe5c9bd5a)

but not in

LibreOffice 3.5.0 
Build ID: d6cde02

thus, this is a regression.
Comment 5 Aron Budea 2017-01-04 21:16:35 UTC
Looks correct in 3.5.0.3, incorrect in 3.6.0.4 / Ubuntu 16.04.
Comment 6 Leonardo M. Ramé 2017-02-09 13:04:06 UTC
The bug still persists in 5.3.0.3.
Comment 7 Buovjaga 2018-06-28 14:40:53 UTC
Bibisecting with 43all I get this range: https://cgit.freedesktop.org/libreoffice/core/log/?qt=range&q=61d78aca81f08ac3a0f9eb65799d04d56fbad312...5553dfe2060cb4a02a827c9774a60e4408d20c33

Nothing immediately jumps out to me. What is funny is that one build of 4.2.0 showed the image correctly - I marked it bad all the same.
Comment 8 Xavier Van Wijmeersch 2018-06-28 17:21:31 UTC
Created attachment 143193 [details]
screenshot

I think the problem seems to be resolved, i am not sure

Version: 6.2.0.0.alpha0+
Build ID: 7414e07f52af87094240f5c3d9a0eb764e8642f5
CPU threads: 8; OS: Linux 4.14; UI render: default; VCL: kde4; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2018-06-24_01:53:55
Locale: nl-BE (en_US.UTF-8); Calc: group threaded
Comment 9 Buovjaga 2018-06-28 17:32:15 UTC
(In reply to Xavier Van Wijmeersch from comment #8)
> Created attachment 143193 [details]
> screenshot
> 
> I think the problem seems to be resolved, i am not sure
> 
> Version: 6.2.0.0.alpha0+
> Build ID: 7414e07f52af87094240f5c3d9a0eb764e8642f5
> CPU threads: 8; OS: Linux 4.14; UI render: default; VCL: kde4; 
> TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time:
> 2018-06-24_01:53:55
> Locale: nl-BE (en_US.UTF-8); Calc: group threaded

Hmm, yes it is closer, but the width is now smaller.

Arch Linux 64-bit
Version: 6.2.0.0.alpha0+
Build ID: 4600b07c1d787f959618d9ecf54161e4ea4ffa61
CPU threads: 8; OS: Linux 4.17; UI render: default; VCL: gtk3; 
Locale: fi-FI (fi_FI.UTF-8); Calc: group threaded
Built on June 28th 2018
Comment 10 QA Administrators 2019-06-29 02:58:34 UTC Comment hidden (obsolete)
Comment 11 Timur 2019-09-17 11:34:00 UTC
Created attachment 154220 [details]
Excel file compared in MSO LO5.3 LO6.0 LO6.4+

 Excel file compared in MSO LO5.3 LO6.0 LO6.4+. Looks OK to me.