Bug 103229 - Area fill toolbar control not supporting patterns
Summary: Area fill toolbar control not supporting patterns
Status: RESOLVED DUPLICATE of bug 128612
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
5.3.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, implementationError
Depends on:
Blocks: Toolbars Object-Fill-Pattern
  Show dependency treegraph
 
Reported: 2016-10-15 02:56 UTC by Yousuf Philips (jay) (retired)
Modified: 2021-07-27 08:54 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
discrepancy between toolbar and sidebar (7.06 KB, image/png)
2019-11-01 21:58 UTC, Gerhard Weydt
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Yousuf Philips (jay) (retired) 2016-10-15 02:56:08 UTC
Steps:
1) Open writer
2) Draw a shape
3) In the area fill toolbar drop down, select pattern
4) Drop down next to it is empty

This works fine in the Area content panel in the sidebar.

Version: 5.3.0.0.alpha0+
Build ID: 45a7137c6796f33fbf5b8f7cb64e293260d991cb
CPU Threads: 2; OS Version: Linux 3.19; UI Render: default; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2016-10-13_23:38:06
Locale: en-US (en_US.UTF-8); Calc: group
Comment 1 Julien Nabet 2016-10-15 11:12:50 UTC
On pc Debian x86-64 with master sources updated today, I could reproduce this.

I noticed this on console:
warn:legacy.osl:6917:1:svx/source/tbxctrls/fillctrl.cxx:522: Non supported FillType (!)
Comment 2 Julien Nabet 2016-10-15 11:15:34 UTC
In http://opengrok.libreoffice.org/xref/core/offapi/com/sun/star/drawing/FillStyle.idl, there's no pattern part, is it the root cause?
Comment 3 Julien Nabet 2016-10-15 11:30:18 UTC
I noticed that in sidebar part, pattern works well.
Comment 4 QA Administrators 2018-09-23 02:50:02 UTC Comment hidden (obsolete)
Comment 5 Gerhard Weydt 2019-11-01 21:53:36 UTC
The bug is still there in
Version: 6.3.2.2 (x64)
Build-ID: 98b30e735bda24bc04ab42594c85f7fd8be07b9c
CPU-Threads: 4; BS: Windows 10.0; UI-Render: Standard; VCL: win; 
Gebietsschema: de-DE (de_DE); UI-Sprache: de-DE
Calc: threaded

Moreover, it applies also to Draw and Impress (didn't test Calc).
And there is a second, connected bug: after choosing "pattern" in the sidebar/notebook bar, the toolbar field shows the same pattern, but the preceding field still says "bitmap". I'll add a screenshot.
Comment 6 Gerhard Weydt 2019-11-01 21:58:36 UTC
Created attachment 155458 [details]
discrepancy between toolbar and sidebar

Attachmnent "discrepancy between toolbar and sidebar" shows correct fill type in sidebar and wrong one in toolbar, while pattern is shown correctly in both.
Screenshot was taken in a German environment, "Muster" means "pattern", the rest should be easily understandable.
Comment 7 Aron Budea 2020-12-28 07:44:49 UTC
For the record, the Pattern entry was added with the following commit:

https://cgit.freedesktop.org/libreoffice/core/commit/?id=76585ae33f3ca75c05c0ccbf6a621b6e2d42bc00
author		Rishabh Kumar <kris.kr296@gmail.com>	2016-06-07 16:58:20 +0530
committer	Katarina Behrens <Katarina.Behrens@cib.de>	2016-06-28 19:37:44 +0000

Convert Bitmap tab to Pattern tab
Comment 8 Katarina Behrens 2021-07-27 08:54:29 UTC

*** This bug has been marked as a duplicate of bug 128612 ***