Download it now!
Bug 103244 - [LOCALHELP] Incorrect menu path to Tools - Protect Sheet/Spreadsheet in Calc
Summary: [LOCALHELP] Incorrect menu path to Tools - Protect Sheet/Spreadsheet in Calc
Status: CLOSED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Documentation (show other bugs)
Version:
(earliest affected)
5.2.1.2 release
Hardware: All Windows (All)
: medium normal
Assignee: Stanislav Horacek
URL:
Whiteboard: target:5.3.0
Keywords:
Depends on:
Blocks: Help-Changes-Menu
  Show dependency treegraph
 
Reported: 2016-10-15 15:20 UTC by gmarco
Modified: 2017-01-05 15:10 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
protection help (395.16 KB, image/jpeg)
2016-10-15 15:20 UTC, gmarco
Details
menu strumenti (54.68 KB, image/jpeg)
2016-10-15 15:21 UTC, gmarco
Details
online tools menu (55.21 KB, image/jpeg)
2016-10-19 07:26 UTC, gmarco
Details
local tools menu (54.08 KB, image/jpeg)
2016-10-19 07:26 UTC, gmarco
Details
screenshot (343.13 KB, image/jpeg)
2017-01-04 14:36 UTC, gmarco
Details

Note You need to log in before you can comment on or make changes to this bug.
Description gmarco 2016-10-15 15:20:39 UTC
Created attachment 128020 [details]
protection help

Beeing probably only an Italian translation I write the explain in Italian Language.

Leggendo l'help allegato si dice "Strumenti-Proteggi documento"
ma nel menu di "Strumenti" appare "Proteggi foglio elettronico ...
Occorre sincronizzare le due definizioni.
Comment 1 gmarco 2016-10-15 15:21:59 UTC
Created attachment 128021 [details]
menu strumenti
Comment 2 Valter Mura 2016-10-18 21:30:22 UTC
Hi,

discrepancy confirmed, there is a difference between the documentation, that follows the old menu structure, and the new interface.

The new menu is here: https://translations.documentfoundation.org/it/libo_ui/translate/officecfg/registry/data/org/openoffice/Office/UI.po#unit=100534789

but the interface points to: https://translations.documentfoundation.org/it/libo_help/translate/scalc/guide.po#unit=30707091

which is correctly translated, but doesn't follow the new menu.
Comment 3 gmarco 2016-10-19 07:26:09 UTC
Created attachment 128065 [details]
online tools menu
Comment 4 gmarco 2016-10-19 07:26:54 UTC
Created attachment 128066 [details]
local tools menu
Comment 5 gmarco 2016-10-19 07:27:30 UTC
Hi,
look also the discrepancies in the TOOLS menu between the online and the local versions.
Comment 6 Buovjaga 2016-10-29 18:44:50 UTC
NEW per comment 2
Comment 7 Stanislav Horacek 2016-11-06 19:36:38 UTC
Patch submitted to Gerrit:
https://gerrit.libreoffice.org/#/c/30614/
Comment 8 Commit Notification 2016-11-06 23:07:30 UTC
Stanislav Horacek committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/help/commit/?id=63fa2d5d4e0b4136516bd8204109271bf85c91ae

tdf#103244 adjust menu path to Tools - Protect Sheet/Spreadsheet
Comment 9 Stanislav Horacek 2016-11-07 16:57:37 UTC
It should be fixed now.
Comment 10 gmarco 2017-01-04 14:30:51 UTC
(In reply to Stanislav Horacek from comment #9)
> It should be fixed now.

I think it is not yet fixed (LO 5.2.3.3)
@ Walter Mura (as it could be a discrepancy in the IT version):

1- l'help online dice solo "Proteggi documento"

2- l'help locale alla voce "Protezione celle e fogli" dice al p.5 "... scegliete Strumenti-Proteggi documento-Foglio" e "... Strumenti-Proteggi documento-Documento"

3- la finestra del menu Strumenti offre "Proteggi foglio" e Proteggi foglio elettronico"

Note mie:
- al p.2 dovrebbe essere "Strumenti-Proteggi foglio" e "Strumenti-Proteggi documento"

- al p.3 dovrebbe essere "Proteggi foglio" e "Proteggi documento"
Comment 11 gmarco 2017-01-04 14:36:50 UTC
Created attachment 130150 [details]
screenshot
Comment 12 Stanislav Horacek 2017-01-04 21:37:40 UTC
The fix will not be in 5.2, but in 5.3 - please check it there and reopen if needed, now I'm closing again.
Comment 13 Adolfo Jayme 2017-01-05 11:30:09 UTC
@gmarco: Just a tip for you in the future.

Whenever a commit notification is posted (e.g., comment 8), the whiteboard of the bug report gets a note stating the version in which you will find the commit; in this case, “target:5.3.0” means that the commit will appear in LibreOffice 5.3.0.

In general, we do not backport commits that change translatable strings to earlier versions, because we enforce a “string freeze” in the released series to avoid burdening translators.
Comment 14 gmarco 2017-01-05 15:10:46 UTC
(In reply to Adolfo Jayme from comment #13)
> @gmarco: Just a tip for you in the future.
> 

OK, thanks, I had viewed the comment 9 (It should be fixed now) but not the whiteboard commit by comment 8.