Bug 103247 - TABLE STYLE: crash trying clicking on Modify to edit a table style.
Summary: TABLE STYLE: crash trying clicking on Modify to edit a table style.
Status: RESOLVED DUPLICATE of bug 101648
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.3.0.0.alpha0+
Hardware: All Windows (All)
: medium critical
Assignee: Not Assigned
QA Contact:
URL:
Whiteboard:
Keywords: haveBacktrace
Depends on:
Blocks:
 
Reported: 2016-10-15 16:20 UTC by m.a.riosv
Modified: 2016-10-15 22:49 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
bt with symbols (5.54 KB, text/plain)
2016-10-15 22:31 UTC, Julien Nabet
Details

Note You need to log in before you can comment on or make changes to this bug.
Description m.a.riosv 2016-10-15 16:20:35 UTC
Description:
Crash at clicking to Modify a table style.

Steps to Reproduce:
1. Open a new writer document
2. On the side bar select Styles and formatting and then Table styles.
3. Right-click on any style and select Modify.
4. LibreOffice crash

Actual Results:  
LibreOfficeDev 5.3 - Fatal Error
/!\ file:///G:/User/MARV/Downloads/LibreOffice%20Master.32/program/share/config/soffice.cfg/modules/swriter/ui/templatedialog32.ui

Expected Results:
No crash


Reproducible: Always

User Profile Reset: No

Additional Info:
Version: 5.3.0.0.alpha0+
Build ID: ed5ca17dce1d088ce3fbbb3a30f748ba92cd07d9
CPU Threads: 4; OS Version: Windows 6.19; UI Render: GL; 
TinderBox: Win-x86@42, Branch:master, Time: 2016-10-09_05:40:51
Locale: es-ES (es_ES); Calc: CL


User-Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:49.0) Gecko/20100101 Firefox/49.0
Comment 1 Julien Nabet 2016-10-15 22:21:33 UTC
On pc Debian x86-64 with master sources updated today, I could reproduce this.

I noticed this on console:
warn:legacy.osl:29981:1:sw/source/uibase/app/docstyle.cxx:1407: unknown style family
warn:vcl.layout:29981:1:vcl/source/window/builder.cxx:210: Unable to read .ui file: file:///home/julien/lo/libreoffice/instdir/program/../share/config/soffice.cfg/modules/swriter/ui/templatedialog32.ui
Gtk-Message: GtkDialog mapped without a transient parent. This is discouraged.
Comment 2 Julien Nabet 2016-10-15 22:31:25 UTC
Created attachment 128026 [details]
bt with symbols

I retrieved a bt from vcl/source/window/builder.cxx
Comment 3 Julien Nabet 2016-10-15 22:34:10 UTC
Jakub/Miklos: Noticing https://cgit.freedesktop.org/libreoffice/core/commit/?id=8b8159784821b7ddf031aec925353c274a10875e, thought you might be interested in this one.
See my bt + comment.
Comment 4 Maxim Monastirsky 2016-10-15 22:49:00 UTC

*** This bug has been marked as a duplicate of bug 101648 ***