Bug 103250 - Autocorrect does not recognise Greek punctuation characters « and »
Summary: Autocorrect does not recognise Greek punctuation characters « and »
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.0.5.2 release
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: AutoCorrect-Complete
  Show dependency treegraph
 
Reported: 2016-10-15 19:14 UTC by vic.orgos+bugslibreoffice
Modified: 2017-12-24 03:28 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description vic.orgos+bugslibreoffice 2016-10-15 19:14:44 UTC
Description:
Autocorrect does not perform correction when using Greek quotation marks « and »

This is regardless of the "localized options quote replacement" setting as this setting does not apply in this instance.

" " double quotes fails with "localized options quote replacement" on but works when it is off.

« » fail regardless of "localized options quote replacement" setting

As tommy27 commented, it looks like LO does not recognise « and » as punctuation.

See also as bug 101851


Steps to Reproduce:
1. Switch to Greek keyboard layout
2. Enter « Greek word »
3. autocorrect does not replace words

Actual Results:  
autocorrection does not happen, words appear as misspelled

Expected Results:
autocorrection


Reproducible: Always

User Profile Reset: No, happens on fresh install

Additional Info:
Original bug was closed as duplicate but wrong diagnosis was made.

as shown in comment #3 in bug 101851 the likely cause,

 @Lazlo Nemeth
 can we add those « and » to the "autocorrect" triggers list?


User-Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:49.0) Gecko/20100101 Firefox/49.0
Comment 1 tommy27 2016-10-16 04:50:58 UTC
you are right. not truly a duplicate of Bug 54409
status NEW.
Comment 2 QA Administrators 2017-12-24 03:28:50 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

Test to see if the bug is still present with the latest version of LibreOffice from https://www.libreoffice.org/download/

If the bug is present, please leave a comment that includes the information from Help - About LibreOffice.
 
If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a comment that includes the information from Help - About LibreOffice.

Please DO NOT

Update the version field
Reply via email (please reply directly on the bug tracker)
Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not 
appropriate in this case)


If you want to do more to help you can test to see if your issue is a REGRESSION. To do so:
1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3) from http://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug
3. Leave a comment with your results.
4a. If the bug was present with 3.3 - set version to 'inherited from OOo';
4b. If the bug was not present in 3.3 - add 'regression' to keyword


Feel free to come ask questions or to say hello in our QA chat: https://kiwiirc.com/nextclient/irc.freenode.net/#libreoffice-qa

Thank you for helping us make LibreOffice even better for everyone!

Warm Regards,
QA Team

MassPing-UntouchedBug