Bug 103330 - SIDEBAR: Unable to modify new default cell styles
Summary: SIDEBAR: Unable to modify new default cell styles
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
5.3.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Markus Mohrhard
QA Contact:
URL:
Whiteboard: target:5.4.0 target:5.3.4
Keywords: notBibisectable, regression
: 107856 (view as bug list)
Depends on:
Blocks: 90937
  Show dependency treegraph
 
Reported: 2016-10-19 13:03 UTC by Yousuf Philips (jay)
Modified: 2017-05-19 17:25 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Yousuf Philips (jay) 2016-10-19 13:03:24 UTC
Steps:
1) Open Calc with a git build
2) Open the sidebar's styles and formatting
3) Right-click on 'Accent 1' style
4) No 'Modify' entry in context menu

Version: 5.3.0.0.alpha0+
Build ID: 55d028488580c5835682188cb8d23e5fe4dcb424
CPU Threads: 4; OS Version: Linux 4.4; UI Render: default; 
Locale: en-US (en_US.UTF-8); Calc: group
Comment 1 Aron Budea 2016-10-21 08:36:45 UTC
Confirmed with build d4936e876b1b965505ee2e82efaa35eef65d2135 / Windows 7.

Note that it's not working for any cell styles, like Heading1.
It's working fine for Heading1 in 5.2.2.2. => regression
However, it might not be bibisectable because of bug 103332, need to check bibisect repository.
Comment 2 Yousuf Philips (jay) 2016-10-21 09:54:30 UTC
(In reply to Aron Budea from comment #1)
> Note that it's not working for any cell styles, like Heading1.

Works for Default. :D

> It's working fine for Heading1 in 5.2.2.2. => regression

No need to bibisect as these new cell styles are a new implementation.
Comment 3 Yousuf Philips (jay) 2016-10-21 09:56:10 UTC
So i mentioned this issue to moggi on irc and he said "that means it is not registered in scp". @Cloph: Any input on this.
Comment 4 Markus Mohrhard 2016-11-05 21:23:14 UTC
(In reply to Yousuf Philips (jay) from comment #3)
> So i mentioned this issue to moggi on irc and he said "that means it is not
> registered in scp". @Cloph: Any input on this.

Then I misunderstood you. I thought you mentioned that the styles don't show up in a release. That would be a scp issue (and still need to be fixed by me).

If just the modify button does not show I need to inspect what is going on.
Comment 5 Yousuf Philips (jay) 2016-11-07 14:54:07 UTC
(In reply to Markus Mohrhard from comment #4)
> Then I misunderstood you. I thought you mentioned that the styles don't show
> up in a release. That would be a scp issue (and still need to be fixed by
> me).

I mistakenly put comment 3 here when it was for bug 103332. :D

> If just the modify button does not show I need to inspect what is going on.

Yes the modify entry doesnt show.
Comment 6 Mike Kaganski 2017-02-03 08:23:49 UTC
Just wanted to mention a workaround: right-click any of those styles -> New -> the style is selected in "Inherit from:" -> Edit Style.
Comment 7 Commit Notification 2017-04-22 20:47:06 UTC
Markus Mohrhard committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=6e55f7df9ae8e0948b456cb02f6c841b353acd23

mark all new styles as default styles, tdf#103380, tdf#103330

It will be available in 5.4.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 8 Commit Notification 2017-04-27 15:27:39 UTC
Markus Mohrhard committed a patch related to this issue.
It has been pushed to "libreoffice-5-3":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=4df765766892a9148b7be1b8d5f174ee37cf73e0&h=libreoffice-5-3

mark all new styles as default styles, tdf#103380, tdf#103330

It will be available in 5.3.4.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 9 Buovjaga 2017-05-19 17:25:20 UTC
*** Bug 107856 has been marked as a duplicate of this bug. ***