Download it now!
Bug 103396 - Trim marks are not available for use when a professional printer requires them
Summary: Trim marks are not available for use when a professional printer requires them
Status: RESOLVED DUPLICATE of bug 103683
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Printing and PDF export (show other bugs)
Version:
(earliest affected)
5.2.2.2 release
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: needsUXEval
: 114891 114892 (view as bug list)
Depends on:
Blocks: DTP
  Show dependency treegraph
 
Reported: 2016-10-21 23:29 UTC by Taylor
Modified: 2019-09-06 12:39 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Taylor 2016-10-21 23:29:02 UTC
Description:
Professional printers (or at least the two I have talked to) have requirements on how they expect a file to arrive (if you don't want to pay extra).
They have typically expected CMYK, bleed on full page graphics or color, and trim marks to show where to cut.

Steps to Reproduce:
1. Create a new document in Writer / Draw (example: Business Cards) and create document desired.
2. Export document, run through process to make CMYK, realize that you don't have a bleed for the background OR crop marks.

Actual Results:  
No option for crop marks / bleed

Expected Results:
I expect to see an option for exporting for professional printers by home/business users


Reproducible: Always

User Profile Reset: No

Additional Info:
Link to Microsoft explanation: https://blogs.office.com/2011/02/09/what-are-crop-marks-and-why-would-you-want-to-print-them



User-Agent: Mozilla/5.0 (X11; Linux x86_64; rv:49.0) Gecko/20100101 Firefox/49.0
Comment 1 V Stuart Foote 2016-10-22 05:28:44 UTC
Thought about closing WFM, but to new for UX discussion related to bug 99525.

In Draw you can size the page larger than final desired print size, set margin to zero.  You can layout trim marks, and registration marks on a Master page from main menu's  View -> Master mode. Also trivial to allow for bleed and compose slugs outside the trim marks.

You have full control to configure the page, margin and spacing to object while laying out the document.

Actual CMYK would not be controlled from within LibreOffice--rather use a "print to file" format supporting CMYK.  Or a print driver capable of splitting out the CMYK.

It is not as convenient as some dedicated DTP programs, and there is no ability to easily toggle printer markup.  But kind of believe that doing more than that is going to be beyond scope of project.
Comment 2 Taylor 2016-10-22 17:48:33 UTC
I have done what you suggest with various documents, i.e. making the page "bigger" to accommodate bleed/crop marks, and so on. I just have to figure out how to add crop marks to the document -- the border section of the page dialog doesn't quite get me what I want. If I could have the borders go all the way to the edge of the page, it would be better. 


Workarounds for items mentioned in initial bug report:
Make page size larger than required (allows for bleed)
Add borders (KIND OF ACTS LIKE CROP MARKS, may have some black borders on final piece) around entire page, change "spacing to contents" and margins appropriately
Export to PDF and then use ghostscript to convert to CMYK.


For reference, I use the following command to convert to pdfs to the CMYK color space (which is why I was requesting an enhancement on crop marks):

#!/usr/bin/env bash
gs \
	-o "cmyk-${1}" \
	-sDEVICE=pdfwrite \
	-sProcessColorModel=DeviceCMYK \
	-sColorConversionStrategy=CMYK \
	-sColorConversionStrategyForImages=CMYK \
	-dEncodeColorImages=false \
	-dOverrideICC \
	"${1}"

I probably should have focused on writer, since that is the program used when creating business cards from the menu, instead of mentioning draw.


----


After typing that all up, crop marks might go better in the "Page Style" "Borders" section.
Comment 3 V Stuart Foote 2016-10-22 20:46:11 UTC
(In reply to Taylor from comment #2)
> ... 
> I probably should have focused on writer, since that is the program used
> when creating business cards from the menu, instead of mentioning draw.
> 

Maybe, but reality is that LibreOffice (and OO before) provides for this type of layout annotation only through Draw's "Master Page"--folks needing an occasional print shop ready layout can already make do with Draw. 

As noted, print shop ready layout from the other modules is not well supported.

Developing a series of templates for Draw's Master Page composition might be of some help for the average user--but efforts beyond that seem a bit too much of a DTP corner case.
Comment 4 Heiko Tietze 2016-12-29 10:36:06 UTC
Let's continue the discussion in the other ticket.

*** This bug has been marked as a duplicate of bug 103683 ***
Comment 5 V Stuart Foote 2018-01-07 18:50:18 UTC
*** Bug 114892 has been marked as a duplicate of this bug. ***
Comment 6 V Stuart Foote 2018-01-07 18:51:08 UTC
*** Bug 114891 has been marked as a duplicate of this bug. ***