Bug 103527 - Documented Tools->Options->LibreOffice[Dev]->Colors is missing; may need revised Help for how to define new cell bg colors
Summary: Documented Tools->Options->LibreOffice[Dev]->Colors is missing; may need revi...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Documentation (show other bugs)
Version:
(earliest affected)
5.3.0.0.alpha0+
Hardware: All Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:5.3.0 target:5.4.0 target:5.3....
Keywords:
Depends on:
Blocks: Help-Changes-Features
  Show dependency treegraph
 
Reported: 2016-10-27 01:11 UTC by Jim Avera
Modified: 2018-10-01 10:10 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
screenshot of Tools->Options...->LibreOfficeDev menu (with no "Colors") (70.60 KB, image/png)
2016-10-27 01:13 UTC, Jim Avera
Details
screenshot of color selector with no "pick" button (that I can see...) (176.20 KB, image/png)
2016-12-09 19:13 UTC, Jim Avera
Details
screenshot for Comment #28 (116.82 KB, image/png)
2017-04-10 00:37 UTC, Jim Avera
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jim Avera 2016-10-27 01:11:56 UTC
Description:
The Help text says to create a new color go to
  Tools->Options->LibreOfficeDev->Colors

but there is no "Colors" under Tools->Options->LibreOffice[Dev]

Using Version: 5.3.0.0.alpha1
Build ID: f4ca1573fcf445164c068c1046ab5d084e1b005f

Steps to Reproduce:
n/a

Actual Results:  
n/a

Expected Results:
n/a


Reproducible: Always

User Profile Reset: No

Additional Info:


User-Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:49.0) Gecko/20100101 Firefox/49.0
Comment 1 Jim Avera 2016-10-27 01:13:52 UTC
Created attachment 128294 [details]
screenshot of Tools->Options...->LibreOfficeDev menu (with no "Colors")
Comment 2 Jim Avera 2016-10-27 01:17:21 UTC
I see now that the menu item is called "Application Colors".   

Updated bug title to indicate that Help text should be changed to give the correct menu item name.
Comment 3 Jim Avera 2016-10-27 01:33:07 UTC
...on further examination, the "Application Colors" dialog is completely different from the old "Colors" dialog, and I'm unable to see where to create a new custom color for use as the background color in a Spreadsheet cell.

So I'm updating the description again to say that the feature in the Help is not there
Comment 4 Gabor Kelemen 2016-10-30 09:11:03 UTC
This was removed recently as part of a GSoC project:
https://cgit.freedesktop.org/libreoffice/core/commit/?id=28da3aed71a4850f47156d717b6a18fce98154e9
Comment 5 Jim Avera 2016-10-30 20:59:51 UTC
Was the ability to define new colors removed entirely, or moved to some other place in the UI?
Comment 6 Commit Notification 2016-10-31 10:59:44 UTC
Gabor Kelemen committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/help/commit/?id=129393b348cf785721113200e54fe7d243dbd403

tdf#103527 Remove references to the Colors settings page
Comment 7 Gabor Kelemen 2016-11-02 15:09:54 UTC
(In reply to Jim Avera from comment #5)
> Was the ability to define new colors removed entirely, or moved to some
> other place in the UI?

The feature is still there. It's just not reachable anymore from the main Options panel. Instead, it's on the Area tab of the "Format" window of various objects like page, paragraph, frame, shape, image etc.
I'm working on updating this whole page: https://help.libreoffice.org/Common/Colors
Comment 8 Jim Avera 2016-11-02 17:42:14 UTC
Gabor, would you mind giving specific instructions for how to define a custom color for a spreadsheet cell background?   

For example, open the Styles & Formatting window in calc, right-click Default and select "New...", click the Background tab, then...  there is no method I can find to create a new color.
Comment 9 Olivier Hallot 2016-11-25 15:52:10 UTC
(In reply to Jim Avera from comment #8)
> Gabor, would you mind giving specific instructions for how to define a
> custom color for a spreadsheet cell background?   
> 
> For example, open the Styles & Formatting window in calc, right-click
> Default and select "New...", click the Background tab, then...  there is no
> method I can find to create a new color.

To add a colcor, click on the "Pick" button, select the color, click OK, then click on the Add button to add you color into the "custom" color palete.
Comment 10 Olivier Hallot 2016-11-25 15:52:54 UTC
Making dep of bug#80430
Comment 11 Commit Notification 2016-12-07 21:24:35 UTC
Gabor Kelemen committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/help/commit/?id=15ced7d749a5a317e2c10b84ac035d3e90c02a9a

tdf#103527 Update Area -> Color page
Comment 12 Jim Avera 2016-12-09 19:12:27 UTC
> To add a colcor, click on the "Pick" button, select the color ...

Oliver, I just don't see the button.  Please look at attached screen shot.

(Version: 5.4.0.0.alpha0+ Build ID: cb598029835477326b190bc99abd31a487cc5a91)
Comment 13 Jim Avera 2016-12-09 19:13:42 UTC
Created attachment 129432 [details]
screenshot of color selector with no "pick" button (that I can see...)
Comment 14 Gabor Kelemen 2016-12-09 19:45:38 UTC
(In reply to Jim Avera from comment #12)
> > To add a colcor, click on the "Pick" button, select the color ...
> 
> Oliver, I just don't see the button.  Please look at attached screen shot.
> 
> (Version: 5.4.0.0.alpha0+ Build ID: cb598029835477326b190bc99abd31a487cc5a91)

Hi Jim

I think you are right, the new Area window is only available in Writer, not in the other applications. So that's a feature loss for now.
Comment 15 Commit Notification 2016-12-11 18:20:32 UTC
Gabor Kelemen committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/help/commit/?id=957f72b1e3aeeb596eb9c82b4b623d09d1122e71

tdf#103527 (related) Drop redundant Color settings page
Comment 16 Commit Notification 2016-12-12 15:38:10 UTC
Gabor Kelemen committed a patch related to this issue.
It has been pushed to "libreoffice-5-3":

http://cgit.freedesktop.org/libreoffice/help/commit/?id=90b439d73faed542e01ae08e973ddb5b3dcc0bf2&h=libreoffice-5-3

tdf#103527 (related) Drop redundant Color settings page
Comment 17 Jim Avera 2016-12-12 18:44:51 UTC
I think this is a fairly serious feature regression (not allowing user-defined colors in spreadsheets).   

So please consider rolling back the changes before the 5.3 release if that is the only way to maintain compatibility with existing documents.

(If the underlying color def rep is the same as it always was, then maybe you could just put back the global color-definition dialog until the new color-picker stuff is fully integrated everywhere it has to be).

Thanks.
Comment 18 Commit Notification 2016-12-24 23:30:55 UTC
Gabor Kelemen committed a patch related to this issue.
It has been pushed to "libreoffice-5-3":

http://cgit.freedesktop.org/libreoffice/help/commit/?id=fbcfea666d6af3d158cd5281ddcd7d93703e5634&h=libreoffice-5-3

tdf#103527 Update Area -> Color page
Comment 19 Xisco Faulí 2017-03-01 11:08:19 UTC
Hello Gabor,
Is this bug fixed?
If so, could you please close it as RESOLVED FIXED?
Comment 20 Jim Avera 2017-03-01 18:30:51 UTC
Not yet fixed in 5.4.0.0.alpha0+ from 2017-02-14

STEPS TO REPRODUCE:

1. Open calc
2. Select a cell.  Rightclick->Format Cells... -> Background
3. Try to set background to a custom color #123456

RESULTS: Not possible.  There is no "Area tab" (as mentioned in comment#7), and Options->Colors which was in previous releases is gone.

I'd like to suggest again that until the new color-creator mechanism is fully integrated everywhere colors are used (including calc cell backgrounds), that the changes which removed the global color-def stuff be rolled back.
Comment 21 Jim Avera 2017-03-01 18:41:30 UTC
Tried latest master build (March 1, 2017) and it's the same.

Also: Reading help text for "colors->adding" *in calc* shows instructions
which  discuss a "Color Window" accessed with Format - Area - Colors tab - Edit

Does this mean the global "Format" menu?  I can't find an "Area" entry in the global Format menu.
Comment 22 russell 2017-03-11 09:28:32 UTC
Regarding Tools -> Options -> LibreOffice -> Colors

It is missing in 5.3.0.3 (linux mint 17.3). 
Similar to the first screenshot by Jim Avera.

It is NOT missing in 5.2.3.3 (opensuse leap 42.2).

I went looking for help because I always went to Tools -> Colors to add custom colors to palettes that I wanted to use across LibreOffice Writer and Calc. 

Custom colors can be created and added to a palette from:
Writer -> Format -> Page -> Area -> Colors.
This is the only place I found "Area".

Calc can create custom colors via the toolbar buttons, Font Color and Background Color, but can not save them to a palette. 

Calc has access to the custom palettes created by Writer via the toolbar buttons, Font Color and Background Color.
Comment 23 Thomas Lendo 2017-03-15 15:01:22 UTC
Jim and  russell:
This bug is only to fix the missing documentation - not to fix any missing color feature or a regression. Please search for other existing bugs or file new bugs that address missing color features in Calc, custom colors, etc. in current LibO versions. Calc's page and cell background color dialog is covered by bug 105225.
Comment 24 Jim Avera 2017-03-15 16:39:57 UTC
Hi Thomas,

Either the docs or the code (or both) need to change so that the user can both know how to perform the function (e.g. custom color a cell background), and be able to actually do it. 

On the documentation side, the current docs discuss the old UI for custom colors, which doesn't work any longer. But simply changing the docs to discuss the new "Area tab" method would be insufficient because that method does not actually work in all cases, e.g. for Calc cell backgrounds.

It is of course up to the developers what to do.  But I see only 3 choices:

1. Roll back the incomplete changes for now, and restore the old color UI.  In that case the docs don't need any changes.

2. Change the code to add the missing functionality (e.g. Cell background colors).  In that case the docs need to be revised to describe only the new method.

3. If there is a work-around, leave the code as-is.  In this case, the docs need to be revised for the new method AND to clearly describe the work-arounds in all the cases where direct functionality was lost (e.g. switch from Calc to Writer to define custom color which can be later used for cell backgrounds).

So I think the decision of what to do with docs can not be separated from what to do with the code, in this case.  The decision presumably depends on available resources.

-Jim
Comment 25 Regina Henschel 2017-04-06 20:37:14 UTC
The workaround is: Draw a shape and open the area dialog for the shape. Select a palette and/or add you own color. Click OK to assign a color from the selected palette. When opening the background dialog for the table, it has the new selected palette. You can then delete the temporarily inserted shape.

Bug 105225 collects all places, where the new color dialog is not yet available.
Comment 26 Jim Avera 2017-04-09 02:43:24 UTC
Regina, would you please clarify how to "draw a shape"?  Remember, this is in Calc, not Draw.
Comment 27 Regina Henschel 2017-04-09 11:08:30 UTC
Jim, the right most symbol in the Standard toolbar should be "Show Draw Functions". It toggles the view of the Drawing toolbar. The default position of the Drawing toolbar is above the status bar. Or you use View > Toolbars > Drawing to enable the Drawing toolbar. Draw a shape, keep it selected and use the context menu to open the Area dialog.
Comment 28 Jim Avera 2017-04-10 00:37:02 UTC
Hi Regina,

Thanks for the clarification, I can now create a custom color for the temporary shape.

However I still don't see how to apply that color to spreadsheet cell backgrounds.  When I open the Background tab for in Format Cells, the palette does not include the new color I created, or at least I didn't see it.
Would you mind spelling out beginner-level step-by-step instructions to create a custom color and apply it to a spreadsheet (not Writer table) cell Background?

Attached is a screen-shot of what I see when viewing the color palette reached by (rightclick)->Format Cells->Background-tab.  This is after creating a custom color named "CustomIckyYellow" in the temporary shape.  I moused over all the colors in the palette and did not find it by name, and I don't think I see it by color (though it's hard to be certain).   I _do_ see custom colors I created using previous versions of Libre Office via Tools->Options->Colors.

Thanks.
Comment 29 Jim Avera 2017-04-10 00:37:43 UTC
Created attachment 132427 [details]
screenshot for Comment #28
Comment 30 Regina Henschel 2017-04-10 07:38:03 UTC
Do not use the way Format > Cells. Use the symbol "Background color" in the Formatting toolbar or use the section Cell Appearance in the property pane of the sidebar. In Calc those symbols are not for the paragraph background but for the cell background. You get a dialog, which has top a drop down field, where can choose the palette. Your own colors are in "Custom". In addition it has a list of recent used colors and symbol to call a tool to define new colors. So forget my suggestion to use a shape and use that.
Nevertheless it is an error, that the Background tab is not yet adapted.
Comment 31 Regina Henschel 2017-04-10 09:04:00 UTC
With index entry "Options; tools" you get a page in the help, where the top-level sections of the options dialog are listed. Click on "LibreOffice". There is a section "Color" about the no longer existing part. It needs to be removed.

I see this help error in Version: 5.4.0.0.alpha0+
Build ID: 6a59352290a5d05c4236522b56124ac06cd591ad
CPU threads: 4; OS: Windows 6.1; UI render: default; 
TinderBox: Win-x86@62-TDF, Branch:MASTER, Time: 2017-03-31_08:37:47
Locale: de-DE (de_DE); Calc: group

The fact, that in Calc the Format > Cells > Background dialog is not adapted is already tracked in bug 105225, see Description there.
Comment 32 Xisco Faulí 2017-07-13 10:20:49 UTC
Setting Assignee back to default. Please assign it back to yourself if you're
still working on this issue
Comment 33 Commit Notification 2018-10-01 10:08:30 UTC
Ilmari Lauhakangas committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/help/commit/?id=c5ee45213fccf09f14c6fe13fd25cae0c8a71b43

tdf#103527 Remove Colors from Options help