Bug Hunting Session
Bug 103544 - DOCX export: Image loss when have a frame anchored to the same paragraph
Summary: DOCX export: Image loss when have a frame anchored to the same paragraph
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.4.0.0.alpha0+ Master
Hardware: All All
: medium normal
Assignee: Tamás Zolnai
URL:
Whiteboard: target:5.3.0 target:5.2.4
Keywords: bibisected, bisected, filter:docx, regression
: 104605 (view as bug list)
Depends on:
Blocks: Frame-Dialog
  Show dependency treegraph
 
Reported: 2016-10-27 20:48 UTC by Tamás Zolnai
Modified: 2019-08-13 05:52 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Frame and image anchored to the same paragraph (14.66 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2016-10-27 20:48 UTC, Tamás Zolnai
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Tamás Zolnai 2016-10-27 20:48:04 UTC
Description:
When an image and a frame is anchored to the same paragraph, DOCX export drops the image and saves only the frame.

Steps to Reproduce:
1.Open attached DOCX file
2.Save it as a new DOCX file
3.Open the new file in LO Writer or in MS Word 

Actual Results:  
Image is lost.

Expected Results:
Image should be there after save to DOCX format.


Reproducible: Always

User Profile Reset: No

Additional Info:


User-Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/54.0.2840.71 Safari/537.36
Comment 1 Tamás Zolnai 2016-10-27 20:48:49 UTC
Created attachment 128313 [details]
Frame and image anchored to the same paragraph
Comment 2 Xisco Faulí 2016-10-28 10:26:37 UTC
Confirmed in

Version: 5.3.0.0.alpha0+
Build ID: 8974b0fafb18f9dd3f2c0e175a3255b80e4c249e
CPU Threads: 4; OS Version: Linux 4.2; UI Render: default; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group

and 

Version: 4.5.0.0.alpha0+
Build ID: 2851ce5afd0f37764cbbc2c2a9a63c7adc844311
Locale: ca_ES

but not in

Version: 4.3.0.0.alpha1+
Build ID: c15927f20d4727c3b8de68497b6949e72f9e6e9e

thus, this is a regression
Comment 3 Xisco Faulí 2016-10-28 10:38:09 UTC
Regression introduced by:

author	Rohit Deshmukh <rohit.deshmukh@synerzip.com>	2014-06-13 06:09:56 (GMT)
committer	Miklos Vajna <vmiklos@collabora.co.uk>	2014-06-19 11:01:17 (GMT)
commit	1c876f5616522ab695de8c0316cdb0c601081815 (patch)
tree	cca50a93dbf02fe9e9e6b8935a2a4496b051f642
parent	ee9e8f677103f3b93faaef55832fb704f95e0a4b (diff)

fdo#78590: Fix for Corruption of para with framePr & drawing object into para
Issue:
 - File contains paragraph with framePr have graphic object in it.
 - So Libreoffice converts framePr into textbox.
 - So after saving file textbox gets exported with drawing object.
 - MS office does not allowed drawing object inside tetxbox.

Adding CC: to Rohit Deshmukh
Comment 4 Commit Notification 2016-10-28 14:12:50 UTC
Tamás Zolnai committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=b927c1f4b334f80d2c2965e5b7327d6b6a685105

tdf#103544: DOCX exp.: Image loss when have a frame anchored to the same para.

It will be available in 5.3.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 5 Commit Notification 2016-11-11 15:35:05 UTC
Tamás Zolnai committed a patch related to this issue.
It has been pushed to "libreoffice-5-2":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=d3d714f7a16df13b97a06ec68234d08d57a09479&h=libreoffice-5-2

tdf#103544: DOCX exp.: Image loss when have a frame anchored to the same para.

It will be available in 5.2.4.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 6 Justin L 2019-08-13 05:52:55 UTC
*** Bug 104605 has been marked as a duplicate of this bug. ***