Download it now!
Bug 103579 - UI: Open Navigator in docked state by default
Summary: UI: Open Navigator in docked state by default
Status: RESOLVED DUPLICATE of bug 81902
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.4.0.3 release
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: needsUXEval
Depends on:
Blocks: Navigator
  Show dependency treegraph
 
Reported: 2016-10-29 19:59 UTC by Cor Nouws
Modified: 2017-05-03 10:51 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Cor Nouws 2016-10-29 19:59:44 UTC
In a fresh installation, the Navigator window is floating.
With the usual wide screens, docked state makes more sense I think.
Comment 1 V Stuart Foote 2016-10-29 20:48:55 UTC
@Cor, do we really need to do this? 

The continued use of F5 to launch an instance of the sidebar deck's Navigator in a separate frame is _temporary_ pending work on bug 85905 -- F5 will revert to the "docked" Sidebar deck, but with that we'll be able to position each deck docked or floating where we like.

Remember that when implementing the Sidebar decks for bug 73151 Samuel removed the Gallery and Style & Formatting detached instance but left a detached Sidebar Navigator deck in a _floating_ frame.

That could be changed of course, but seemed then to have more folks voicing preference for a floating instance rather than docked left.  Still the case?

And since it eventually goes away--do we gain anything now by forcing it docked left?

Also interesting interplay of left docked Navigator in Draw--with both the Draw toolbar and the Page Pane "previews" docked left by default also.

=-ref-=
https://bugs.documentfoundation.org/show_bug.cgi?id=73151#c19  

https://gerrit.libreoffice.org/#/c/11253/
Comment 2 Cor Nouws 2016-10-29 21:35:34 UTC
Hi Stuart,

(In reply to V Stuart Foote from comment #1)
> @Cor, do we really need to do this? 
> 
> The continued use of F5 to launch an instance of the sidebar deck's
> Navigator in a separate frame is _temporary_ pending work on bug 85905 -- F5
> will revert to the "docked" Sidebar deck, but with that we'll be able to
> position each deck docked or floating where we like.

Thanks for remembering me to this. I did not pay too much attention to that topic - only jumped in now and then. (Great that I may lean on your & others focus now and then.)

> And since it eventually goes away--do we gain anything now by forcing it
> docked left?

Ah well, prolly not. So let me be clear and close this issue right away.
Comment 3 Yousuf Philips (jay) (retired) 2017-05-03 10:51:01 UTC

*** This bug has been marked as a duplicate of bug 81902 ***