Bug 103623 - Opening OTS/ODS file with image takes very long
Summary: Opening OTS/ODS file with image takes very long
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: perf
Depends on:
Blocks: Calc-Images
  Show dependency treegraph
 
Reported: 2016-11-01 16:09 UTC by Oliver Klee
Modified: 2019-02-19 22:03 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
affected file (138.58 KB, application/vnd.oasis.opendocument.spreadsheet-template)
2016-11-01 16:09 UTC, Oliver Klee
Details
Modified ots (139.55 KB, application/vnd.oasis.opendocument.spreadsheet-template)
2016-11-01 19:40 UTC, m.a.riosv
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Oliver Klee 2016-11-01 16:09:34 UTC
Created attachment 128405 [details]
affected file

Opening the attached OTS file take very long (more than one minute) using LibreOffice 5.1.4-0ubuntu1.

During opening this file (or any ODS file created from the OTS template), all other LibreOffice Calc windows will get displayed fine, but cannot be interacted with: The menu bar does not respond, and the spreadsheet cells cannot be edited. The windows can be resized and moved, though.

A window for the document that is being opened is there (i.e., it has the KDE frame), but its contents are not drawn (neither the spreadsheet cells nor the LibreOffice Calc UI).

There is no discernible CPU load during opening this file.

Purging the list of recent documents seems to avoid this problem for opening an affected file one or two time, but then the problem reappears.
Comment 1 Xisco Faulí 2016-11-01 16:42:26 UTC
Confirmed in

Version: 5.3.0.0.alpha1+
Build ID: 64d3bd38c9242c1cc114f6e68bf13475ef679b73
CPU Threads: 4; OS Version: Linux 4.2; UI Render: default; VCL: gtk2; Layout Engine: old; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group

and

LibreOffice 3.3.0 
OOO330m19 (Build:6)
tag libreoffice-3.3.0.4
Comment 2 Richard 2016-11-01 18:50:12 UTC
CONFIRMED on Ubuntu 16.04 and Libreoffice 5.2.2.2
Comment 3 m.a.riosv 2016-11-01 19:40:17 UTC
Created attachment 128410 [details]
Modified ots

Seems the source of the issue it's a image in D39, that looks like an image of a hyperlink url in vertical.

Deleting it, and saved as ots, open just fine.

So I think the problem is why LibreOffice it's so slow managing that image.
Comment 4 Oliver Klee 2016-11-01 23:21:35 UTC
Just a wild (and mildly educated) guess: Maybe LibraOffice tries to load the image URL, then times out, and displays the image URL instead of the image.
Comment 5 Aron Budea 2016-11-10 17:33:06 UTC
Yes, that's what happens.
And it's not Linux-only, so adjusting OS field.
Comment 6 QA Administrators 2018-02-08 03:36:29 UTC Comment hidden (obsolete)
Comment 7 Oliver Klee 2018-02-16 09:32:47 UTC
I've just tested with version 6.0.1.1 (on Mac this time). The problem is still present.
Comment 8 QA Administrators 2019-02-17 03:44:24 UTC Comment hidden (obsolete)
Comment 9 Oliver Klee 2019-02-18 12:57:57 UTC
Using LibreOffice 7.0.7.3 on Kubuntu, the problem does not occur anymore. Marking as fixed.
Comment 10 Oliver Klee 2019-02-18 12:58:11 UTC
Using LibreOffice 6.0.7.3 on Kubuntu, the problem does not occur anymore. Marking as fixed.
Comment 11 steve -_- 2019-02-19 22:03:34 UTC
WORKSFORME as we have no specific commit fixing the performance issue.