Download it now!
Bug 103669 - Notebookbar does not have New button on File tab
Summary: Notebookbar does not have New button on File tab
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
5.3.0.0.alpha1+
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Notebookbar-Tabbed
  Show dependency treegraph
 
Reported: 2016-11-03 03:36 UTC by Volga
Modified: 2017-12-23 19:18 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Volga 2016-11-03 03:36:21 UTC
Description:
LibreOfficeDev can create file via File -> New menu item, but Notebookbar have no way to do it.

Steps to Reproduce:
1. Open LibreOfficeDev Writer
2. View -> Toolbar Layout -> Notebookbar
3. Notebookbar appearing, but no button to create the file, especially in File tab

Actual Results:  
This making Notebookbar not useful than default toolbar layout.

Expected Results:
To fix it, adding New button on File tab is necessary.


Reproducible: Always

User Profile Reset: No

Additional Info:
Version: 5.3.0.0.alpha1+
Build ID: c8be45889217c555e4bec92af838d0524ceba4e0
CPU Threads: 4; OS Version: Windows 6.2; UI Render: default; Layout Engine: new; 
TinderBox: Win-x86@62-merge-TDF, Branch:MASTER, Time: 2016-11-02_23:27:06
Locale: zh-CN (zh_CN); Calc: group


User-Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:49.0) Gecko/20100101 Firefox/49.0
Comment 1 Volga 2017-01-13 18:13:56 UTC
Confirmed with 5.3.0.1, this making Notenbookbar uncomfortable.

Version: 5.3.0.1 (x64)
Build ID: 3b800451b1d0c48045de03b5b3c7bbbac87f20d9
CPU Threads: 4; OS Version: Windows 6.19; UI Render: default; 布局引擎:新; 
Locale: zh-CN (zh_CN); Calc: group
Comment 2 Johnny_M 2017-03-11 09:53:21 UTC
Adding kkremitzki to CC, per bug 102062 comment 6.
Comment 3 Luke 2017-03-19 05:33:06 UTC
The Start Center would make a perfect main 'File' Button for the Notebook Bar. Once Bug 77590 is resolved, we can use that interface for new files.
Comment 4 Volga 2017-12-23 17:05:51 UTC
I think this can be closed, since LO 6.0 having New tab in Notebookbar.

Version: 6.0.0.1 (x64)
Build ID:d2bec56d7865f05a1003dc88449f2b0fdd85309a
CPU 线程:4; 操作系统:Windows 10.0; UI 渲染:默认; 
区域语言:zh-CN (zh_CN); Calc: group
Comment 5 Yousuf Philips (jay) (retired) 2017-12-23 19:18:13 UTC
Yes this has been fixed by me.