Bug Hunting Session
Bug 103700 - Cell comment is not comletely removed
Summary: Cell comment is not comletely removed
Status: RESOLVED DUPLICATE of bug 73287
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
5.2.3.3 release
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-11-04 12:52 UTC by Juergen
Modified: 2016-11-17 15:06 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Screenshot containing bugs and window with view settings (198.46 KB, image/jpeg)
2016-11-05 14:46 UTC, Juergen
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Juergen 2016-11-04 12:52:14 UTC
Description:
A cell comment window should be removed when the cursor leaves the cell which contains a comment. The upper or lower part of the comment windows (depending on the scroll position of the spreadsheet)is not removed. If a part of the spreadsheet is frozen (e.g. for headlines etc.)and the spreadsheet is not scrolled to the top position the Comment window will not be removed in the frozen part of the spreadsheet.

Steps to Reproduce:
1.Just take a spreadsheet with cells that contain comments
2.move the cursor over the cells that contain comments
3.move the cursor to another part of the spreadsheet

Actual Results:  
Parts of the comment windows are still visible. Which part and how much depends on the scrolling position of the Spreadsheet.

Expected Results:
The comment window should be removed completely


Reproducible: Always

User Profile Reset: No

Additional Info:
in my special case I have adjusted the comment window to a width of 23 cm and variable height. But this seems to be not relevant.
I reproduced this bug also on another PC (also Windows 10 64 bit).
How much of the comment window remains on the screen depends on the scroll position of the spreadsheet.


User-Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:49.0) Gecko/20100101 Firefox/49.0
Comment 1 brucehohl 2016-11-05 01:29:08 UTC
The described problem does not appear on this install:
Version: 5.2.3.2
Build ID: 1:5.2.3~rc2-0ubuntu1~xenial1
CPU Threads: 2; OS Version: Linux 4.4; UI Render: default; 
Locale: en-US (en_US.UTF-8); Calc: single

Perhaps different settings under: "Tools > Options >LibreOffice > View, Graphics Output" will impact the problem.
Comment 2 Juergen 2016-11-05 14:46:45 UTC
Created attachment 128516 [details]
Screenshot containing bugs and window with view settings

The screenshot contains the view settings you mentioned and the bugs (marked in red). If you need additional information about settings etc. please let me know.
Comment 3 Buovjaga 2016-11-17 13:41:38 UTC
Juergen: can you look at the reports in this list with "freeze" or "frozen" in them and see, if maybe your bug is already reported: https://bugs.documentfoundation.org/buglist.cgi?component=Calc&list_id=649617&query_format=advanced&resolution=---&short_desc=comment&short_desc_type=allwordssubstr

Set to NEEDINFO.
Change back to UNCONFIRMED, if your problem was not reported. Change to RESOLVED DUPLICATE of some report, if it exists.
Comment 4 Juergen 2016-11-17 15:06:45 UTC

*** This bug has been marked as a duplicate of bug 73287 ***