Download it now!
Bug 103703 - When printing multiple duplex copies of a document with odd pages, the first page is printed on the back of the last page of the first copy
Summary: When printing multiple duplex copies of a document with odd pages, the first ...
Status: REOPENED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard: target:5.3.0 target:6.3.0 target:6.1....
Keywords:
Depends on:
Blocks:
 
Reported: 2016-11-04 13:45 UTC by Dr. Martinus
Modified: 2020-08-01 09:02 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Dr. Martinus 2016-11-04 13:45:39 UTC
Description:
When I print a document that has an odd page number, i.e. 3,5,7,9 etc., and want to do multiple copies at once, the printer receives all pages in a row, which results in the first page of the second, fourth, sixth etc. copy being printed on the last page of the previous copy, which actually should be left empty. I try to visualize it with a 5 page document:

1|2 3|4 5|1 2|3 4|5 1|2 3|4 5|1 2|3 4|5

It should be:

1|2 3|4 5|- 1|2 3|4 5|- 1|2 3|4 5|- 1|2 3|4 5|- 

I hope this shows what I mean. I have done this kind of printing in OpenOffice without any such problems. 

Steps to Reproduce:
1. Create a document with an odd number of pages
2. Choose the printer's duplex print option
3. Print multiple copies

Actual Results:  
Document is printed like this:

1|2 3|4 5|1 2|3 4|5 1|2 3|4 5|1 2|3 4|5

Expected Results:
Document should be printed like this:

1|2 3|4 5|- 1|2 3|4 5|- 1|2 3|4 5|- 1|2 3|4 5|- 




Reproducible: Always

User Profile Reset: No

Additional Info:
I guess this has to do with the option "Print automatically inserted empty pages" within the print dialogue. This option had been always turned on in earlier versions, but has now been disabled by default. I found it awkward when printing form letters with only one page, because then it inserted always automatically an empty page, and maybe because of that this option has been disabled by default. 
However, when printing multiple copies of a document, this option shouldn't affect the way how LibreOffice prints the document. It's obvious that you want multiple copies of the same document, and not a mixup of pages.


User-Agent: Mozilla/5.0 (X11; Linux x86_64; rv:43.0) Gecko/20100101 Firefox/43.0
Comment 1 Regina Henschel 2016-11-04 22:14:22 UTC
Please use the option "Create single print jobs for collated output" from the Options page of the printing dialog. Does it word then?

In addition, please tell us, which printer do you use and what kind of Linux.
Comment 2 Dr. Martinus 2016-11-11 05:28:13 UTC
Yes, it seems to work then. This option should however be set by default. 
Printer: Brother MFC-J6920DW
Linux: Manjaro 16.10 64bit
Comment 3 Commit Notification 2016-11-14 10:16:47 UTC
Gabor Kelemen committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=37c3e57c788fb5ad931126ea233093d87ac3dbc3

tdf#103703 Turn on single print jobs for collated prints by default

It will be available in 5.3.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 4 QA Administrators 2017-05-31 10:50:58 UTC Comment hidden (obsolete)
Comment 5 QA Administrators 2017-06-28 12:34:11 UTC Comment hidden (obsolete)
Comment 6 Xisco Faulí 2019-01-09 10:20:03 UTC
This shouldn't be set to RESOLVED INSUFFICIENTDATA...
Changing it to RESOLVED FIXED since there's a commit fixing this...
Comment 7 Commit Notification 2019-01-10 17:26:03 UTC
Gabor Kelemen committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/2117257eafac507b6af0be86ae62261fd192089a%5E%21

tdf#107416 Revert "tdf#103703 Turn on single print jobs for collated prints"

It will be available in 6.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 8 Cor Nouws 2019-01-10 19:53:11 UTC
(In reply to Dr. Martinus from comment #0)

> 1|2 3|4 5|1 2|3 4|5 1|2 3|4 5|1 2|3 4|5
> 
> It should be:
> 
> 1|2 3|4 5|- 1|2 3|4 5|- 1|2 3|4 5|- 1|2 3|4 5|- 

Writer does automatically insert balk pages for that goal.
Tools > Options > Writer > Print .. Other: Print automatically inserted blank pages.
Comment 9 Cor Nouws 2019-01-10 19:56:45 UTC
(In reply to Cor Nouws from comment #8)
> (In reply to Dr. Martinus from comment #0)
> 
> > 1|2 3|4 5|1 2|3 4|5 1|2 3|4 5|1 2|3 4|5
> > 
> > It should be:
> > 
> > 1|2 3|4 5|- 1|2 3|4 5|- 1|2 3|4 5|- 1|2 3|4 5|- 
> 
> Writer does automatically insert balk pages for that goal.
> Tools > Options > Writer > Print .. Other: Print automatically inserted
> blank pages.

Thus basically I would suggest: notABug ..?
Comment 10 Commit Notification 2019-01-11 12:52:59 UTC
Gabor Kelemen committed a patch related to this issue.
It has been pushed to "libreoffice-6-1":

https://git.libreoffice.org/core/+/d8d148c96d7cdd96948240ac30b3aeacfb5aa7ca%5E%21

tdf#107416 Revert "tdf#103703 Turn on single print jobs for collated prints"

It will be available in 6.1.5.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 11 Commit Notification 2019-01-14 09:26:48 UTC
Gabor Kelemen committed a patch related to this issue.
It has been pushed to "libreoffice-6-2":

https://git.libreoffice.org/core/+/3b10c732a83122198886ec16986110d5ad668a1e%5E%21

tdf#107416 Revert "tdf#103703 Turn on single print jobs for collated prints"

It will be available in 6.2.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 12 Commit Notification 2019-01-21 17:14:57 UTC
Gabor Kelemen committed a patch related to this issue.
It has been pushed to "libreoffice-6-2-0":

https://git.libreoffice.org/core/+/72d6916a05e7862e6b7ac033f8e74feed931e3bc%5E%21

tdf#107416 Revert "tdf#103703 Turn on single print jobs for collated prints"

It will be available in 6.2.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 13 Gabor Kelemen 2019-01-23 10:34:11 UTC
(In reply to Cor Nouws from comment #8)
> (In reply to Dr. Martinus from comment #0)
> 
> > 1|2 3|4 5|1 2|3 4|5 1|2 3|4 5|1 2|3 4|5
> > 
> > It should be:
> > 
> > 1|2 3|4 5|- 1|2 3|4 5|- 1|2 3|4 5|- 1|2 3|4 5|- 
> 
> Writer does automatically insert balk pages for that goal.
> Tools > Options > Writer > Print .. Other: Print automatically inserted
> blank pages.

Hi Cor

I think I start to understand things. Better late than never :).

Yes, the solution would be to use this setting.
But: in bug #42099 we turned this default off. I think bug #42099 was misunderstood, and was about the problem solved in bug #89708.

This one here is about the regression caused by bug #42099
So I'd suggest to revert that one and enable the Print automatically inserted blanks by default setting by default.
Comment 14 Cor Nouws 2019-03-11 22:35:40 UTC
(In reply to Gabor Kelemen from comment #13)

> This one here is about the regression caused by bug #42099
> So I'd suggest to revert that one and enable the Print automatically
> inserted blanks by default setting by default.
Basically you would want to have duplex printing and mail merge with "print automatically inserted blank pages" turned on, and other printing not.
If that is reached by reverting #42099, it is fine to do so.
Comment 15 Commit Notification 2019-08-07 08:12:44 UTC
Gabor Kelemen committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/2343372851cc98daafe6899382792c56d941bcdd%5E%21

tdf#103703 Print automatically inserted blank pages by default

It will be available in 6.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 16 theenterprisemagazine 2019-08-07 08:19:02 UTC Comment hidden (spam)
Comment 17 trackersphere 2019-08-07 08:33:03 UTC Comment hidden (spam)
Comment 18 naturalhealthbase 2019-08-07 08:46:24 UTC Comment hidden (spam)
Comment 19 health-news-blog 2019-08-07 08:55:56 UTC Comment hidden (spam)
Comment 20 AutoSmithCars 2019-09-25 13:15:50 UTC Comment hidden (spam)
Comment 21 investconcept 2019-09-26 06:09:49 UTC Comment hidden (spam)
Comment 22 nomanseo0 2020-01-20 07:43:20 UTC Comment hidden (spam)
Comment 23 nomanseo0 2020-01-20 07:43:44 UTC Comment hidden (spam)
Comment 24 Gacha 2 2020-08-01 09:02:47 UTC Comment hidden (spam)