Bug 103733 - [UI] Menus and toolbars of master documents have not been reorganized as for Writer documents
Summary: [UI] Menus and toolbars of master documents have not been reorganized as for ...
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.2.3.3 release
Hardware: All All
: medium normal
Assignee: Yousuf Philips (jay) (retired)
URL:
Whiteboard: target:6.0.0 target:6.1.0
Keywords:
Depends on:
Blocks: Writer-Menus Writer-Master-Doc Writer-Toolbars
  Show dependency treegraph
 
Reported: 2016-11-06 07:21 UTC by pierre-yves samyn
Modified: 2018-02-13 06:42 UTC (History)
8 users (show)

See Also:
Crash report or crash signature:


Attachments
Screenshot with both main menues. (7.27 KB, image/png)
2016-11-06 12:46 UTC, m.a.riosv
Details

Note You need to log in before you can comment on or make changes to this bug.
Description pierre-yves samyn 2016-11-06 07:21:57 UTC
Description:
Hi

Since version 5.1 the reorganization of menus is underway. It was not brought to the master documents

Steps to Reproduce:
1. File> New> Master Document


Actual Results:  
You get "old" menus.

Expected Results:
Menus should be the same as for a "standard" Writer document


Reproducible: Always

User Profile Reset: Yes (fresh install: reset profile & clean registry)

Additional Info:
Platform: Windows 7/64 & Version: 5.2.3.3
Build ID: d54a8868f08a7b39642414cf2c8ef2f228f780cf
CPU Threads: 2; OS Version: Windows 6.1; UI Render: default; 
Locale: fr-FR (fr_FR); Calc: group


User-Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:49.0) Gecko/20100101 Firefox/49.0
Comment 1 Bastián Díaz 2016-11-06 08:36:34 UTC
(In reply to pierre-yves samyn from comment #0)
> Description:
> Hi
> 
> Since version 5.1 the reorganization of menus is underway. It was not
> brought to the master documents
> 

Do you refer to the toolbars? I also noticed a strange behavior with toolbars using master documents. The best example is enable the standard toolbar (single bar mode) and then when you open a master document, the toolbar disappears.

The same applies to the development version (5.3 alpha). the interface for a common document vs. a master document don't correspond in any combination It is especially noticeable when activating the experimental features and change the ui modes.
Comment 2 m.a.riosv 2016-11-06 12:46:43 UTC
Created attachment 128526 [details]
Screenshot with both main menues.
Comment 3 Thomas Lendo 2017-05-22 21:44:32 UTC
I also hate that--every time opening a master document--the toolbars are different to normal Writer toolbars. Every single customization in Writer has to be done twice.

But I think there are many people who would hate to have the same toolbars in Writer documents and Writer master documents.

At least the evolving of the Writer document toolbary should also be done in the Writer master document toolbars.

Adding Jay as he is highly involved in menu and toolbar reorganization.
Comment 4 Yousuf Philips (jay) (retired) 2017-05-24 19:19:13 UTC
(In reply to Thomas Lendo from comment #3)
> Adding Jay as he is highly involved in menu and toolbar reorganization.

Yes the menus and toolbars from Writer can be copied over to Master Docs quite easily if i get an okay from those familiar with it. @Cor, @Stuart, @Regina: Is there anything in the menus and toolbars of Master Documents that should be different from Writer?
Comment 5 pierre-yves samyn 2017-05-25 05:14:29 UTC
Hi

Thank you for working on it.

(In reply to Yousuf Philips (jay) from comment #4)
> Is there anything in the menus and toolbars of Master Documents
> that should be different from Writer?


I do not know if it's in the perimeter of your question, but, for the record, there is the navigator's toolbar: Toggle Master View - Edit - Update - Insert, etc.

Best regards
Pierre-Yves
Comment 6 Thomas Lendo 2017-09-04 09:18:23 UTC
As Writer master documents are only Writer documents that contain another Writer documents, there should be no difference between both when using the same features. (LibO help citation: "A master document lets you manage large documents, such as a book with many chapters. The master document can be seen as a container for individual LibreOffice Writer files.")

I found no difference in menus and toolbars or special commands that were used for master documents. If there are special commands available, I never used it in the last >10 years. :-)

In comment 5 it was said that "Toggle Master View" in the Navigator is the only master document specific command. But that's a Navigator feature and has nothing to do with menus and toolbars, I assume.

I also found that the Page deck of the sidebar is missing in master documents, see bug 112205.
Comment 7 sophie 2017-09-07 12:18:15 UTC
Hi Jay, +1 on my side for Pierre-Yves request, there should be no differences between master and normal documents - Sophie
Comment 8 Yousuf Philips (jay) (retired) 2017-09-08 15:00:59 UTC
patch is in - https://gerrit.libreoffice.org/42108
Comment 9 Heiko Tietze 2017-09-21 13:12:24 UTC
(In reply to Yousuf Philips (jay) from comment #8)
> patch is in - https://gerrit.libreoffice.org/42108

Rebased now but didn't review. Please keep an eye on this topic.
Comment 10 Heiko Tietze 2017-09-21 13:15:09 UTC
(In reply to Heiko Tietze from comment #9)
> Rebased now but didn't review. Please keep an eye on this topic.

Rebasing was not possible due to a merge conflict. Please resubmit.
Comment 11 Commit Notification 2017-09-23 10:52:12 UTC
Yousuf Philips committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=183c041e4c474cdce6bf43484684607f19018954

tdf#103733 Unify master doc menu and toolbars with writer

It will be available in 6.0.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 12 Thomas Lendo 2017-09-24 20:05:41 UTC
Set to VERIFIED FIXED.

Version: 6.0.0.0.alpha0+
Build ID: 722161e26437b25adc449f773836d369bd0cb081
CPU threads: 4; OS: Linux 4.10; UI render: default; VCL: gtk3; 
Locale: de-DE (de_DE.UTF-8); Calc: group
moggi's auto updater build, 2017-09-24

Thank you very much, Jay!
Comment 13 Thomas Lendo 2017-11-03 12:07:29 UTC
Maybe before the first RC of 6.0, the toolbars and menus of Writer UI should be transferred to Writer master UI again due to some big changes like special character widget and Form menu.
Comment 14 Commit Notification 2018-02-13 06:42:22 UTC
Yousuf Philips committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=18d78dac064bdb16c54c89563d8df22803e84083

tdf#103733 Unify writer master doc menu with writer

It will be available in 6.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.