Download it now!
Bug 103753 - create a new sheet while cell is in edit mode
Summary: create a new sheet while cell is in edit mode
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.1 all versions
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisectRequest, regression
Depends on:
Blocks: Sheet
  Show dependency treegraph
 
Reported: 2016-11-07 10:04 UTC by Dietmar
Modified: 2017-11-21 09:51 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Dietmar 2016-11-07 10:04:45 UTC
Description:
if in calc one cell is in edit mode and a new sheet is created, the content of that cell is transfered to the new sheet.

Steps to Reproduce:
1. edit cell (F2)
2. click to create new sheet
3. new sheet is created

Actual Results:  
content is transfered to new sheet

Expected Results:
content stays in the old sheet


Reproducible: Always

User Profile Reset: No

Additional Info:


User-Agent: Mozilla/5.0 (X11; Linux x86_64; rv:49.0) Gecko/20100101 Firefox/49.0
Comment 1 Xisco Faulí 2016-11-07 13:47:13 UTC
Confirmed in

Version: 5.3.0.0.alpha1+
Build ID: 8a2a3f1032b4e60f7607e3ecb1ff99a6bb9af7f9
CPU Threads: 4; OS Version: Linux 4.2; UI Render: default; VCL: gtk3; Layout Engine: new; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group

and 

Version 4.1.0.0.alpha0+ (Build ID: efca6f15609322f62a35619619a6d5fe5c9bd5a)

but not in

LibreOffice 3.3.0 
OOO330m19 (Build:6)
tag libreoffice-3.3.0.4

thus, this is a regression
Comment 2 brucehohl 2016-11-08 01:33:24 UTC
Using the steps noted I was not able to reproduce the error with:
Version: 5.2.3.2
Build ID: 1:5.2.3~rc2-0ubuntu1~xenial1
CPU Threads: 2; OS Version: Linux 4.4; UI Render: default; 
Locale: en-US (en_US.UTF-8); Calc: single
Comment 3 Dietmar 2016-11-09 11:40:27 UTC
confirmed in 
Version: 5.2.3.3 (x64)
Build-ID: d54a8868f08a7b39642414cf2c8ef2f228f780cf
CPU-Threads: 4; BS-Version: Windows 6.19; UI-Render: Standard; 
Gebietsschema: de-DE (de_DE); Calc: group
Comment 4 Aron Budea 2017-06-05 02:59:20 UTC
Not reproducible with 5.4beta1 anymore for me.
Comment 5 tagezi 2017-11-21 09:51:17 UTC
I cannot confirm in Version: 5.4.2.2