Download it now!
Bug 103806 - Slide sorter doing unwanted deletion and duplication when moving slides
Summary: Slide sorter doing unwanted deletion and duplication when moving slides
Status: RESOLVED DUPLICATE of bug 56864
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
4.1 all versions
Hardware: x86-64 (AMD64) All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: regression
Depends on:
Blocks: Slide-Sorter
  Show dependency treegraph
 
Reported: 2016-11-09 10:19 UTC by Marc SCHAEFER
Modified: 2018-07-05 11:39 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
sample (1.11 MB, application/vnd.oasis.opendocument.presentation)
2016-11-09 19:16 UTC, Xisco Faulí
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Marc SCHAEFER 2016-11-09 10:19:02 UTC
Description:
With 4.4.3.2 or with 5.1.5.2-2 or 5.2.3.3-3, moving a slide will do bizarre things, such as duplicate another nearby one while deleting the moved slide.

Steps to Reproduce:
1. Open a presentation in loffice
2. Go to the Slide sorter
3. Move the slide number 40 between 37 and 38

Actual Results:  
Slide 40 disappears, a copy of slide 37 is placed between 37 and 38

Expected Results:
Slide 40 should be between 37 and 38


Reproducible: Always

User Profile Reset: No

Additional Info:
See the document here:

https://www.alphanet.ch/~schaefer/tmp/LOFFICE-BUG/slide-sorter/encodage.odp


User-Agent: Mozilla/5.0 (X11; Linux x86_64; rv:49.0) Gecko/20100101 Firefox/49.0
Comment 1 Marc SCHAEFER 2016-11-09 10:28:31 UTC
Also fails the same way on Microsoft Windows 7 with loffice 5.2.3.3
Comment 2 Xisco Faulí 2016-11-09 19:16:03 UTC
Created attachment 128624 [details]
sample
Comment 3 Xisco Faulí 2016-11-09 19:21:24 UTC
Confirmed in

- Version: 5.3.0.0.alpha1+
Build ID: 8dc495c93239739629683bb29e4110f5c57c94f0
CPU Threads: 4; OS Version: Linux 4.2; UI Render: default; VCL: gtk2; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group

- Version: 4.4.0.0.alpha0+
Build ID: df9145abe89ae698287facdeb41c0dd3b7758190

- Version 4.1.0.0.alpha0+ (Build ID: efca6f15609322f62a35619619a6d5fe5c9bd5a)

but not in

LibreOffice 3.3.0 
OOO330m19 (Build:6)
tag libreoffice-3.3.0.4
Comment 4 Buovjaga 2018-07-05 11:36:28 UTC
No problem anymore with 6.0. I first confirmed with 5.0 that I could repro.

Version: 6.0.4.2 (x64)
Build ID: 9b0d9b32d5dcda91d2f1a96dc04c645c450872bf
CPU threads: 4; OS: Windows 10.0; UI render: default; 
Locale: fi-FI (fi_FI); Calc: group
Comment 5 Buovjaga 2018-07-05 11:39:51 UTC

*** This bug has been marked as a duplicate of bug 56864 ***