Download it now!
Bug 103850 - Different vertical text alignment behavior between Firefox and LibreOffice
Summary: Different vertical text alignment behavior between Firefox and LibreOffice
Status: RESOLVED DUPLICATE of bug 103784
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
5.3.0.0.alpha1+
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: CJK Regressions-HarfBuzz
  Show dependency treegraph
 
Reported: 2016-11-11 04:30 UTC by Volga
Modified: 2016-11-17 04:13 UTC (History)
0 users

See Also:
Crash report or crash signature:


Attachments
screenshot from LibreOfficeDev (56.93 KB, image/png)
2016-11-11 04:49 UTC, Volga
Details
Screenshot from Firefox (53.04 KB, image/png)
2016-11-11 04:50 UTC, Volga
Details
Test file (8.79 KB, application/vnd.oasis.opendocument.text)
2016-11-11 04:54 UTC, Volga
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Volga 2016-11-11 04:30:29 UTC
Description:
Recently I found the text alignment for Latin and CJK Ideographs are different between Firefox and LibreOffice when I use vertical layout

Steps to Reproduce:
1. Open https://wymeditor.github.io/wymeditor/dist/examples/01-basic.html in Firefox, input 世界你好 Hello, World! in there and use writing-mode: vertical-rl property
2. Create Writer Document in LibreOffice, input the same text, then using LTR (vertical) direction for the page.

Actual Results:  
On Firefox the left edge of CJK Ideographs aligned with beard line (https://en.wikipedia.org/wiki/Descender), on LibreOffice, the left edge of CJK Ideographs aligned with baseline.

Expected Results:
When vertical layout enabled, CJK texts should always align with beard line. See my attachment.


Reproducible: Always

User Profile Reset: No

Additional Info:
Version: 5.3.0.0.alpha1+
Build ID: 05d2a66955f8a6552a79696474386ca9f45f9ef2
CPU Threads: 4; OS Version: Windows 6.2; UI Render: default; Layout Engine: new; 
TinderBox: Win-x86@62-merge-TDF, Branch:MASTER, Time: 2016-11-07_23:34:48
Locale: zh-CN (zh_CN); Calc: group


User-Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:49.0) Gecko/20100101 Firefox/49.0
Comment 1 Volga 2016-11-11 04:49:03 UTC
Created attachment 128651 [details]
screenshot from LibreOfficeDev
Comment 2 Volga 2016-11-11 04:50:54 UTC
Created attachment 128652 [details]
Screenshot from Firefox
Comment 3 Volga 2016-11-11 04:54:46 UTC
Created attachment 128653 [details]
Test file
Comment 4 Volga 2016-11-11 05:42:37 UTC
You can also see the sample from here:

https://userscloud.com/tqvelmv274wt
Comment 5 Volga 2016-11-17 04:13:01 UTC

*** This bug has been marked as a duplicate of bug 103784 ***